Pourquoi la performance vidéo de Chrome se dégrade-t-elle substantiellement après son réveil en 10.10?

9

Remarque: Pour plus de détails, dont certains ne sont peut-être pas corrects, voir cet article .

Lors du premier démarrage de mon ordinateur, les performances vidéo (à la fois HTML5 H.264 natif dans YouTube et Vimeo et dans Flash) dans Chrome sont parfaitement raisonnables. L'utilisation du processeur reste lente, tout fonctionne correctement et la vidéo est lisse.

Mais pour quelque raison que ce soit, si je suspends mon ordinateur, réveille-le, la performance vidéo diminue. La vidéo HTML5 plein écran est agitée au mieux, et la vidéo Flash plein écran met fondamentalement mon ordinateur à genoux (je parle moins d'une image par seconde, et un délai de 5 secondes pour quitter l'écran après avoir frappé Esc). Redémarrer Chrome ne résout pas ce problème - Je dois redémarrer complètement ma machine avant que les performances ne reviennent à la normale. Les performances vidéo dans d'autres applications, telles que Movie Player, ne semblent pas être affectées par le cycle de suspension - il ne s'agit que de Chrome.

J'utilise un Lenovo X201, avec un chipset graphique Intel GMA HD, et des composants Intel tout autour (je n'ai pas besoin de pilotes propriétaires). Cela ne s'est pas produit en 10.04 et je ne pense pas que cela aurait pu se produire. Il est possible qu'une version de Chrome ait pu provoquer cela, mais elle semble moins probable qu'une régression entre 10.04 et 10.10.

Des idées?

EDIT: En réponse au commentaire de Georg, se connecter et se déconnecter ne résout pas le problème. Redémarrer Compiz ou passer à Metacity (du moins en utilisant "compiz / metacity --place & amp; disown" - est-ce que je le fais bien?) N'aide pas (en fait, cela semblait aider quelque peu avec Flash, mais t été capable de reproduire cela). Je ne suis pas sûr de GDM - quand j'utilise "sudo restart gdm", je suis renvoyé sur le shell Linux (?), Dont je ne sais absolument pas comment sortir.

En outre, je tiens à préciser que ce n’est pas seulement un cas d’éclatement de Flash (c’est le cas, mais cela n’est pas le cas). Je vois le même problème général avec les vidéos HTML5, et Flash fonctionne mieux sur mon Nexus One que sur mon ordinateur portable Core i5. Il se passe quelque chose avec Chrome et / ou 10.10.

    
posée unused 02.11.2010 - 06:19
la source

1 réponse

2

La mise à niveau vers la nouvelle version bêta de Chrome 8 a complètement corrigé mon problème avec la vidéo HTML5, car elle a ajouté l’accélération GPU. Flash est toujours aussi lent, mais il fonctionne assez bien dans Firefox, ce qui ne me pose pas de problème car j'utilise Firefox comme navigateur. Nous avons eu Flash désactivé dans Chrome 99% du temps pendant un certain temps).

Ce n’est pas vraiment une réponse à un aveu de défaite, mais en attendant une solution réelle, je pense que c’est probablement le conseil le plus judicieux pour la plupart des gens.

    
réponse donnée unused 05.11.2010 - 19:54
la source

Lire d'autres questions sur les étiquettes