Pas de connexion Internet sur Virtualbox (Windows 7 en tant qu'invité, Ubuntu 13.04 en tant qu'hôte)

51

Internet fonctionne parfaitement sur l'hôte (Ubuntu 13.04, 32 bits, entièrement mis à jour) mais ne peut pas se connecter à Internet sur l'invité Windows 7 (sous Virtualbox 4.2). J'ai essayé NAT et Bridge Network - aucun n'a fonctionné. J'ai eu une connexion internet dans l'OS invité il y a quelques mois, mais je n'ai pas essayé la virtualbox depuis et maintenant c'est parti pour une raison quelconque. Je vous serais reconnaissant si quelqu'un pouvait m'aider à reconnecter le système d'exploitation Windows en ligne (sans avoir à formater mon ordinateur ou à désinstaller et réinstaller le système d'exploitation invité). Merci!

    
posée Ben 21.10.2013 - 13:21
la source

6 réponses

62

J'avais le même problème sur Ubuntu 12.10 64bit en utilisant Virtualbox 4.2.22. Voici les mesures que j'ai prises pour résoudre mon problème:

  1. Ouvrir Gestionnaire Virtualbox
  2. Sélectionnez la machine sur laquelle vous ne pouvez pas accéder à Internet dans le volet gauche
  3. Cliquez sur le bouton Paramètres dans le menu supérieur
  4. Cliquez sur Réseau dans le volet gauche de la fenêtre de configuration
  5. Passé à Adaptateur ponté dans le menu déroulant Attaché à
  6. Sélectionnez le nom de la carte réseau que vous utilisez actuellement sur votre ordinateur hôte. J'utilise sans fil alors j'ai choisi eth0 qui est mon adaptateur réseau sans fil. Vous pouvez vérifier quel adaptateur vous utilisez actuellement en ouvrant le terminal ( CTRL + ALT + T par défaut) et en exécutant ifconfig . Ce sera probablement l'adaptateur eth qui affichera un inet addr et affichera le transfert de données à côté de octets RX .
  7. Sous Avancé , assurez-vous que la machine utilise le Type d'adaptateur de bureau .
  8. Sous Avancé , assurez-vous que Mode promiscuité est défini sur Autoriser les ordinateurs virtuels .
  9. Sous Avancé , vérifiez que l'option Câble connecté est activée
  10. Cliquez sur OK pour enregistrer vos modifications
  11. Démarrer votre VM

À ce stade, vous devriez pouvoir démarrer un navigateur Web sur votre machine virtuelle et obtenir une connexion. Cette vidéo fournit les informations que j'ai répertoriées ci-dessus, même si elles utilisent un hôte Windows 7 avec un invité Windows Server. .

Ceci est une image montrant un exemple des paramètres dont vous avez besoin (tirés de cette réponse).

    
réponse donnée jakesantos 21.02.2014 - 23:28
la source
2

Pour que le sans-fil fonctionne, dans mes machines de toute façon, l'adresse MAC WiFi dans les paramètres doit correspondre au matériel , et wlan0 doit être sélectionné ).

MODIFIER:

Après avoir acquis beaucoup plus d’expérience avec cela, je trouve:

  1. La connexion réseau initiale est très difficile et incohérente.
  2. Une fois créé, il se reconnecte à chaque fois sans problème.
  3. L'adresse MAC n'est pas nécessaire pour correspondre au matériel (comme indiqué initialement).
  4. En raison de 1., il est préférable de résoudre les problèmes liés à la connexion Internet de la machine virtuelle en supprimant et / ou en modifiant le code MAC, en démarrant la machine virtuelle, en arrêtant, en pontant, etc. / strong>

[/ EDIT]

Voici un bref aperçu:

Cliquez d’abord sur l’icône de votre réseau et sélectionnez Informations de connexion.

Sur la ligne d’adresse matérielle, copiez l’adresse MAC (les paires de six chiffres séparées par deux points).

Collez-le dans un endroit neutre, tel qu'un éditeur de texte, où les deux points peuvent être supprimés (supprimez-les). Copiez les 12 caractères restants restants.

Remarque: Les tentatives de coller le MAC avec les deux-points en attente échoueront.

Avec la dernière version de VirtualBox (VBox) disponible dans * buntu repos, v4.1.12 à ce jour:

Dans VBox, avec la machine virtuelle sélectionnée, cliquez sur Paramètres. Cliquez sur Réseau et sur cette page, généralement sous l'onglet Adaptateur 1, cliquez sur Avancé.

Cliquez sur le menu déroulant dans Attaché à: et sélectionnez Adaptateur ponté. Mettez en surbrillance les données «Mac Address» et supprimez-les. Collez la véritable adresse MAC copiée ci-dessus.

Les paramètres de vérification sont définis comme suit, de haut en bas:

  • Activer l’adaptateur réseau: vérifié
  • Attaché à: Adaptateur ponté
  • Nom: wlan0

Sous 'Avancé'

  • Type d’adaptateur: celui avec "Desktop" dans le nom
  • Mode promiscuité: Autoriser tout
  • Adresse Mac: telle que copiée et collée ci-dessus
  • Câble connecté: vérifié

Notez que dans la fenêtre VM, pour Win7 au moins, le symbole WiFi apparaît différent de ce qu’il est en mode natif. Mais le WiFi fonctionne néanmoins.

    
réponse donnée u2n 24.06.2015 - 21:25
la source
1

J'ai eu le même problème avec une VM VirtualBox (5.9.14) qui fonctionnait précédemment et qui a cessé de fonctionner après un arrêt / un redémarrage. Dans mon cas, l'option VB "cable connected" a été désactivée pour une raison obscure. Activer cela a encore fait que tout fonctionne à nouveau (pas besoin de mode promiscuité dans ce cas puisque je ne fais rien nécessitant ceci - pas de WireShark ou quoi que ce soit de ce genre) Ligne du bas: ne présumez pas que la configuration réseau de votre machine virtuelle est correcte. Si vous avez des problèmes, consultez cette partie de la configuration.

    
réponse donnée jslarochelle 08.08.2016 - 20:40
la source
0

J'ai essayé les solutions ci-dessus mais malheureusement je n'ai pas trouvé de travail.

J'ai essayé ci-dessous la solution mentionnée:

  1. définir NAT Adapter dans les paramètres de boîte virtuelle & gt; Paramètres réseau.
  2. Ajouter "BOOTPRO = DHCP" dans la carte réseau.
  3. Cochez l'option Autoriser le partage Internet dans l'adaptateur de la machine hôte.
réponse donnée Kashyap 10.10.2016 - 15:29
la source
0

Cette solution a fonctionné pour moi:

vi /etc/sysconfig/network-script/ifcfg-enp0s3

Puis changez

ONBOOT = yes

Puis redémarrez.

    
réponse donnée new gust 10.11.2016 - 18:58
la source
0

Si cela fonctionnait bien jusqu'à récemment, mais que votre VM semble avoir perdu la connectivité réseau alors que host semble avoir une connexion Internet normale, essayez peut-être simplement les étapes suivantes.

Etape 1: Cliquez avec le bouton droit de la souris sur l’icône réseau de la machine virtuelle, qui apparaît la plupart du temps dans le coin inférieur droit en mode fenêtré.

Étape 2: Désactivez le bouton "Connect Network Adapter" et, après 10 secondes d'attente, réactivez-le.

    
réponse donnée 9KSoft 15.10.2017 - 21:45
la source

Lire d'autres questions sur les étiquettes