phpmyadmin ne fonctionne pas après l'avoir installé

48

J'utilise ubuntu-11.04 .

J'ai suivi ces étapes sur ce site:

Jusqu'ici mon apache2, php, et mysql fonctionnent bien excepté phpmyadmin… Chaque fois que je lance ceci:

http://localhost/phpmyadmin/

Je reçois cette erreur sur mon navigateur:

  

non trouvé

     

L’URL / phpmyadmin / n’a pas été trouvée sur ce serveur.

     

Serveur Apache / 2.2.17 (Ubuntu) sur le port 80 de localhost

    
posée Moron 01.08.2011 - 04:21
la source

10 réponses

103

Veuillez lire cette section dans le wiki Ubuntu. Vous devrez configurer votre apache2.conf pour que phpMyAdmin fonctionne.

gksu gedit /etc/apache2/apache2.conf

Ajoutez ensuite la ligne suivante à la fin du fichier.

Include /etc/phpmyadmin/apache.conf

Puis redémarrez apache

/etc/init.d/apache2 restart
    
réponse donnée JohanSJA 01.08.2011 - 05:12
la source
12

J'ai essayé différentes façons.

Finalement, ceci de documentation ubuntu a fonctionné pour moi:

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo a2enconf phpmyadmin
sudo service apache2 reload
    
réponse donnée sangharsh 22.09.2015 - 11:29
la source
5

Ubuntu 16.04

Après avoir installé et configuré l'utilisateur et le mot de passe dans mysql et phpmyadmin, exécutez la commande suivante

sudo apt install php-gettext

Travaillé pour moi ...

Edit1 Si vous avez juste besoin de apache, phPmyAdmin et MySQL dans un environnement d’application Web, alors je vous suggère d’examiner les trois applications à installer, puis vous êtes prêt à partir. Voici Link

Installateurs et téléchargements XAMPP | Apache Friends

    
réponse donnée Rajat Verma 03.07.2016 - 08:52
la source
3

Ne paniquez pas! Il suffit d'exécuter le code suivant avec l'autorisation root dans le terminal

sudo ln -s /usr/share/phpmyadmin /var/www
    
réponse donnée Hardik Thaker 13.02.2013 - 14:59
la source
1

J'ai rencontré le même problème, je l'ai corrigé en courant sudo dpkg-reconfigure phpmyadmin

donner un nouveau nom d'utilisateur et mot de passe

    
réponse donnée Tachyons 13.02.2013 - 15:10
la source
0

Vous devez trouver où phpmyadmin est situé, par exemple locate phpmyadmin , certains renverront l'emplacement, tel que /usr/share/phpmyadmin .

Ensuite, vous pouvez créer un lien symbolique comme ceci: sudo ln -s /usr/share/phpmyadmin /var/www

Démarrer Ubuntu 14.04 et plus, /var/www ne fonctionne plus à la place de /var/www/html . Par exemple, sudo ln -s /usr/share/phpmyadmin /var/www/html

Référence: Où placer mon site Web local à partir de la version 2.4.7 d’apache2?

    
réponse donnée Arman Ortega 21.06.2015 - 18:13
la source
0
sudo sed -i '$ a\Include /etc/phpmyadmin/apache.conf' /etc/apache2/apache2.conf && sudo service apache2 restart && sudo apt-get install php-gettext'

Testé et fonctionne. Courir ça devrait le résoudre pour tous ceux qui veulent un liner.

    
réponse donnée Robert Pounder 30.11.2016 - 17:06
la source
0

J'ai essayé toutes les méthodes ci-dessus et elles ne fonctionnaient pas pour moi. Enfin celui-ci a fonctionné.

Ouvrez le terminal et passez au super utilisateur à l’aide de la commande: sudo su

Après avoir installé phpmyadmin en utilisant les instructions données dans lien , ouvrez /etc/apache2/conf-available .

Vous trouverez un fichier nommé phpmyadmin.conf . Copiez-le dans /etc/apache2/conf-enabled . Ou utilisez simplement la commande

sudo cp /etc/apache2/conf-available /etc/apache2/conf-enabled

Redémarrez apache2 ( sudo service apache2 restart ), puis ouvrez le lien localhost / phpmyadmin dans un navigateur.

    
réponse donnée abeginner 23.02.2017 - 22:22
la source
0

enfin ce travail pour Ubuntu 14.04 LTS

sudo ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf-available/phpmyadmin.conf
sudo ln -s /usr/share/phpmyadmin /var/www/html/phpmyadmin
sudo service apache2 restart

tapez maintenant localhost/phpmyadmin dans le navigateur Web.

    
réponse donnée shamsh nezam 12.10.2017 - 08:59
la source
-3

J'étais confronté au même problème.

Vérifiez d'abord si le répertoire appelé /usr/share/phpmyadmin/ existe. Si c'est le cas, déplacez-le simplement vers /var/www/phpmyadmin en exécutant cette commande:

mv /usr/share/phpmyadmin /var/www/phpmyadmin

Ouvrez votre navigateur et ouvrez http://localhost/phpmyadmin . Maintenant ça devrait marcher.

    
réponse donnée Mariyah 26.07.2012 - 08:06
la source

Lire d'autres questions sur les étiquettes