'apt-get' ne fonctionne pas avec Proxy

45

Pour la commande

sudo apt-get update

Je reçois l'erreur suivante:

W: Failed to fetch http://ch.archive.ubuntu.com/ubuntu/dists/maverick-updates/multiverse/binary-i386/Packages.gz  
407  Proxy Authentication Required (The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )

J'utilise Ubuntu 10.10 sous Windows XP en utilisant VirtualBox. Pour les connexions Internet, j'utilise un serveur proxy avec une authentification. J'ai essayé d'utiliser l'outil gnome-network-proxy pour définir les paramètres proxy à l'échelle du système.

Après que /etc/environment a été mis à jour par la variable http_proxy au format http://my_proxy:port/ , il n'y avait pas de données d'authentification.

J'ai vérifié ceci avec Firefox. Le navigateur m'a demandé un identifiant et un mot de passe et tout fonctionnait bien. Ce n'était malheureusement pas le cas pour apt-get. J'ai aussi essayé de faire comme décrit ici . Malheureusement ça ne marche pas.

Peut-il y avoir un lien entre le fait qu’un proxy se trouve dans un domaine Windows, des idées?

Le nom de mon proxy est lien . Est-ce que - est un personnage spécial?

    
posée tommyk 28.01.2011 - 11:23
la source

11 réponses

4

cntlm a une option de découverte qui aide à trouver la configuration appropriée pour fonctionner avec l'authentification NTLM de votre réseau, essayez ceci:

cntlm -I -M http://test.com

copier et coller les résultats dans /etc/cntlm.conf

redémarrer cntlm

    
réponse donnée tommyk 01.02.2011 - 15:54
la source
47

Pour mon réseau d'entreprise, mon administrateur m'a donné le nom du proxy au format:

http://[username]:[password]@[proxy-webaddress]:[port]

Pour notre réseau Windows, notre nom d'utilisateur est au format:

[domain]\[username]

Par exemple:

http://mywindowsdomain\fossfreedom:[email protected]:8080

Ceci a été ajouté au nouveau fichier suivant (il n’existe pas par défaut):

gksudo gedit /etc/apt/apt.conf.d/01proxy

Le texte suivant a été ajouté:

Acquire::http::Proxy "http://mywindowsdomain\fossfreedom:[email protected]:8080";

Si vous utilisez un proxy anonyme, vous n’avez pas besoin de vos identifiants de connexion:

Acquire::http::Proxy "http://askubuntu-proxy.com:8080";

Enregistrez le fichier puis vérifiez que tout va bien avec:

sudo apt-get update
    
réponse donnée fossfreedom 04.04.2012 - 14:23
la source
11

J'ai trouvé que USERNAME et PASSWORD saisis dans l'applet "Network Proxy" ne sont pas stockés dans le fichier apt.conf. Vous devez ajouter manuellement le nom d'utilisateur et le mot de passe dans le fichier /etc/apt/apt.conf.

L'applet "Network Proxy" stocke uniquement le nom d'hôte et le port.

La syntaxe de base est

Acquire::http::proxy "http://User:[email protected]:port/";

Acquire::ftp::proxy "ftp://User:[email protected]:port/";

Acquire::https::proxy "https://User:[email protected]:port/";

Si vous utilisez les noms d’utilisateur et le mot de passe Windows, suivez ces conseils:

User = Domain/Username

(les utilisateurs de Windows utilisent / not \ )

Si vous utilisez un mot de passe Windows fort / complexe avec des caractères spéciaux, vous devez utiliser le codage URL pour les valeurs, par exemple un "@" dans le mot de passe serait "% 40".

    
réponse donnée MneMoth 06.10.2011 - 19:27
la source
8

Essayez de définir http_proxy sur lien

modifier:
Si la configuration de http_proxy ne fonctionne pas, essayez de modifier apt.conf . Dans
Ubuntu apt.conf est fragmenté dans le répertoire /etc/apt/apt.conf.d/ .
Dans ce répertoire edit /etc/apt/apt.conf.d/01ubuntu :

APT {
    Acquire {
        http {
            Proxy "http://user:[email protected]:port";
        };
    };
};

ou essayez de le configurer en utilisant Synaptic: Paramètres - & gt; Préférences - & gt; Réseau
Et puis définissez vos paramètres de proxy dans "Configuration manuelle du proxy".

    
réponse donnée Casual Coder 28.01.2011 - 11:42
la source
3

Je suis derrière un proxy MS ISA et j'utilise le proxy d'authentification Cntlm; dans le apt.conf j'ai 4 lignes; J'ai lu quelque part que la dernière ligne doit être vide, mais je ne suis pas sûr à ce sujet. Cela fonctionne parfaitement:

Acquire::http::proxy "http://127.0.0.1:3128/";
Acquire::ftp::proxy "ftp://127.0.0.1:3128/";
Acquire::https::proxy "https://127.0.0.1:3128/";
    
réponse donnée dEvil 03.06.2011 - 13:57
la source
2
  1. Ouvrez le terminal et ajoutez les lignes suivantes à /etc/apt/apt.conf.

    gksu gedit /etc/apt/apt.conf
    
  2. Ajoutez ces 2 lignes:

    Acquire::http::Proxy "http://user:[email protected]:port/";
    Acquire::ftp::Proxy "http://user:[email protected]:port/";
    
  3. Enregistrez et quittez.

    Maintenant apt-get update et devrait fonctionner derrière un proxy, mais vous remarquerez que quelque chose ne fonctionne toujours pas, c’est-à-dire la commande add-apt-repository .

    Pour pouvoir ajouter un référentiel derrière un proxy, tapez les commandes suivantes:

    # export https_proxy="http://192.168.1.5:8080"
    # sed -i 's/"keyserver.ubuntu.com"/"hkp://keyserver.ubuntu.com:80"/' /usr/share'/pyshared/softwareproperties/ppa.py'
    

    Maintenant, vous pouvez ajouter des référentiels dans Lucid et Natty en utilisant LANG = C add-apt-repository

    Exemple:

    root @ ubuntu: ~ # LANG = C-add-apt-repository ppa: motumedia / mplayer-daily

Via Unixmen

    
réponse donnée donadony 24.02.2012 - 21:32
la source
2

Comment appliquer apt-get update ou installer dans Ubuntu? J'étais derrière un serveur proxy et après l'installation d'Ubuntu, je ne pouvais rien mettre à jour ni installer avec la commande apt-get. Après la recherche, j'ai trouvé que le paquet apt avait été modifié, maintenant il n'y a plus d'apt.conf dans le répertoire / etc / apt.

Ce que j'ai fait pour résoudre ce problème est le suivant:

Ouvrir le terminal et le fichier

sudo -H gedit /etc/bash.bashrc

et ajoutez en bas du fichier ces 2 lignes:

#proxy 
export http_proxy=http://user:[email protected]:port/
export ftp_proxy=http://user:[email protected]:port/

Maintenant, enregistrez et quittez, Vous pourrez maintenant mettre à jour, mettre à niveau ou installer des paquets dans Ubuntu

    
réponse donnée hhlp 28.01.2011 - 14:11
la source
1

Avec un proxy BlueCoat, le format du fichier apt.conf devait pour moi ressembler à:

Acquire::http::proxy "http://Domain%5cUserID:[email protected]:80/";
Acquire::ftp::proxy "ftp://Domain%5cUserID:[email protected]:80/";
Acquire::https::proxy "https://Domain%5cUserID:[email protected]:80/";

^ ^ ^ ^ Ligne blanche après la 3ème ligne proxy, n'entrez pas cette ligne. ^ ^ ^ ^

    
réponse donnée Jason 02.05.2012 - 21:27
la source
1

Celui-ci a fonctionné pour moi !!

(l'ajout de proxy manuellement à partir de l'interface graphique via system-settings- & gt; le réseau, etc. devrait fonctionner) Mais si ne le fait pas et que vous exportez la variable env depuis le terminal:

export http_proxy=http://<your proxy url>:<proxy port>

et encore pour https:

export https_proxy= <usually the same as the http>

Plus important d'ajouter le -E: Pour exécuter sudo apt-get install ou sudo apt-get update , vous devez exécuter:

sudo -E <command>

Le "-E" utilise vos variables d’environnement utilisateur pour la racine (sudo), à savoir le http_proxy / https_proxy que vous venez d’exporter.

J'espère que ça aide :)

    
réponse donnée Kohn1001 05.02.2017 - 10:51
la source
0
  1. Démarrez Synaptic (accédez à Système - & gt; Administration - & gt; Synaptic dans Gnome 2, ou tapez "synaptic" dans le tableau de bord dans Unity).
  2. Dans la barre de menus, cliquez sur Paramètres , puis sur Préférences .
  3. Lorsque la fenêtre Préférences apparaît, cliquez sur l'onglet Réseau .
  4. Sélectionnez le bouton radio Configuration manuelle du proxy et entrez vos informations de proxy.
  5. Pour appliquer les informations d'authentification, cliquez sur le bouton Authentification et entrez le nom d'utilisateur et le mot de passe.
  6. Cliquez sur OK pour fermer la fenêtre d’authentification HTTP.
  7. Cliquez sur OK pour fermer la fenêtre Préférences.
  8. Cliquez sur le bouton Recharger pour mettre à jour les listes de paquets.

Notez que cette modification affectera également Update Manager .

    
réponse donnée N.C. Weber 13.10.2011 - 21:23
la source
0

Cette solution à un trait a fonctionné pour moi:

sudo env http_proxy=http://<ip>:<port> apt-get update
    
réponse donnée Raheel 26.03.2017 - 06:03
la source

Lire d'autres questions sur les étiquettes