Comment se connecter aux réseaux wifi d'entreprise WPA2 / PEAP / MSCHAPv2 qui n'utilisent pas de certificat CA_Cert, comme Eduroam

47

Mon université utilise le cryptage WPA2 Enterprise pour permettre aux étudiants de se connecter à leur réseau sans fil. Dans NetworkManager, j'ai saisi tout ce dont ils avaient besoin

  • Sécurité: WPA & amp; WPA2 Enterprise
  • Authentification: EAP protégé (PEAP)
  • Le certificat de CA n'est pas nécessaire
  • Version PEAP: automatique
  • intérieur authentification: MSCHAPv2
  • Le nom d'utilisateur et le mot de passe sont corrects.

Chaque fois que j'essaie de me connecter, une fenêtre me demande de saisir mon mot de passe encore et encore

    
posée Balraj McCoy 10.04.2013 - 04:44
la source

6 réponses

35

Il y a un rapport de bogue ici: lien

Une solution de contournement consiste à supprimer la ligne

system-ca-cert=true

à partir du fichier de configuration trouvé dans / etc / NetworkManager / system-connections /

    
réponse donnée chionis 15.05.2013 - 08:57
la source
21

Voilà un travail autour de vous.

  1. Ouvrez un terminal ( Alt + F2 ) et exécutez les commandes suivantes:

    cd /etc/NetworkManager/system-connections
    sudo touch SSID #SSID is the name of the profile, e.g. eduroam
    sudo nano SSID
    
  2. Puis éditez le profil "SSID" comme suit:

    [ipv6]
    method=auto
    
    [connection]
    id=SSID #(e.g.EDUroam)
    uuid=9e123fbc-0123-46e3-97b5-f3214e123456 #unique uuid will be created upon creation of this profile
    type=802-11-wireless
    
    [802-11-wireless-security]
    key-mgmt=wpa-eap
    auth-alg=open
    
    [802-11-wireless]
    ssid=SSID
    mode=infrastructure
    mac-address=0A:12:3C:DA:C1:A5
    security=802-11-wireless-security
    
    [802-1x]
    eap=peap;
    identity=studentid123123
    phase2-auth=mschapv2
    password=mypass123123
    
    [ipv4]
    method=auto
    

Modifiez le fichier ci-dessus et cela devrait fonctionner.

    
réponse donnée keith 07.10.2013 - 21:17
la source
7

J'ai eu le même problème au travail, j'ai suivi les instructions et changé le system-ca-cert=false mais je devais aussi aller et changer les paramètres du pilote sans fil une fois les modifications apportées directement. consultez le lien où j'ai reçu les informations ci-dessous

lien

-o<driver> and -O<ctrl>

/usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service

[D-BUS Service]
Name=fi.epitest.hostap.WPASupplicant
Exec=/sbin/wpa_supplicant -u -f /var/log/wpa_supplicant.log
User=root

[D-BUS Service]
Name=fi.epitest.hostap.WPASupplicant
Exec=/sbin/wpa_supplicant -u -onl80211 -O/var/run/wpa_supplicant
User=root
    
réponse donnée user250563 03.03.2014 - 20:29
la source
2

Vous devrez peut-être également spécifier le domaine de votre entreprise en l’ajoutant avant le nom d’utilisateur comme suit: Nom de domaine \ Nom d'utilisateur à côté de commenter / supprimer la ligne mentionnée ci-dessus ..

    
réponse donnée bingorabbit 09.06.2014 - 08:33
la source
0

Je suppose que vous utilisez un certificat auto-signé (vous avez dit: "Le certificat CA n'est pas nécessaire"). Si tel est le cas, assurez-vous que le certificat est approuvé lors de l'établissement de la connexion.

    
réponse donnée Guardian 10.04.2013 - 12:55
la source
0
  1. Essayez de réinitialiser votre mot de passe (en contactant l'administrateur système ou en utilisant un formulaire en ligne pour envoyer le lien de réinitialisation du mot de passe à votre adresse e-mail)
  2. via l'interface graphique du gestionnaire de réseau, modifiez la connexion wifi pour mettre à jour le champ de mot de passe avec le nouveau et enregistrez.
  3. Reconnectez-vous à votre wifi et cela devrait fonctionner maintenant!
réponse donnée Sulliwane 07.09.2017 - 16:49
la source

Lire d'autres questions sur les étiquettes