Comment puis-je résoudre "Échec de la connexion VPN"?

52

Y a-t-il un journal d'erreur pour une tentative de connexion VPN échouée? Tout ce que je reçois, c'est cette notification et je n'ai aucune idée où aller à partir de là.

    
posée Olivier Lalonde 04.12.2010 - 00:05
la source

6 réponses

52

Le journal est écrit dans /var/log/syslog .
Ouvrez gnome-terminal et faites sudo tail -f /var/log/syslog
Cela suivra le fichier (imprime les nouveaux messages du journal du terminal).
Maintenant, essayez de vous connecter au VPN, les messages commenceront alors à apparaître dans le terminal.
Lorsque vous avez fini de suivre le journal, cliquez simplement sur Ctrl + c pour quitter la queue.

On peut ajouter des marqueurs au journal en ouvrant un autre terminal et en faisant quelque chose comme ça:
logger "............... Starting VPN... "

    
réponse donnée kroiz 06.02.2013 - 20:17
la source
9

La nouvelle variante (systemd-) pour obtenir les journaux est

journalctl -u NetworkManager.service
    
réponse donnée Matthias Weiler 22.01.2016 - 10:49
la source
5

Quel type de VPN essayez-vous d'établir?

Est-ce que c'est PPTP (propriétaire Microsoft) ou compatible Cisco?

Le moyen le plus simple serait d’exécuter pptp (pour PPTP) ou vpnc (pour Cisco) à partir d’une console et de voir les erreurs possibles de manière interactive.

Je pense que vpnc est assez simple, il vous suffit de saisir les informations nécessaires (ip de la passerelle, nom du groupe / pass, nom d'utilisateur / pass).

Je n'ai pas réellement utilisé de VPN PPTP, mais quelques informations sur sa configuration peuvent être trouvées ici au cyberciti

    
réponse donnée Pavlos G. 04.12.2010 - 06:22
la source
2

Dans Fedora et les autres distributions systemd sans / var / log / syslog, les journaux VPN sont accessibles avec "sudo journalctl -f"

-f est à suivre.

    
réponse donnée Ray Foss 03.12.2014 - 15:38
la source
0

Je confirme le problème sur Ubuntu 14.04 LTS.

Ajoutez que si vous lancez le vpn manuellement avec la commande suivante, cela fonctionne au moins pour moi:

sudo vpnc --domain "" --local-port 0 --enable-1des mypcffile
    
réponse donnée Stefano Ghezzi 20.01.2015 - 08:37
la source
0

Ouvrez les options Avancé et cochez Utiliser une connexion TCP . Cela a réglé pour moi. Ubuntu 14.04 LTS, OpenVPN.

    
réponse donnée user472251 15.11.2015 - 00:58
la source

Lire d'autres questions sur les étiquettes