Mise à jour de l'échec LTS de 12.04.3 à 14.04.1

8

Cela a probablement déjà été demandé des millions de fois, mais j'ai du mal à mettre à jour mon système Ubuntu de LTS à LTS, maintenant que la mise à niveau vers 14.04.1 est terminée. Mon système continue de me notifier de passer à la dernière version, affirmant que

Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07.  After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.'

Cependant, quand j'exécute sudo do-release-upgrade , Ubuntu dit que je ne dispose pas de mises à jour. En outre, le remplacement du paramètre prompt dans /etc/update-manager/release-upgrades par prompt=normal au lieu de prompt=lts génère l'erreur suivante:

Checking for a new Ubuntu release
404  Not Found [IP: 91.189.91.14 80]
Err Upgrade tool
404  Not Found [IP: 91.189.91.14 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.

Cela me semble étrange car Quantal n’est même pas la version actuelle, alors je ne sais pas pourquoi le système le chercherait.

Les gens ont suggéré d’ajouter l’indicateur -d à la commande do-release-upgrade , mais la documentation indique que cela installera la version de développement de 14.04 que je ne veux pas.

Toute aide serait appréciée pour me permettre de contourner ce barrage routier.

    
posée Noel Forte 31.07.2014 - 07:48
la source

1 réponse

16

Vous devez réinstaller le gestionnaire de mise à jour. Tout d'abord, retirez / purgez-le:

sudo apt-get purge update-manager-core update-notifier-common

Regardez ensuite la sortie de la console. Si cela vous dit que certains répertoires n'ont pas pu être supprimés, supprimez-les manuellement. Dans mon cas:

rm -rf /var/lib/update-manager
rm -rf /var/lib/update-notifier

Si vous utilisez le 13.04 ou une version ultérieure, vous devez également le faire pour effacer les messages de mise à jour mis en cache:

sudo rm /var/lib/ubuntu-release-upgrader/release-upgrade-available

Puis mettez à jour vos sources:

sudo apt-get update

Réinstallez le gestionnaire de mise à jour:

sudo apt-get install update-manager-core update-notifier-common -y

Seulement si vous êtes actuellement sur un LTS et que vous souhaitez passer à la dernière version de LTS, assurez-vous que dans /etc/update-manager/release-upgrades vous avez défini:

Prompt=lts

Sinon (mise à niveau de toute version vers une version plus récente), définissez:

Prompt=normal

Maintenant, dist-upgrade devrait fonctionner:

sudo apt-get dist-upgrade
    
réponse donnée AWM 18.09.2014 - 11:37
la source

Lire d'autres questions sur les étiquettes