Les icônes de la barre d'état système ont disparu après la mise à niveau d'Ubuntu

45

J'ai de nombreuses applications avec des icônes de bac comme davmail, un moniteur matériel. Cette fonctionnalité me manque sur Ubuntu 14.04. Quelqu'un at-il une solution?

Il existe des outils comme l'indicateur Skype, mais j'ai besoin d'une solution générale pour résoudre ce problème afin de pouvoir ajouter des icônes d'application à la barre d'état système.

    
posée Ahmed Daif 28.04.2014 - 13:44
la source

15 réponses

158

Vous devrez peut-être faire deux choses:

1. Installez les bibliothèques sni-qt .

Installez sni-qt (cliquez sur le lien) ou avec sudo apt-get install sni-qt sni-qt:i386 du terminal, puis redémarrez Skype. L'icône du plateau / panneau devrait maintenant être de retour!

  

La raison pour laquelle cette étape est requise est que sni-qt est installé automatiquement par le package Skype du référentiel Ubuntu, mais PAS par le téléchargement direct de Skype deb. Une fois que Skype 4.0 est dans les repos Ubuntu, vous pouvez l'installer à partir de là et cela ne sera plus nécessaire.

2. Vous pouvez également avoir besoin d’une liste blanche pour l’indicateur

Nous ne savons pas pourquoi, mais pour certains systèmes, cette étape supplémentaire est nécessaire avant que l'indicateur ne s'affiche (merci à Bruno Pereira !)

Étapes :

  1. Installez le package dconf-tools (cliquez sur le lien) ou depuis le terminal avec sudo apt-get install dconf-tools

  2. Ouvrez l'éditeur dconf depuis le tableau de bord (ou dconf-editor depuis le terminal):

  3. Dans la barre latérale gauche, utilisez les triangles pour accéder à desktop & gt; unité & gt; panneau . Sur Ubuntu 12.10, vous devez plutôt accéder à com & gt; canonique & gt; unité & gt; panneau . Double-cliquez sur la partie orange [JavaEmbedded...] à droite et ajoutez ,'skype' pour permettre à l'indicateur Skype d'afficher, comme ci-dessous:

  4. Appuyez sur Entrez , fermez l'éditeur dconf , déconnectez-vous et connectez-vous - votre indicateur devrait maintenant être de retour!

réponse donnée ish 15.06.2012 - 08:47
la source
67

Pour que l'icône de la barre d'état Skype s'affiche dans Ubuntu, installez sni-qt package:

sudo apt-get install sni-qt:i386
    
réponse donnée mcFactor 05.08.2014 - 15:02
la source
19

Activer l'icône Skype sur le panneau de notification Unity sur Ubuntu 12.04 LTS

Lorsque vous effectuez une nouvelle installation d'Ubuntu 12.04 (ou toute version avec Unity), vous installez Skype et attendez-vous à ce qu'il fonctionne comme avant. Mais si vous fermez la fenêtre principale, vous remarquerez rapidement que l’icône Skype n’est pas affichée dans le panneau supérieur.

Pour résoudre ce problème, vous devrez exécuter quelques commandes. Alors ouvrez votre terminal et lancez ceci:

gsettings get com.canonical.Unity.Panel systray-whitelist

Vous devriez avoir quelque chose comme ça:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier']

En gros, cela signifie que Skype n’est pas en liste blanche, il n’est donc pas autorisé par défaut à afficher son icône dans la barre des tâches. Nous devons résoudre ce problème. Ajoutez «Skype» à la liste pour que vous ayez quelque chose comme ça:

['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']

Ensuite, enveloppez-le avec des guillemets doubles (") et ajoutez gsettings set com.canonical.Unity.Panel systray-whitelist devant lui. À ce stade, vous devriez avoir quelque chose comme ceci:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

Copiez maintenant ceci dans votre terminal et exécutez la commande. Redémarrez après. Maintenant, vous devriez voir l'icône.

Source entrez la description du lien ici

    
réponse donnée One Zero 19.07.2012 - 15:45
la source
10

Ceci est dû au fait qu’Ubuntu a désactivé la liste blanche depuis la version 13.10. Voici deux options à corriger:

soit

sudo apt-get install libappindicator1

ou

sudo apt-add-repository ppa:gurqn/systray-trusty
sudo apt-get update
sudo apt-get upgrade

Pour plus d'informations: Les icônes de la barre d'état système ne s'affichent pas lien lien

    
réponse donnée Jordan Koplowicz 28.04.2014 - 20:58
la source
9

Je faisais aussi face à ce problème. L'installation du paquet suivant a résolu mon problème.

sudo apt-get install sni-qt:i386

Je suis sur Ubuntu 15.10, sni-qt:i386 était requis pour que l’icône de la barre des tâches apparaisse.

    
réponse donnée mostafiz rahman 16.09.2014 - 16:08
la source
5

peut-être avez-vous besoin d'ajouter une liste blanche à skype dans la zone de notification (je ne suis pas sûr que skype inclue un indicateur)

Le moyen le plus simple d’installer des outils dconf

sudo apt-get install dconf-tools

ou Utilisation du Centre logiciel

Puis appuyez sur alt + f2 et entrez dconf-editor pour voir un programme comme celui-ci:

Accédez à desktop - & gt; unity - & gt; panel et ajoutez les applications que vous souhaitez ajouter à la liste blanche à la fin de la liste (dans votre cas, vous devez ajouter 'Skype') séparées par comas. Au lieu de cela, vous pouvez écrire all sur la liste blanche de toutes les applications pour utiliser la zone de notification.

Vous devrez vous déconnecter et vous reconnecter pour appliquer les modifications.

Plus d’informations: lien

    
réponse donnée zurdo 18.01.2012 - 15:01
la source
4

Voici ce qui a fonctionné pour que je puisse récupérer l’indicateur Skype et Franz sous Ubuntu 16.10 64-bit Unity Desktop

1) J'ai installé sni-qt: i386 comme mentionné ici avec sudo apt-get install sni-qt:i386

2) J'ai installé libappindicator comme mentionné ici avec sudo apt-get install libappindicator1

3) Enfin, j'ai installé le package .deb trouvé à l'adresse lien via le centre logiciel. Comme mentionné ici , ceci a fourni la résolution finale.

    
réponse donnée Elder Geek 11.11.2016 - 22:06
la source
3

Référence

Ici, je vous poste un article qui explique comment inclure Skype dans une liste blanche de la barre d'état système Unity.

J'ai Ubuntu 12.04, ça a fonctionné pour moi!

Détails

En principe, ouvrez un nouveau terminal et exécutez-le:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Wine', 'Update-notifier', 'Skype']"

puis redémarrez Skype.

    
réponse donnée Israel 18.11.2012 - 19:22
la source
2

Si vous utilisez gnome shell, activez cet appel d’extension Status Icon Fixer

Corrige Dropbox, Skype, vlc et autres dans la barre d’état; pas parfait, mais ok.

lien

    
réponse donnée penreturns 24.06.2012 - 17:42
la source
2

Pour moi, le chemin dans l'éditeur dconf était le suivant:

com -> canonical -> indicator -> appmenu -> messages

Puis cliquez sur applications et, en valeur, ajoutez 'skype' . J'utilise Ubuntu 13.10 (64 bits).

    
réponse donnée kmajaa 15.08.2014 - 03:37
la source
2

Une solution qui à partir de décembre 2015 dans Ubuntu 14.04 est d'installer le PPA suivant:

sudo apt-add-repository ppa:fixnix/indicator-systemtray-unity
sudo apt-get update
sudo apt-get install indicator-systemtray-unity

Cela vous donne une flèche dans la barre des tâches sur laquelle vous pouvez cliquer pour afficher vos icônes. Vous pouvez également voir les icônes dans la barre elle-même et les instructions pour cela peuvent être trouvées ici: lien

Pourquoi les autres solutions ne fonctionnent-elles plus? Les mises à jour d'Unity continuent à briser les autres solutions ppa et il semble que personne ne s'engage à les tenir à jour.

    
réponse donnée Planky 15.12.2015 - 22:30
la source
1

Allez dans les options Skype- & gt;

Dans la catégorie Général, cochez la case "Démarrer Skype réduit dans la barre d'état système".

    
réponse donnée upapilot 15.06.2012 - 08:42
la source
1

J'utilise Gnome-Flashback (anciennement Fallback / Classic) avec un panneau tint2. J'ai essayé tous ces correctifs et aucun d'entre eux n'a fonctionné pour moi. J'ai même essayé

sudo add-apt-repository ppa:timekiller/unity-systrayfix
sudo apt-get update
sudo apt-get upgrade

Pas de chance. Même essayé de tuer la teinte 2 et d'utiliser le panneau gnome à la place. Toujours pas d'icônes pour beaucoup, mais pas toutes, de mes applications.

J'ai enfin trouvé une solution tout en cherchant un moyen (spécifique) d’afficher le gestionnaire de réseau dans la barre des tâches ici . Comme j'utilise Cairo-Dock comme lanceur, je viens de modifier toutes les commandes de lancement de mes applications qui ne figuraient pas dans dbus-launch app-launch-command . Où app-launch-command est la commande de lancement régulière pour cette application. A fait de même pour les applications de démarrage et cela fonctionne comme un charme.

    
réponse donnée amadis 19.08.2014 - 05:10
la source
0

Cette solution fonctionne bien avec Ubuntu 17.04

  

Exécutez simplement l'application avec "env XDG_CURRENT_DESKTOP = Unity". Pour   Par exemple, pour démarrer Skype pour Linux, vous utiliseriez:

env XDG_CURRENT_DESKTOP=Unity skypeforlinux
     

Pour rendre le correctif permanent, copiez le fichier de bureau de l’application depuis   / usr / share / applications / vers ~ / .local / share / applications /, puis éditez   le fichier et changez la ligne "Exec" en ajoutant "env   XDG_CURRENT_DESKTOP = Unity "(sans les guillemets) immédiatement après   "Exec=".

Plus de détails sur lien

    
réponse donnée bibocreation 26.04.2017 - 22:50
la source
-2

J'ai eu le même problème. Voici ce que j'ai fait pour le corriger.

Terminal ouvert

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
sudo shutdown -r now
    
réponse donnée WhosUrDaddy 13.11.2014 - 22:25
la source

Lire d'autres questions sur les étiquettes