Comment désactiver le Bluetooth au démarrage du système?

271

Comment puis-je désactiver Bluetooth au démarrage du système?

    
posée Floqqi 16.10.2011 - 23:02
la source

28 réponses

187

18.04+ utilisateurs qui n’ont pas naturellement /etc/rc.local, vous devrez en créer un et le rendre exécutable. Pour faciliter les choses, vous pouvez simplement coller la commande suivante dans un terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Exécutez sudoedit /etc/rc.local et ajoutez ceci avant la ligne avec exit 0 :

rfkill block bluetooth

Vous devriez toujours pouvoir activer Bluetooth via l’applet de la barre supérieure.

Cette devrait fonctionner pour la plupart des systèmes, mais il semblerait qu'il y ait quelques bogues dans l'ACPI du noyau pour Thinkpads. Si vous êtes sur un Thinkpad, ajoutez ce qui suit à /etc/rc.local :

echo disable > /proc/acpi/ibm/bluetooth

Ou consultez ibm-acpi - Pilote ACPI IBM ThinkPad - certains rapports suggèrent qu'ibm-acpi inclut un contrôle Bluetooth (entre autres belles choses). Mais je n'ai pas le matériel, donc je suis complètement incapable de vérifier ces affirmations. Bonne chance.

    
réponse donnée Oli 18.08.2010 - 11:00
la source
67

J'ai trouvé un guide pratique avec une "solution de contournement" propre ici ( lien d'archive pour la postérité)

En fait, changer /etc/bluetooth/main.conf était suffisant pour moi.

De l'article:

Rechercher l'entrée:

InitiallyPowered = true

et changez la valeur en:

InitiallyPowered = false

Cela me suffisait, même si l’article décrit d’autres étapes qui peuvent ou non être nécessaires.

Sur Ubuntu 17.10 et Ubuntu 18.04 , l’option InitiallyPowered a été remplacée par AutoEnable

    
réponse donnée Stepbaer 25.06.2012 - 20:00
la source
23

Pour désactiver le chargement du pilote Bluetooth au démarrage:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

ajouter:

blacklist btusb

L'activer ultérieurement ne devrait être que:

sudo modprobe btusb
    
réponse donnée maco 18.08.2010 - 18:59
la source
16

Étape 1: Accédez au terminal et entrez la commande suivante pour modifier le fichier /etc/rc.local du système:

gksudo gedit /etc/rc.local

Étape 2: Ajoutez la ligne suivante avant la ligne exit 0 :

rfkill block bluetooth
    
réponse donnée Varun 04.05.2012 - 22:44
la source
12

À partir d'ubuntu 16.04, systemd gère les services de démarrage tels que bluetooth ... pour afficher le problème de statut actuel dans un terminal

sudo systemctl status bluetooth.service 

désactiver le bluetooth lors du démarrage, cela

sudo systemctl disable bluetooth.service

puis au prochain redémarrage bluetooth ne sera pas actif ... pour activer le problème Bluetooth

sudo systemctl enable bluetooth.service
    
réponse donnée Scott Stensland 01.08.2017 - 17:08
la source
7

Tapez ce qui suit dans un terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Au bas du fichier, ajoutez la ligne:

blacklist bluetooth

Enregistrez le fichier et redémarrez - Bluetooth devrait maintenant être désactivé.

    
réponse donnée Nathan Osman 16.10.2011 - 23:25
la source
7

Vous pouvez modifier les services démarrés au démarrage à l’aide de BUM .

Installez-le: sudo apt-get install bum

Exécuter: sudo bum

Décochez la case et cliquez sur Apply .

    
réponse donnée desgua 05.05.2012 - 02:09
la source
5

Je pense que le meilleur moyen est d’empêcher le démarrage du service. Il existe une méthode générale pour désactiver les services qui fonctionne parfaitement:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Cela fonctionne pour Ubuntu 13.10 et probablement aussi pour les versions antérieures.

    
réponse donnée Felipe 18.01.2014 - 10:49
la source
5

J'ajoute

"/etc/init.d/bluetooth stop"

dans

"/etc/rc.local" 

avant la commande "exit 0" pour démarrer avec bluetooth désactivé.

    
réponse donnée Saeed Zarinfam 23.08.2012 - 15:00
la source
5

1. bluetooth bloque dans rc.local

Ajoutez cette ligne à la fin du fichier /etc/rc.local juste avant la ligne exit 0 :

rfkill block bluetooth

Cela fera l'affaire, mais uniquement dans les anciennes versions d'Ubuntu utilisant upstart .

2. réactiver rc.local sur systemd

Sous Ubuntu 15.10 avec systemd en tant que gestionnaire de démarrage, le fichier /etc/rc.local n’est plus utilisé par défaut, alors appelez ceci sur un terminal:

sudo systemctl edit --full rc-local

Ce qui ouvre un éditeur. A la fin du fichier, j'ai ajouté:

[Install]
WantedBy=multi-user.target

Ces modifications sont activées par

sudo systemctl reenable rc-local

Maintenant, le fichier /etc/rc.local est utilisé tel que vous le connaissez.

3. désactiver blueman-applet au démarrage

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Maintenant, blueman-applet est visible et vous pouvez le désactiver à partir des programmes de démarrage

4. Redémarrez pour voir l'effet

    
réponse donnée rubo77 10.11.2015 - 13:29
la source
4

Vous pouvez modifier vos paramètres update-rc.d . J'ai utilisé quelque chose de similaire à:

sudo update-rc.d bluetooth remove

Dans Debian Wheezy. Découvrez man update-rc.d pour plus d'informations sur son utilisation.

    
réponse donnée Keith Smiley 13.02.2013 - 16:50
la source
2

Vous pouvez peut-être le désactiver dans les applications de démarrage. Mais ces applications sont masquées par défaut. Afficher les applications de démarrage cachées dans 12.04: Ouvrez le terminal et exécutez ces deux commandes:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Maintenant, vous pouvez décocher Bluetooth. (Ne pas enlever!)

    
réponse donnée schiemanski 05.05.2012 - 10:50
la source
2

Non. Ce n'est pas toujours dans la liste des applications de démarrage. Je pense que la meilleure solution consiste à ajouter la commande rfkill dans le script rc.local ou à définir le paramètre InitiallyPowered dans /etc/bluetooth/main.conf .

    
réponse donnée Robert 05.05.2012 - 02:06
la source
2

1) Installez le package smbios-utils et ajoutez-le à Applications de démarrage avec:

sudo smbios-wireless-ctl --bt 0

2) Dans le type de terminal:

sudo visudo

et ajoutez à la fin du fichier ouvert /etc/sudoers la ligne:

<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Pour activer le bluetooth pendant la session, exécutez le terminal:

sudo smbios-wireless-ctl --bt 1

Cela fonctionne pour moi sur mon Dell D630 avec Ubuntu 13.10

    
réponse donnée victor 15.03.2014 - 16:58
la source
2

Sur Ubuntu 16.04, j'ai simplement désactivé le service de démarrage en utilisant systemctl.

Pour ce faire, ouvrez une fenêtre de terminal et tapez ce qui suit:

sudo systemctl disable bluetooth

Vous pouvez soit redémarrer depuis que le démarrage de bluetooth est désactivé, ou si vous ne souhaitez pas redémarrer et que vous souhaitez arrêter le bluetooth immédiatement, vous pouvez taper:

sudo service bluetooth stop

    
réponse donnée Ken 22.08.2017 - 05:57
la source
2

Nous pouvons désactiver le démarrage automatique Bluetooth de cette façon:

sudo gedit /etc/bluetooth/main.conf

( gedit est mon éditeur favori, vous pouvez le remplacer par xed ou tout ce qui est installé sur votre système.)

Au bas de ce fichier, il y a cette ligne:

#AutoEnable=false

Dé-commentez-le, comme ceci:

AutoEnable=false
    
réponse donnée Shayan 20.02.2018 - 15:47
la source
1

J'utilise le noyau Sputnik , qui a résolu ce problème sur mon Dell Inspiron 14R N4110.

    
réponse donnée Alex Wiedermann 25.09.2012 - 01:53
la source
1

Je pense que vous devriez éditer

/etc/default/bluetooth

et définir

BLUETOOTH_ENABLED=0

pour désactiver le service Bluetooth au démarrage

    
réponse donnée Fabio 06.03.2014 - 21:17
la source
1

Pour ceux d’entre vous où l’insertion de la ligne rfkill block bluetooth (ou toute autre) dans /etc/rc.local ne fonctionne pas, essayez d’inclure la même ligne à la fin de ~/.bashrc

Dans ma configuration (Ubuntu 14.04, Thinkpad W540), aucune option n’a fonctionné pour l’insérer dans /etc/rc.local mais le premier fonctionnait dans bashrc. Notez que cela ne fonctionnera que pour l'utilisateur actuel, pas globalement pour tous les utilisateurs.

    
réponse donnée Sam 19.10.2014 - 14:10
la source
1

Sur Ubuntu Studio 16.04, vous pouvez désactiver l’applet Bluetooth au démarrage dans:

  

Session et démarrage & gt; Application Autostart & gt; Applet Bluetooth

Vous pouvez cliquer ici pour le désactiver.

    
réponse donnée ateymuri 26.08.2016 - 20:05
la source
0

J'ajoute

"/etc/init.d/bluetooth stop"

dans

"/etc/rc.local" 

avant la commande "exit 0" pour démarrer avec bluetooth désactivé.

    
réponse donnée Saeed Zarinfam 23.08.2012 - 15:05
la source
0

Solution pour mon portable

"BIOS - Configuration USB - EHCI2: Désactivé"

EHCI1 est pour les ports USB (en fait, mon ordinateur portable a 2 ports USB 2.0)

    
réponse donnée MSP 27.03.2014 - 19:46
la source
0

Modifier /etc/default/grub :

sudo nano /etc/default/grub

et changez la ligne suivante:

GRUB_CMDLINE_LINUX=""

au lieu de cela:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Ensuite, mettez à jour grub et redémarrez:

sudo update-grub
    
réponse donnée mchid 21.09.2015 - 07:58
la source
0

Cela devrait désactiver le démarrage de Bluetooth sur les systèmes basés sur Debian:

sudo chkconfig bluetooth off

ou sur des systèmes basés sur RedHat

systemctl disable bluetooth.service
    
réponse donnée Stanislav 16.10.2017 - 22:18
la source
0

Si vous utilisez l’applet Bluetooth sur le panneau supérieur (blueman-applet), il possède son propre paramètre qui activera automatiquement Bluetooth, même si vous l’avez désactivé à d’autres endroits (comme / etc / bluetooth / main). .conf ou / etc / default / tlp).

Pour empêcher le Bluetooth d’activer au démarrage à l’aide de la ligne de commande:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Ou via l'interface graphique:

  1. Cliquez sur l’applet Bluetooth & gt; Plugins & gt; PowerManager & gt; Configuration
  2. Décochez Mise sous tension automatique

La prochaine fois que vous redémarrerez, l’applet Bluetooth sera toujours visible mais Bluetooth sera désactivé. Pour l'activer:

Cliquez sur l’applet Bluetooth & gt; Activer Bluetooth

    
réponse donnée bmaupin 27.07.2018 - 19:12
la source
-1

J'ai dû utiliser une méthode brutale pour empêcher le démarrage automatique de bluetoothd au démarrage. J'ai renommé l'exécutable pour qu'il soit introuvable.

    
réponse donnée bluesdiva2001 06.07.2012 - 03:02
la source
-1

Vous pouvez également utiliser cette application graphique qui fait également ce gestionnaire bluetooth

    
réponse donnée deFreitas 27.12.2014 - 14:26
la source
-3

Vous devez le désactiver à partir de la liste des applications de démarrage dans Paramètres système.

Cliquez sur le cog en haut à droite de la barre de menu, puis sélectionnez Paramètres système.

Cliquez sur Démarrer les applications, puis faites défiler la page jusqu’à ce que vous trouviez le réglage Bluetooth, cochez la case et vous avez tous terminé.

    
réponse donnée Mark Rooney 16.10.2011 - 23:13
la source

Lire d'autres questions sur les étiquettes