Comment désactiver le pavé tactile dans Ubuntu 17.10?

9

J'ai récemment mis à jour 17.10 à partir de 17.04 et maintenant je n'ai aucun moyen de désactiver le pavé tactile sur mon ordinateur portable. Lorsque je fais Fn + F9 (dans mon cas), je vois le logo du pavé tactile sur l'écran car il est désactivé, mais ne l'est pas.

ASUS GL752

    
posée dr46ul 27.10.2017 - 13:33
la source

3 réponses

6

J'ai eu le même problème sur mon Asus X555UB, mais j'utilise la commande synclient TouchpadOff=1 dans le script @Legolas. Cela fonctionne pour moi. source

    
réponse donnée Fernando Stefanello 28.10.2017 - 14:53
la source
5

Je ne suis pas sûr pourquoi la clé ne fonctionne pas pour votre ordinateur portable. Mais je peux suggérer une alternative générale.

Placez le code suivant dans un fichier, tel que touchpad_toggle.sh :

#!/bin/bash
STATUS='gsettings get org.gnome.desktop.peripherals.touchpad send-events'
if [ "$STATUS" = "'enabled'" ]
then
    gsettings set org.gnome.desktop.peripherals.touchpad send-events 'disabled'
else
    gsettings set org.gnome.desktop.peripherals.touchpad send-events 'enabled'
fi

Accordez l'autorisation d'exécution du fichier:

chmod +x touchpad_toggle.sh

Ajoutez un raccourci clavier au fichier à partir de Paramètres Périphériques Clavier .

    
réponse donnée Legolas 27.10.2017 - 14:51
la source
4

Sur la base des réponses de Fernando et Legolas, voici un script qui fonctionne pour moi:

#!/bin/bash
synclient -l | grep TouchpadOff | grep 1
if [ $? == 0 ]; then
  synclient TouchpadOff=0
else 
  synclient TouchpadOff=1
fi
    
réponse donnée Konrad Garus 30.10.2017 - 11:42
la source

Lire d'autres questions sur les étiquettes