Comment installer Firefox 32-bit ESR 52 sans désinstaller Firefox 64-bit le 16.04

7

Mon ordinateur a Ubuntu 16.04.2 LTS 64 bits et Firefox 52 64 bits.

Pour l'un des sites Web du gouvernement, parce qu'il utilise le plug-in Java du navigateur pour signer des documents, je dois installer:

  1. Firefox ESR 52 . Firefox 52 ordinaire ne prend plus en charge Java en tant que plug-in de navigateur, car NPAPI a été supprimé ( source ). .
  2. Firefox ESR 52 32 bits . Je sais que Firefox 32-bit ne supporte que Sun Java sous Windows, mais je ne suis pas sûr que ce soit aussi une limitation sur Ubuntu. Si c'est le cas, j'ai besoin de la version Firefox 32 bits et non de la version 64 bits de Firefox. 2

Je sais que je peux installer Firefox 32-bit comme en utilisant:

  1. installez Firefox 32 bits dans le terminal:

    sudo apt install firefox:i386
    

    mais l’installation de Firefox 32-bit désinstallera Firefox 64 bits, que je voudrais conserver.

  2. téléchargez et extrayez Firefox 52 ESR 32 bits depuis 2 .

Y a-t-il d'autres moyens d'installer Firefox ESR 52 32 bits et d'installer Sun Java 32 bits sur Ubuntu 16.04.2 LTS 64 bits sans désinstaller Firefox 52 64 bits?

Voir:

  1. Prise en charge des plug-ins a été supprimé autre que Flash
  2. Télécharger la version de support étendue de Firefox

Merci

    
posée folow 07.03.2017 - 19:08
la source

3 réponses

8

Veuillez essayer cette solution de contournement. Pour moi, les plug-ins comme Java et VLC sont revenus après cela. J'utilise Ubuntu 16.04 64 bit avec Mozilla Firefox 64 bits version 52 (pas ESR) et Java JDK 1.8.0_112

  1. Ouvrez Firefox et tapez à propos de: config dans la barre d’adresse, puis appuyez sur Entrée
  2. Cliquez sur ' J'accepte les risques! '
  3. Cliquez avec le bouton droit de la souris n'importe où et sélectionnez Nouveau & gt; Booléen
  4. Tapez plugin.load_flash_only dans la zone qui apparaît
  5. Définissez la valeur sur false
  6. Effacer tout historique et redémarrer Firefox

J'utilise également divers sites Web du gouvernement qui utilisent le plug-in java et les signatures numériques.

Essayez ceci et faites le moi savoir.

Modifier : Mozilla Firefox 53 supprime l'indicateur plugin.load_flash_only pour que cette solution de contournement ne fonctionne plus.

L’équipe de navigateur Web Pale Moon a annoncé qu’elle poursuivrait indéfiniment le support des plug-ins NPAPI . Pour installer le plugin java dans Pale Moon, lancez-le dans le terminal

sudo ln -s /usr/lib/java/jdk1.8.0_121/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so

J'ai testé le plugin java dans le navigateur Pale Moon. 100% de travail.

    
réponse donnée Lijin 09.03.2017 - 18:32
la source
2

J'utilise la version 16.04 LTS 64 bits
Je télécharge et décompresse Firefox 64 bits (mais la version antérieure - v.45) à partir d’ici lien
Et après cela, je ferme mon Firefox 'standard' précédemment installé et lance le fichier 'firefox' à partir du dossier extrait de l'archive de la version 45.
J'ouvre donc mon site et lance avec succès l'application Java à l'intérieur.

P.S.
J'ai aussi mis à jour Java pour avoir la dernière version:

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer
    
réponse donnée Rib47 14.03.2017 - 11:13
la source
0

Vous pouvez installer une nouvelle version dans un dossier local (tel que ~/applications/firefox_esr/ ), mais vous ne pourrez pas les exécuter simultanément. De ce que j'ai lu sur Site Web de Firefox , la version de Linux n'a pas la même limitation que la version de Windows; donc il vaut mieux simplement utiliser l'ESR 64 bits.

J'avais un problème similaire mais ce qui précède ne suffisait pas à résoudre le problème avec le plug-in Java. Si ce n'est pas le cas, installez SeaMonkey 2,46 (64 bits) et réessayez.

    
réponse donnée Alexandre 09.03.2017 - 04:12
la source

Lire d'autres questions sur les étiquettes