Pas de son dans DELL XPS 13 (Ubuntu 15.04)

7

Aujourd'hui, j'ai installé Ubuntu 15.04 (édition de bureau, 64 bits) sur un ordinateur portable DELL XPS 13 (modèle 9343). Avant l'installation, j'ai mis à niveau le bios de l'ordinateur vers A03. Le noyau que je cours est 3.19.0-15. Je n'ai pas d'audio / son. Voici quelques infos:

[email protected]:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

EDIT: les informations complémentaires du commentaire

$ lspci -nn | grep -i audio
00:03.0 Audio device [0403]: Intel Corporation Broadwell-U Audio Controller [8086:160c] (rev 09)
00:1b.0 Audio device [0403]: Intel Corporation Wildcat Point-LP High DefinitionAudio Controller [8086:9ca0] (rev 03)
    
posée user205661 23.04.2015 - 23:57
la source

1 réponse

10

La solution est ici (grâce à Paul Wall).

Commencez par faire 2 redémarrages à froid dans Ubuntu (redémarrage à froid signifie qu’il faut arrêter et redémarrer sans redémarrer!). Si vous n’avez toujours pas de son, essayez

sudo modprobe snd-soc-rt286

puis sélectionnez la carte son dans Systems Settings / Sound (pour moi, ça a fonctionné).

Si vous souhaitez que le module se charge automatiquement au démarrage, faites

sudo nano /etc/modules

ajoutez ceci au fichier

snd-soc-rt286

enregistrez et fermez-le. Redémarrez et votre son devrait fonctionner sans avoir besoin de sudo modprobe snd-soc-rt286 . Cependant, vous devrez toujours effectuer un redémarrage à froid après avoir utilisé Windows.

    
réponse donnée Benoît Legat 18.05.2015 - 12:09
la source

Lire d'autres questions sur les étiquettes