Impossible de modifier la luminosité dans un ordinateur portable Lenovo

40

Touches de réglage de la luminosité Fn + / & gt; n'ont aucun effet (bien qu'ils soient reconnus par l'environnement), et je ne peux pas modifier la luminosité à l'aide des outils de l'interface graphique. Cela semble être un problème sur Linux lui-même, pas sur l’environnement de bureau.

Je peux changer la luminosité du système d’exploitation Windows, ce n’est donc pas une erreur matérielle.

Détails:
Lenovo B570 (Nom du modèle: 20093)
Carte graphique Intel HD intégrée
Kubuntu 11.04 (Linux 2.6.38-10-generic, KDE 4.7.0), tout est à jour
Aucun pilote graphique propriétaire (Wi-Fi uniquement)

Ce que j'ai essayé:

  • Modifier /etc/default/grubGRUB_CMDLINE_LINUX_DEFAULT : acpi_osi=Linux , acpi_backlight=vendor , nomodeset . Et oui, j'ai fait update-grub
  • Modifiez /etc/X11/xorg.conf (pas de fichier, même après sudo dpkg-reconfigure xserver-xorg )
  • Modifier /proc/acpi/video/VGA/LCD/brightness (pas de fichier)
  • sudo setpci -s 00:02.0 F4.B=XX (sans effet)
  • xbacklight -set XX (" No outputs have backlight property ")

Comment puis-je résoudre ce problème?

    
posée Oleh Prypin 15.08.2011 - 22:33
la source

14 réponses

10

Essayez ceci . Cela a fonctionné pour mon Ubuntu 14, Lenovo B570, Intel Graphics.

Ouvrez un terminal et créez le fichier de configuration suivant, s’il n’existe pas:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

Maintenant, nous devons éditer ce fichier. Vous pouvez utiliser n'importe quel éditeur, terminal ou graphique.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Ajoutez les lignes suivantes à ce fichier:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Enregistrez-le. Déconnectez-vous et connectez-vous.

    
réponse donnée Ignacio 18.07.2014 - 03:33
la source
31

Si les outils de l'interface graphique échouent, essayez d'utiliser le terminal pour cela.

  1. Ouvrez un terminal

  2. Exécuter: ls /sys/class/backlight/*/brightness . Exemple de sortie serait:

    /sys/class/backlight/acpi_video0/brightness
    
  3. Si rien n’est trouvé, le noyau ne supporte pas le contrôle de la luminosité (pilotes manquants?). Sinon, vous pouvez utiliser les commandes ci-dessous (remplacez acpi_video0 en conséquence):

    • Obtenez le niveau de luminosité actuel:

      cat /sys/class/backlight/acpi_video0/brightness
      
    • Obtenez le niveau de luminosité maximal:

      cat /sys/class/backlight/acpi_video0/max_brightness
      

    Ces commandes renvoient des niveaux de luminosité allant de zéro à max_brightness (voir ci-dessus).

  4. Pour modifier le niveau de luminosité, vous devez écrire un numéro dans le fichier brightness . Cela ne peut pas être fait par un éditeur comme gedit . Disons que vous voulez changer votre luminosité à 5, vous devez exécuter:

    echo 5 | sudo tee /sys/class/backlight/acpi_video0/brightness
    

    Si vous souhaitez simplement définir le niveau de luminosité le plus élevé possible:

    sudo tee /sys/class/backlight/acpi_video0/brightness < /sys/class/backlight/acpi_video0/max_brightness
    
réponse donnée Lekensteyn 18.08.2011 - 14:20
la source
9
  1. Installez linux-kamal-mjgbacklight - un correctif pour le noyau Linux.

    • Vérifiez si cela vous convient:
      lsmod | grep ^i915
      Quelque chose comme i915 331519 3 devrait apparaître. S'il n'y a pas de résultat, cela ne fonctionnera pas.
    • sudo add-apt-repository ppa:kamalmostafa/linux-kamal-mjgbacklight
    • Installer les mises à jour ( sudo apt-get update; sudo apt-get upgrade )
  2. Redémarrer.

  3. Vous pouvez maintenant utiliser le terminal pour régler la luminosité, comme proposé par Lekensteyn .
    Si vous pouvez modifier la luminosité avec terminal + sudo , c'est la fin de la réponse.
    Si vous êtes sur le bureau GNOME, la luminosité peut même fonctionner pleinement.

  4. Téléchargez mon script de changement de luminosité , laissez-le s'exécuter et mettez-le dans / usr / local / bin / :
    wget -O brightness http://ideone.com/plain/yPlo5
    chmod +x brightness
    sudo mv brightness /usr/local/bin

  5. Nous devons autoriser l’édition du fichier de luminosité afin que sudo ne soit pas nécessaire partout.
    En outre, nous voulons que le paramètre de luminosité se rétablisse sur le paramètre précédent lors du démarrage du système (il n'est malheureusement pas enregistré par défaut).

    Le script brightness mentionné peut tout gérer (avec le paramètre restore ), ajoutez-le simplement à autorun.
    Pour ce faire, nous allons modifier /etc/rc.local ( sudo nano /etc/rc.local ou n'importe quel éditeur au lieu de nano).
    Ajoutez la ligne suivante avant la ligne exit 0 :
    /usr/local/bin/brightness restore

  6. Il est préférable de redémarrer maintenant.

  7. Le script brightness fonctionne donc. Vous pouvez aller au terminal à tout moment et les taper:

    • brightness - récupère le paramètre de luminosité actuel
    • brightness value - définit la luminosité sur valeur
    • brightness inc step , brightness dec step - augmente ou diminue la luminosité par étape (si elle n'est pas spécifiée, une valeur par défaut est utilisée à partir du fichier de configuration, généralement 10% de la luminosité maximale)
  8. Maintenant, vous voudrez peut-être mapper le changement de luminosité sur vos raccourcis clavier.

    • Définissez XF86BrightnessUp sur brightness inc
    • Définissez XF86BrightnessDown sur brightness dec
  9. Si vous voulez modifier quelque chose, assurez-vous de regarder /etc/bx_brightness.conf
    Vous pouvez modifier l'étape de modification de la luminosité avec brightness inc / dec

Merci à Toz pour son aide inestimable dans cette discussion .

    
réponse donnée Oleh Prypin 21.08.2011 - 15:29
la source
4

Je pense que j'ai trouvé un moyen simple et moins efficace de régler le problème avec intel_backlight à l'aide des règles udev.

J'ai remarqué l'action "change" du sous-système "backlight" lorsque j'appuie sur Fn + Haut / Bas sur mon noyau Lenovo G360 3.2. J'ai donc écrit une règle de /etc/udev/rules.d/99-writeintelbacklight.rules comme ci-dessous:

ACTION=="change", SUBSYSTEM=="backlight", RUN+="/usr/sbin/writeintelbacklight.sh"

Faites en sorte que le script shell /usr/sbin/writeintelbacklight.sh contienne:

#!/bin/bash

intelmaxbrightness='cat /sys/class/backlight/intel_backlight/max_brightness'
acpimaxbrightness='cat /sys/class/backlight/acpi_video0/max_brightness'
scale='expr $intelmaxbrightness / $acpimaxbrightness'
acpibrightness='cat /sys/class/backlight/acpi_video0/brightness'
newintelbrightness='expr $acpibrightness \* $scale'
curintelbrightness='cat /sys/class/backlight/intel_backlight/actual_brightness'
if [ "$newintelbrightness" -ne "$curintelbrightness" ]
then
  echo $newintelbrightness > /sys/class/backlight/intel_backlight/brightness
fi
exit 0

Bien sûr, vous devez faire un sudo chmod +x /usr/sbin/writeintelbacklight.sh .

    
réponse donnée littlebat 08.06.2012 - 08:00
la source
4

Vos touches Fn ne fonctionneront pas, mais vous pourrez assigner toute autre touche pour régler la luminosité.

J'ai essayé plusieurs de ces solutions, mais rien n'a fonctionné pour moi tant que je n'ai pas trouvé ce petit programme d'indicateurs lien . Avec elle, vous pouvez configurer des raccourcis pour contrôler la luminosité, utiliser votre molette de défilement ou sélectionner une liste déroulante dans l’indicateur. J'ai remplacé 'Fn' par 'Win + Alt' qui est très similaire pour mes mains et je peux maintenant l'utiliser avec un clavier externe!

Ajouter PPA et installer:

sudo add-apt-repository ppa:indicator-brightness/ppa
sudo apt-get update && sudo apt-get install indicator-brightness

Les raccourcis clavier doivent être attribués à:

/opt/extras.ubuntu.com/indicator-brightness/indicator-brightness-adjust --up

et

/opt/extras.ubuntu.com/indicator-brightness/indicator-brightness-adjust --down

Note de bas de page: Hors de la boîte, l’indicateur de luminosité reconnaît 7 niveaux de luminosité dans mon système. En ajoutant acpi_backlight=vendor à la ligne GRUB_CMDLINE_LINUX_DEFAULT en /etc/default/grub , ce nombre est augmenté à 16!

    
réponse donnée Joel Ostblom 21.04.2014 - 04:55
la source
4

J'ai un idovoad z400 de Lenovo.

J'ai essayé tous les TIPS listés ci-dessus, sans succès.

J'ai donc trouvé un autre qui fonctionnait très bien:

Mettez la ligne suivante dans / etc / default / grub

GRUB_CMDLINE_LINUX="acpi_backlight=vendor acpi_osi=Linux resume=/dev/sdYY"

YY = zone de swap, utilisez swapon -s pour voir votre swap de périphérique.

Exécuter un update-grub en tant que root

Après le redémarrage, le problème a été résolu.

    
réponse donnée Douglas Mugnos 17.08.2015 - 16:44
la source
2

J'ai un Thinkpad T450s avec des graphiques Nvidia et des pilotes binaires sur Ubuntu 14.04. Pour que le rétro-éclairage fonctionne, j'ai dû modifier le fichier /etc/X11/xorg.conf en ajoutant la ligne suivante à la définition du périphérique intel (le fichier xorg.conf est créé lors de l'installation des pilotes binaires):

Option      "Backlight"  "intel_backlight"

La section complète est maintenant:

Section "Device"
    Identifier "intel"
    Driver "intel"
    BusID "PCI:[email protected]:2:0"
    Option "Backlight" "intel_backlight"
    Option "AccelMethod" "SNA"
EndSection
    
réponse donnée Tor Berg 05.02.2016 - 09:46
la source
1

Cela ne fonctionne pas pour les utilisateurs de KDE tels qu’ils sont écrits dans lien

  

NOTES POUR LES UTILISATEURS DE KDE DESKTOP

     

Utilisateurs de bureau KDE: Ce PPA ne peut pas réparer vos raccourcis de contrôle de rétroéclairage: ce correctif nécessite un module de noyau pour fournir la nouvelle interface /sys/class/backlight/intel_backlight (qui fonctionnera indépendamment de votre bureau) et un module de bureau pour accéder à cette interface. Pour Gnome, le gnome-power-manager mis à jour dans ce PPA le fournit, mais l'équivalent de KDE n'a pas encore été développé. "

Cependant, vous pouvez essayer une solution trouvée ici .

Cela dit de taper le terminal echo XXX | sudo tee /sys/class/backlight/intel_backlight/brightness où XXX est une valeur entière.

Dans mon cas, XXX peut être une valeur de 0 à 4882, mais faites attention: si vous écrivez 0, l’écran sera complètement noir et vous ne verrez rien.

    
réponse donnée Álvaro 21.11.2011 - 19:37
la source
1

Voici un patch que vous pouvez faire.

Créez ce script avec le nom .modificarBrillo.sh (dans mon cas, je l’ai créé dans mon dossier personnel: ~ / .modificarBrillo.sh)

#!/bin/bash
if [ -z "" ]; then
    echo "ERROR: Tiene que introducir un parámetro: \"a\" para aumentar o \"d\" para disminuir"
    exit
else
    if [ "" != "a" ] && [ "" != "d" ]; then
        echo "ERROR: el parámetro de entrada sólo puede ser o \"a\" para aumentar el brillo o \"d\" para disminuirlo"
        exit
    fi
fi
MAX_BRILLO='cat /sys/class/backlight/intel_backlight/max_brightness'
MIN_BRILLO_ABSOLUTO="0"
MIN_BRILLO="100" #el brillo mínimo puede ser 0 pero eso deja la pantalla completamente a oscuras
INTERVALO='expr $MAX_BRILLO - $MIN_BRILLO_ABSOLUTO'
INTERVALO='expr $INTERVALO / 10'
brillo='cat /sys/class/backlight/intel_backlight/actual_brightness'
if [ "" = "a" ]; then
    let "brillo = brillo + INTERVALO"
    if [ "$brillo" -gt "$MAX_BRILLO" ]; then
    let "brillo = MAX_BRILLO"
    fi
else
    let "brillo = brillo - INTERVALO"
        if [ "$brillo" -lt "$MIN_BRILLO" ]; then
            let "brillo = MIN_BRILLO"
        fi
fi
echo "$brillo" | tee /sys/class/backlight/intel_backlight/brightness

Cependant, comme le script précédent a besoin d’une autorisation d’exécution et que / sys / class / backlight / intel_backlight / brightness ne peut être modifié que par root, vous devez exécuter le terminal:

chmod a+x ~/.modificarBrillo.sh
sudo chmod a+w /sys/class/backlight/intel_backlight/brightness'

La dernière commande doit être exécutée à chaque démarrage car les autorisations du fichier de luminosité sont renouvelées avec le démarrage. Pour ce faire, sudo vim /etc/rc.local et ajoutez la commande sudo chmod a+w /sys/class/backlight/intel_backlight/brightness avant la ligne "exit 0"

Enfin, vous devez installer xbindkeys pour associer la touche Fonction pour exécuter le script.

Dans mon cas, j'ajoute les lignes au fichier de configuration ~ / .xbindkeysrc

#Aumentar brillo
"/home/alvaro/.modificarBrillo.sh a"
    m:0x0 + c:233
    XF86MonBrightnessUp 

#Disminuir brillo
"/home/alvaro/.modificarBrillo.sh d"
   XF86MonBrightnessDown

Mais vous pouvez aussi installer le programme xbindkeys-config pour faire le processus graphiquement.

    
réponse donnée Álvaro 24.11.2011 - 14:15
la source
1

Modifiez le fichier /etc/default/grub et ajoutez
pcie_aspm=force acpi_backlight=vendor après
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Alors la ligne entière ressemblera à ceci:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"

Pour plus de détails, consultez ce lien .

    
réponse donnée chirag Hz 13.02.2015 - 21:18
la source
1

J'ai eu le même problème, j'utilise Gnome3.10 dans Ubuntu 14.04 (Unity). J'ai installé tlp pour le contrôle de la température dans mon ordinateur portable. Je viens de supprimer 'tlp' et j'ai redémarré mon système et je suis capable de régler la luminosité de l'écran à l'aide de la fonction (fn) + des touches fléchées.

Cela pourrait aider à le vérifier une fois.

    
réponse donnée Cool Tiger 24.11.2015 - 07:39
la source
1

Avait le même problème (apparemment) avec un Lenovo IP G50-70. - En fait, aucune des touches de fonction n'est apparue pour fonctionner. Finalement, dans le Bios, j'ai trouvé une fonction d'activation / désactivation "Hotkey". Paradoxalement, il était «Enabled» (activé), mais cela permet en fait d'actionner une seule touche pour les touches de fonction. En fait, si vous utilisez la technique traditionnelle «Fn + Function keyX», elles ne fonctionnent pas.

Si vous désactivez la fonction de raccourci clavier dans le Bios, les touches de fonction fonctionnent "comme prévu" (Fn + Function Keyx). - Après cela, toutes les touches de fonction ont fonctionné correctement. Voilà pour le progrès

    
réponse donnée an_other 27.01.2016 - 19:03
la source
1

J'ai dû ajouter ces lignes à grub:

acpi_backlight=vendor acpi_osi=linux thinkpad-acpi.brightness_enable=1

Notez le dernier. C'est celle qui a fait fonctionner les touches de luminosité.

    
réponse donnée Charles Goodwin 06.07.2016 - 12:54
la source
-1

Vous pouvez utiliser ce package pour gérer la luminosité à partir de la ligne de commande (terminal), avec xbacklight .

xbacklight peut être installé dans le Software Center. Ou dans le terminal:

sudo apt-get update && sudo apt-get install xbacklight

vous pouvez utiliser

  • xbacklight -inc <range from 0 to 100> pour augmenter la luminosité avec la valeur < ... >

  • xbacklight -dec <range from 0 to 100> pour diminuer la luminosité avec la valeur < ... >

réponse donnée ElTntawy 16.01.2012 - 23:55
la source

Lire d'autres questions sur les étiquettes