Pas de flux audio A2DP de 12.04 vers le casque Bluetooth [dupliquer]

7

Je souhaite écouter de la musique en streaming depuis Ubuntu en utilisant un casque ( Bose Bluetooth Casque série 2 ). Bien que la connexion Bluetooth soit établie, je n'ai pas pu entendre quoi que ce soit via le casque. Comment puis-je le faire en général (je sais que cela peut sembler brutal mais je n'ai pas beaucoup de connaissances en paramétrage audio sur Linux)?

Lorsque j'utilise mon autre oreillette Bluetooth BlueAnt Q2 ( lien ), le streaming est en cours. Dans l'onglet "Matériel" du panneau de configuration du son (je ne suis pas sûr de savoir comment il s'appelle officiellement, mais voir l'image ci-dessous) montre mon casque.

Cependant, Bose One n'apparaît jamais sur la même fenêtre lorsqu'il est connecté via Bluetooth, à l'exception de quelques secondes après la déconnexion manuelle du casque (ce moment est pris en photo comme l'image ci-dessous). Btw, avec le téléphone Android, ce casque fonctionne très bien.

Le

manuel de Bose indique que

Make sure the device supports A2DP audio streaming.

J'ai donc essayé de déterminer si A2DP était activé sur mon Ubuntu (en référence à Puis-je utiliser mon ordinateur en tant que récepteur A2DP / haut-parleur bluetooth? , en trouvant qu'il est probablement disponible comme le montre le résultat ci-dessous:

$ sdptool search --bdaddr local a2snk
Searching for a2snk on FF:FF:FF:00:00:00 ...
Service Name: Audio Sink
Service RecHandle: 0x10005
Service Class ID List:
  "Audio Sink" (0x110b)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 25
  "AVDTP" (0x0019)
    uint16: 0x102
Profile Descriptor List:
  "Advanced Audio" (0x110d)
    Version: 0x0102
    
posée IsaacS 20.10.2012 - 01:38
la source

4 réponses

6

Je l'ai fait fonctionner de la manière suivante:

Avant d’aller plus loin:

  • Mettez à jour votre système (je cours 13.10)
  • Supprimer blueman
  • Installez pulseaudio-module-bluetooth , pavucontrol (utilitaire de configuration) pulseaudio) et assurez-vous que bluez est installé
  • Supprimer toute entrée "Disable = Socket" ou "Enable = Socket" dans le fichier /etc/bluetooth/audio.conf (éditer avec sudo )

Étapes:

  1. Mettez le périphérique en mode de couplage (même s'il est déjà associé)
  2. Associez l’appareil à votre système en utilisant le gestionnaire Bluetooth par défaut (blueman aurait dû être supprimé) ou si vous êtes déjà associé, passez à l’étape 3
  3. Sélectionnez la connexion A2DP ou Audio Sink pour le périphérique couplé. Si ça échoue, essayez "sudo hciconfig hci0 reset" (où hci0 est votre périphérique bluetooth)
  4. Avec pavutools, sélectionnez a2dp dans l'onglet "configuration" et votre périphérique dans l'onglet "Lecture" / Si a2dp n'est pas sélectionné, essayez pactl list cards short" to get your device id (1,2,3..) puis faites pactl set-card-profile X a2dp où X est votre identifiant de périphérique
  5. En cas d'échec, redémarrez le service avahi-daemon / bluetooth et réinitialisez le périphérique via hciconfig hci0 reset . Vérifiez si le scan est correct avec hcitool scan . Effectuez ensuite les étapes 3 et 4
réponse donnée yilmi 16.12.2013 - 20:00
la source
4

Vous pouvez essayer l'application blueman . Cette application peut vous aider à lire de l'audio via le streaming A2DP. Il vous suffit de marquer le profil de votre appareil comme "Destination audio".

Pour l’installer, utilisez cette commande:

sudo apt-get install blueman

Ouvrez-le en tapant "blueman" dans le tiret.

J'essaierai de mettre à jour la réponse avec la capture d'écran nécessaire plus tard

    
réponse donnée Anwar 22.10.2012 - 20:50
la source
0

voir si vous avez ce paquet installé: pulseaudio-module-bluetooth bien que le fait que votre autre casque BT fonctionne le suggère. C'est un périphérique Mono, donc il peut être soumis à des exigences différentes. Essayez également de vous référer à ma question ici , je viens de poster une solution qui fonctionne pour moi. @Anwar Shah: Retrait de Blueman faisait aussi partie de cette solution, juste pour le mentionner.

    
réponse donnée Bennypr0fane 12.09.2013 - 16:42
la source
0

Utilisez Blueman avec Alsa (les paquets sont beaucoup plus légers que l’audio à impulsions).

Associez et connectez-vous en tant que "dissipateur audio", vous entendrez un "em-pop-b-b-b" sur le casque.

trouvez /etc/alsa.conf ou /usr/share/alsa/alsa.conf et ajoutez-le;

pcm.btheadset {
   type plug
   slave {
       pcm {
           type bluetooth
           device XX:XX:XX:XX:XX:XX
           profile "auto"
       }
   }
   hint {
       show on
       description "BT Headset"
   }
}
ctl.btheadset {
  type bluetooth
}

L’ID de périphérique que vous obtenez de blueman une fois connecté.

par exemple mplayer -ao alsa:device=btheadset mysong.mp3

    
réponse donnée Humpity 17.10.2013 - 20:14
la source

Lire d'autres questions sur les étiquettes