"Bienvenue dans le mode d'urgence!" Pensez que c'est un problème de fsck

60

extrait de journalctl -xb (ce que je pense est faux, au moins en rouge):

-- Unit systemd-fsckd.service has begun starting up.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: /dev/sdb1 contains a file system with errors, check forced.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: /dev/sdb1: Inodes that were part of a corrupted orphan linked list found.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: /dev/sdb1: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: (i.e., without -a or -p options)
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: fsck failed with error code 4.
juli 09 15:40:16 kim-SSD-Sationary systemd-fsck[414]: Running request emergency.target/start/replace
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: systemd-fsck-root.service: main process exited, code=exited, status=1/FAILURE
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: Failed to start File System Check on Root Device.
-- Subject: Unit systemd-fsck-root.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit systemd-fsck-root.service has failed.
-- 
-- The result is failed.
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: Unit systemd-fsck-root.service entered failed state.
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: systemd-fsck-root.service failed.
juli 09 15:40:16 kim-SSD-Sationary systemd[1]: Starting Remount Root and Kernel File Systems...
-- Subject: Unit systemd-remount-fs.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel

Ignoré d’autres erreurs comme: La sonde ACPI PCC a échoué., nvidia pas propidée, etc ...

EDIT: Je peux accéder à mon PC en appuyant sur Ctrl + D , mais c'est agaçant.

    
posée Kim André 09.07.2015 - 16:00
la source

13 réponses

43

Vous pouvez exécuter fsck à partir d'Ubuntu Live.

  1. Allumez votre ordinateur. Démarrez dans un DVD / USB Ubuntu Live.
  2. Après le chargement, ouvrez un terminal en appuyant sur Ctrl + Alt + T
  3. Dans le terminal, exécutez:

    sudo -i
    fdisk -l
    

    fdisk vous indiquera comment votre partition / (root) est appelée. Dans cette question, il s'agit de /dev/sdb1 .

    Ensuite, vous devriez continuer en exécutant:

    umount /dev/sdb1
    fsck -y /dev/sdb1
    poweroff
    

    Si la commande umount se plaint que sdb1 est "non monté", cela ne pose aucun problème. Nous voulions qu'il soit "non monté":).

  4. Retirez le DVD / USB. Allumez à nouveau votre ordinateur pour démarrer à partir du disque SSD.

réponse donnée kyodake 09.07.2015 - 16:52
la source
26

Je ne sais pas si vous avez résolu votre problème. Ce que j'ai fait c'est:

sudo nano /etc/fstab

Supprimez ensuite ce que vous y avez ajouté pour sdb1 , puis exécutez:

sudo systemctl reboot

Il dit qu’il est corrompu, alors je ne sais pas ce qu’il en est, mais j’espère que cela pourrait aider quelqu'un qui ne peut pas faire fonctionner Linux.

    
réponse donnée Akuma 03.07.2016 - 22:34
la source
23

Je viens d'avoir le cas avec le mode d'urgence. Dans ma situation, j'ai suivi un didacticiel d'installation qui proposait de modifier certaines des options pour mes points de montage en /etc/fstab . En supprimant les options supplémentaires, mon serveur a redémarré sans problème.

    
réponse donnée Steffen Nielsen 06.05.2016 - 11:19
la source
15

J'utilise Windows 10 et le système dual boot Ubuntu 16.X.

Je n'ai pas pu monter l'une des partitions ntfs et l'erreur était liée à Windows shutdown / hibernate. J'ai utilisé sudo ntfsfix /dev/sda3 pour résoudre le problème. J'ai pu monter la partition ntfs sda3 mais au redémarrage, Ubuntu commençait en mode d'urgence.
Pour résoudre ce problème, exécutez la commande suivante dans Windows

shutdown /s /t 5

Cela corrige le problème de démarrage d'urgence d'Ubuntu.

    
réponse donnée Khushboo Rani 22.09.2016 - 13:36
la source
12

Les réponses de Khushboo Rani et Cagan Arslan m'a conduit à la solution permanente.

Windows 10 a une fonctionnalité appelée démarrage rapide activé par défaut: lorsque l'utilisateur s'arrête normalement à l'aide du bouton "Arrêter" ou du bouton d'alimentation de l'ordinateur, il sauvegarde le noyau en cours d'exécution et d'autres éléments système sur le disque dur de la même manière que le mode veille prolongée de. Cela oblige également Windows à "verrouiller" la partition d'une manière ou d'une autre tout en empêchant la corruption des données, accidentelle ou malveillante. Cela signifie que Ubuntu ne peut pas monter la partition Windows au démarrage.

Dans mon cas, j'ai des entrées pour la partition Windows dans / etc / fstab, donc cela a rendu Ubuntu impossible à démarrer.

La solution consiste à démarrer Windows, à désactiver le démarrage rapide, puis à arrêter normalement. Maintenant, le problème doit être résolu en permanence!

À partir du lien que j'ai partagé précédemment, désactivez le démarrage rapide sous Windows comme suit:

  1. Lancez le panneau de contrôle
  2. Accédez aux paramètres "Matériel et audio"
  3. Allez dans "Options d'alimentation"
  4. Cliquez sur "Choisir ce que font les boutons d’alimentation"
  5. Cliquez sur "Modifier les paramètres actuellement indisponibles" et autorisez l'accès UAC.
  6. Désélectionnez la case à cocher "Activer le démarrage rapide (recommandé)"
réponse donnée Ben 07.01.2017 - 05:39
la source
5

Dans mon cas (Dual Boot Windows 10), j'ai dû fermer Windows correctement avec la commande (sous Windows):

shutdown /s /t 5

Au redémarrage, Ubuntu se charge sans problème.

    
réponse donnée Cagan Arslan 12.09.2016 - 15:52
la source
2

J'ai juste exactement le même problème, en démarrant Ubuntu LTS 16.04 à partir d'un lecteur flash USB. Faire sysctl default ne l'a pas réparé, fsck clignote rapidement avec la progression de l'analyse msg puis la même invite apparaîtra. Voici ce qui a fonctionné:

fsck -y /dev/sda1
reboot
    
réponse donnée Jimmy Falcon 18.03.2018 - 17:32
la source
1

Si cela se produit dans une VM VirtualBox, il se peut qu’elle n’ait pas réussi à monter l’une des partitions dans /etc/fstab - malheureusement, cela échoue avec "Welcome to emergency mode!" même si ce n'est pas une partition critique - donc, si vous avez ajouté une entrée malformée pour tenter de monter un système de fichiers en utilisant vboxsf , tout le système ne démarre pas sans indiquer clairement le problème principal. / p>

Quoi qu’il en soit, pour résoudre le problème, vous devez soit commenter l’entrée incriminée dans /etc/fstab , soit la modifier pour que mount soit satisfait.

    
réponse donnée Pierz 30.11.2017 - 18:34
la source
1

Comme pour certaines des autres réponses, l’astuce pour moi était de commenter une entrée dans /etc/fstab pour ma partition LVM optionnelle. Je ne sais pas pourquoi il a commencé à se plaindre il y a quelques jours que Ubuntu 17.10 ne pouvait plus trouver la partition LVM, ni pourquoi cela provoquait le démarrage du système en mode "d'urgence".

Une fois l’entrée entrée en commentaire dans /etc/fstab , j'ai redémarré avec succès sur mon bureau. En regardant certains didacticiels, j'ai remarqué que certaines commandes LVM me manquaient, alors j'ai lancé sudo apt-get install lvm2 , qui semble avoir résolu le problème.

Si, comme moi, vous pensez que votre partition LVM est la cause du problème, l’ensemble des commandes que j’ai exécutées était:

sudo lvmdiskscan
sudo apt-get install lvm2
sudo lvmdiskscan
sudo lvdisplay
sudo vi /etc/fstab
sudo vgchange -a y
sudo mount -a

Je ne suis pas sûr que tout cela soit nécessaire - je pense que apt-get install lvm2 était essentiel pour que mon système redémarre.

    
réponse donnée Stéphane 26.12.2017 - 08:17
la source
0

J'ai eu le même problème, après avoir exécuté la commande fsck, il se remettait mais après un certain temps, mon ordinateur se remettait en mode urgence. Cela a résolu mon problème. Je pense que le problème était avec Ubuntu 15.0 version vive, donc j'ai installé la version 14.0. Pourtant, il n'y a toujours pas de problème.

    
réponse donnée Mohit Satish Pawar 01.04.2016 - 12:33
la source
0

J'ai eu le même problème. Commentaires Ajoutés manuellement partitions ntfs de / etc / fstab Le système a démarré normalement. Commande ntfsfix utilisée pour résoudre le problème de journalisation causé à ces partitions ntfs Par exemple: partition Sudo ntfsfix / Dev / ntfs Monté à nouveau dans / etc / fstab Redémarrer

    
réponse donnée Binoy 07.07.2016 - 21:36
la source
0

Donc, il y a beaucoup de bonnes réponses ici - juste pour ajouter à l'info, mon problème était une erreur en orthographiant tmpfs en tant que tempfs qui est incorrect dans une ligne que j'ai ajoutée à / etc / fstab pour sécuriser un serveur

    
réponse donnée user3728501 15.08.2016 - 00:51
la source
0

Je viens d'avoir le même problème et dans mon cas, je venais de recréer ma partition grub et donc il y avait un UUID différent de la dernière partition grub que j'avais. Lorsque j'ai démarré Ubuntu, le système ne pouvait pas vérifier l'UUID. Pour résoudre ce problème, j'ai fait:

sudo nano /etc/fstab

Puis commentez la ligne contenant l’UUID de la partition que je viens de modifier.

puis reboot pour appliquer les modifications.

    
réponse donnée Gabriel Ziegler 02.07.2018 - 22:05
la source

Lire d'autres questions sur les étiquettes