comment puis-je changer la date et l'heure sur Ubuntu

56

quand je vais changer la date et l'heure, cela ne fonctionne pas, et j'essaye de le déverrouiller mais ça ne se déverrouillera pas, s'il y a un moyen de le faire fonctionner, aidez-le. Je sais que ce n'est pas très descriptif mais j'aimerais vraiment avoir des réponses. merci

    
posée viaggio 25.09.2013 - 05:56
la source

5 réponses

75

A partir de man date

-s, --set=STRING
          set time described by STRING

Pour changer la date, utilisez la commande dans le terminal,

sudo date --set=STRING

Par exemple, pour changer la date à 25 sept. 2013 15:00 , la commande serait,

sudo date --set "25 Sep 2013 15:00:00"
    
réponse donnée kern 25.09.2013 - 07:59
la source
40

Essayez ceci:

sudo dpkg-reconfigure tzdata

Cela vous permet de configurer votre fuseau horaire (vous pouvez simplement choisir le même) et synchronise automatiquement votre temps.

S'il n'y a pas de paquet tzdata, installez-le:

sudo apt-get update
sudo apt-get install tzdata
    
réponse donnée Nick Volynkin 23.10.2015 - 10:35
la source
12

Dans 12.04 je ne dois rien débloquer. Il suffit de cliquer sur l'horloge dans la barre du haut et de choisir Time & amp; Paramètres de date, une fois l'heure et l'ampli La fenêtre Date s'ouvre, choisissez Manuellement, vous pouvez ainsi modifier l'heure et la date manuellement. sinon choisissez votre fuseau horaire sur la carte, et choisissez Automatique.

    
réponse donnée Mitch 25.09.2013 - 07:50
la source
2

Voir cet article de blog pour la configuration la date avec une chaîne de format conviviale:

sudo date 120622432007.55

pour le 6 décembre 2007 à 22:43:55,

et consultez cette réponse pour définir la date avec une chaîne conviviale:

sudo date --set "15 MAY 2011 1:40 PM"
    
réponse donnée WillC 09.02.2016 - 01:50
la source
0

J'ai eu un problème similaire sur mon installation et la commande ci-dessus a donné cette erreur:

date: the argument '19 Sep 2014 20:11:00' lacks a leading '+';
when using an option to specify date(s), any non-option
argument must be a format string beginning with '+'
Try 'date --help'

Aide montre -

Usage: date [option]...  [+FORMAT] - (etc)

Ajout du plus requis pour le rendu +19 Sep 2014 20:11:00 qui a fonctionné.

    
réponse donnée shtlcdr 20.09.2014 - 02:42
la source

Lire d'autres questions sur les étiquettes