Entrée fstab correcte pour monter un partage de samba au démarrage?

51

Je suis un peu confus sur l’entrée correcte de fstab pour un partage de samba dans Ubuntu 12.04

  • Je peux obtenir le lecteur à monter manuellement en utilisant:

    sudo mount -t cifs //192.168.2.2/raid_drive /mnt/homeserver -o username=jon,password=password
    
  • J'ai donc essayé de mettre ça dans fstab:

    //192.168.2.2/raid_drive /mnt/homeserver cifs username=jon,password=password,iocharset=utf8,mode=0777,dir_mode=07‌​77 0 0
    
  • Ce qui me donne cette erreur dans syslog:

    kernel: [ 2217.925354] CIFS: Unknown mount option mode
    kernel: [ 2217.936345] CIFS VFS: default security mechanism requested.  The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3
    
  • Ce guide indique comment utiliser smbfs, même si j'estime que smbfs est obsolète?

Quelle est la configuration commune de fstab pour un partage de samba dans Ubuntu 12.04?

MODIFIER:

En utilisant la réponse acceptée ci-dessous, je recevais initialement ce message d'erreur (de dmesg ):

[   45.520883] CIFS VFS: Error connecting to socket. Aborting operation
[   45.520990] CIFS VFS: cifs_mount failed w/return code = -115

bien que cela soit dû à des problèmes de connectivité réseau, et non à une entrée incorrecte de fstab.

    
posée jpetersen 28.06.2012 - 13:58
la source

2 réponses

77

J'ai vécu exactement le même problème ce matin avec 12.04 et voici comment ça marche:

Installez cifs-utils (même si Samba et les paquets associés sont déjà installés):

sudo apt-get install cifs-utils

Modifiez /etc/fstab et ajoutez votre entrée:

//server/share /pathto/mountpoint cifs credentials=/home/username/.smbcredentials,uid=shareuser,gid=sharegroup 0 0

Créez le fichier .smbcredentials dans votre répertoire personnel:

username=shareuser
password=sharepassword
domain=domain_or_workgroupname

Assurez-vous de sécuriser votre fichier ~/.smbcredentials :

chmod 0600 ~/.smbcredentials

Enfin, testez le montage avec:

sudo mount -a

... et vous devriez être prêt à y aller!

    
réponse donnée russnash 28.06.2012 - 14:41
la source
4

Votre problème initial réside dans l’option mode , comme le dit syslog dans la première ligne. Ce que vous vouliez probablement dire était file_mode , voir man mount.cifs pour plus d'informations.

L'approche credential mentionnée par Eliah est en effet meilleure que d'utiliser username et password , mais je ne pense pas que cela interfère avec les autres options comme file_mode ou dir_mode .

    
réponse donnée Vitor 21.01.2013 - 23:48
la source

Lire d'autres questions sur les étiquettes