KVM n'est pas installé sur cette machine (/ dev / kvm est manquant)

54

J'utilise Ubuntu 14.04. J'ai récemment installé Android Studio, mais chaque fois que j'essaie d'exécuter une application Hello World, j'obtiens cette erreur:

/home/praveen/Android/Sdk/tools/emulator -avd Nexus_6_API_21 -netspeed full -netdelay none
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure KVM is properly installed and usable.
CPU acceleration status: KVM is not installed on this machine (/dev/kvm is missing).
    
posée praveen kumar 24.12.2014 - 08:12
la source

7 réponses

30

Soit votre processeur ne prend pas en charge la virtualisation, soit il est désactivé dans le BIOS. Allez dans votre bios et voyez si vous pouvez trouver un paramètre pour l'activer.

    
réponse donnée psusi 24.12.2014 - 16:37
la source
53

Utilisez la commande ci-dessous pour vérifier si le KVM est installé sur la machine ou non,

kvm-ok 

Sortie:

INFO: /dev/kvm exists
KVM acceleration can be used

La sortie comme ci-dessous signifie,

INFO: Your CPU does not support KVM extensions
KVM acceleration can NOT be used

Dans ce scénario, vous devez installer KVM en utilisant la commande ci-dessous,

sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils

J'espère que ça aide.

    
réponse donnée vembutech 24.12.2014 - 09:56
la source
12
HP-EliteBook-820-G1:/opt/android-studio/bin$ sudo /usr/sbin/kvm-ok
INFO: /dev/kvm does not exist
HINT:   sudo modprobe kvm_intel
INFO: Your CPU supports KVM extensions
INFO: KVM (vmx) is disabled by your BIOS
HINT: Enter your BIOS setup and enable Virtualization Technology (VT),
      and then hard poweroff/poweron your system
KVM acceleration can NOT be used

Affectation du paramètre bios, j'ai utilisé la commande suivante

sudo modprobe kvm_intel

Maintenant ça va

    
réponse donnée Allal 11.02.2015 - 12:47
la source
8

Travaillé sur Ubuntu 15.04, le processeur d’Intel

  1. sudo apt-get install qemu-kvm
  2. Activer la technologie de virtualisation dans le BIOS
  3. sudo kvm-ok
réponse donnée asilchenko 28.06.2015 - 01:46
la source
2

J'ai vu la même erreur. Mais je lance Ubuntu sur VMware. Ubuntu est installé sur le VMware. Donc, les étapes pour résoudre le problème sont différentes de la pure machine Ubuntu. Les plaintes sont parties avec les étapes suivantes:

  1. sudo apt install cpu-checker
  2. Dans VMware, définissez les paramètres & gt; Processeurs- & gt; Virtualization Engine, cochez "Virtualiser Intel VT-x / EPT ou AMD-V / RVI.
  3. sudo kvm-ok
réponse donnée Hong 26.07.2016 - 16:40
la source
0

Fermez tous les hyperviseurs avant de démarrer Android Studio. J'ai reçu le même message d'erreur lorsque j'ai essayé d'exécuter un périphérique virtuel Android et qu'une VM Virtual Box était exécutée en même temps.

    
réponse donnée drkpeezy 27.01.2017 - 23:53
la source
0

J'avais essayé la commande,

sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils

mais malheureusement cela n'a pas fonctionné. Ensuite, j'ai changé de propriétaire ( rohanverma est utilisateur dans mon cas) en utilisant,

sudo chown rohanverma:rohanverma -R /dev/kvm

qui a fonctionné pour moi.

    
réponse donnée Rohan Kumar 25.05.2018 - 07:25
la source

Lire d'autres questions sur les étiquettes