Mise à niveau vers le php 7.1 / 7.2 spécifique à partir de php 7.0 dans Ubuntu 16.04 [duplicate]

54

Comment puis-je passer à PHP 7.1 à partir de PHP 7.0 dans Ubuntu 16.04?

Si je fais un php -v je reçois ce message:

PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.8-0ubuntu0.16.04.3, Copyright (c) 1999-2016, by Zend Technologies
    
posée zioMitch 04.12.2016 - 09:21
la source

1 réponse

114

Il n’ya pas de PHP 7.1 officiel dans les dépôts Ubuntu 16.04.

Si vous voulez PHP 7.1, il existe une version disponible dans ppa: ondrej / php

Vous pouvez l’installer comme ceci:

  1. sudo add-apt-repository ppa:ondrej/php
  2. sudo apt-get update
  3. (facultatif) sudo apt-get remove php7.0
  4. sudo apt-get install php7.1 (des commentaires)

N'oubliez pas que ce n'est pas un chemin de mise à niveau officiel. Le PPA est bien connu et est relativement sûr à utiliser.

Le PPA a des packages co-installables (vous pouvez avoir plusieurs versions de PHP installées à partir de ce PPA). ~ muru

    
réponse donnée ThatGuy 04.12.2016 - 09:31
la source

Lire d'autres questions sur les étiquettes