Paire de Bose QuietComfort 35 avec Ubuntu via Bluetooth

50

Dans Paramètres système & gt; Bluetooth , le QC Bose 35 est visible lors de la recherche de périphériques mais l’appariement échoue.

Après plusieurs tentatives et en jouant avec les options PIN , j'ai réussi à l'appairer, mais une fois sélectionné dans Paramètres système & gt; Son , il échouerait et reviendrait à Audio intégré ou à la lecture de certains sons confus.

    
posée Victor 05.10.2016 - 12:20
la source

3 réponses

98

Il semble que Bose Quiet Comfort 35 ait des problèmes avec le jumelage avec Bluetooth LE (Low Energy) .

Retour à un état propre

Je vous recommande de vous nettoyer les tentatives précédentes de jumelage:

  • Sous Ubuntu, retirez les écouteurs de la liste associée Bluetooth.
  • Sur le casque, maintenez le commutateur en position de jumelage Bluetooth pendant 10 secondes pour supprimer tous les appareils associés (vous recevrez une confirmation vocale).
  • Si vous le pouvez, désactivez Bluetooth sur les autres périphériques environnants pour vous assurer qu'ils n'interagiront pas.

Désactiver Bluetooth LE

Modifier le fichier de configuration Bluetooth:

sudo nano /etc/bluetooth/main.conf 

Remplacer:

#ControllerMode = dual

avec:

ControllerMode = bredr

Redémarrer Bluetooth:

sudo service bluetooth restart

Paire

  1. Assurez-vous que le casque est en mode d'appairage.
  2. Jumeler avec Paramètres système & gt; Bluetooth
  3. Sélectionnez & amp; tester le casque dans Paramètres système & gt; Son . Vous pouvez choisir Lecture haute fidélité (récepteur A2DP) pour une qualité de lecture élevée.

Réactiver Bluetooth LE (facultatif)

Comme il n’ya que l’appariement qui doit être fait sans Bluetooth LE, une fois apparié, vous pouvez revenir à la configuration d’origine:

sudo nano /etc/bluetooth/main.conf 

Remplacer:

ControllerMode = bredr

avec:

#ControllerMode = dual

Redémarrer Bluetooth:

sudo service bluetooth restart

Dépannage

Si vous avez des problèmes pour vous reconnecter après la déconnexion / redémarrage:

  • Assurez-vous que l'ordinateur et le Bluetooth sont allumés avant le casque.
  • Si Connexion est grisé dans Paramètres système & gt; Bluetooth , vous pouvez utiliser le menu Bluetooth de la barre de menus (à côté de l’horloge) pour faire Connexion activée / désactivée .
réponse donnée Victor 05.10.2016 - 12:20
la source
28

La réponse acceptée n’a pas fonctionné pour moi. Cette entrée de blog a fonctionné: lien

  1. Créer /etc/bluetooth/audio.conf

    [General]
    Disable=Socket
    Disable=Headset
    Enable=Media,Source,Sink,Gateway
    AutoConnect=true
    load-module module-switch-on-connect
    
  2. In /etc/bluetooth/main.conf set

    ControllerMode = bredr
    AutoEnable=true
    
  3. Redémarrer le bluetooth

  4. Connectez vos écouteurs
  5. Choisissez High Fidelity Playback (A2DP sink) -mode dans les options audio
réponse donnée Ohjeah 20.02.2017 - 03:18
la source
1

La solution ci-dessus n'a pas fonctionné pour moi. Je l'ai fait fonctionner, mais vous devez le configurer manuellement chaque fois que vous redémarrez.

  1. Fermez d'abord bluetooth et bluez en les arrêtant efficacement (sans redémarrer), puis en les redémarrant en utilisant systemctl start bluetooth et sudo /etc/init.d/bluetooth start .
  2. Démarrez le gestionnaire bluez et connectez le périphérique à l'aide de la configuration avec le profil de dissipateur audio.
  3. Changez manuellement le son sur le casque.

Je suis un débutant avec des scripts, peut-être que quelqu'un de plus expérimenté que moi peut créer un script qui effectue toutes ces actions au démarrage.

    
réponse donnée Ale763 17.03.2017 - 12:00
la source

Lire d'autres questions sur les étiquettes