Comment configurer le terminal pour qu'il s'ouvre au maximum

39

Je veux dire compiz, metacity, le gnome-terminal ou quiconque est chargé d'ouvrir la fenêtre du terminal maximisé par défaut.

Comment puis-je le faire?

    
posée tutuca 05.08.2010 - 16:54
la source

9 réponses

43

Lancez gnome-terminal en tant que tel:

gnome-terminal --window --maximize
    
réponse donnée Tommy Brunn 05.08.2010 - 16:59
la source
30

Si vous voulez que gnome-terminal ouvre le plein écran lorsque vous l'ouvrez avec Gnome Do ou le menu Applications, placez ce qui suit dans un fichier nommé gnome-terminal.desktop et mettez-le dans ~/.local/share/applications .

[Desktop Entry]
Name=Terminal
Comment=Use the command line
TryExec=gnome-terminal
Exec=gnome-terminal --window --maximize
Icon=utilities-terminal
Type=Application
X-GNOME-DocPath=gnome-terminal/index.html
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-terminal
X-GNOME-Bugzilla-Component=BugBuddyBugs
X-GNOME-Bugzilla-Version=2.32.0
Categories=GNOME;GTK;Utility;TerminalEmulator;
StartupNotify=true
OnlyShowIn=GNOME;
X-Ubuntu-Gettext-Domain=gnome-terminal

Déconnectez-vous et reconnectez-vous pour appliquer les modifications.

    
réponse donnée Isaiah 29.10.2010 - 22:19
la source
19
  • Ouvrir un terminal.
  • Dans le menu Edit , sélectionnez Profile Preferences .
  • Cochez Use custom default terminal size et entrez une taille par défaut trop grande pour l'écran, par ex. 240 colonnes et 100 lignes.

Fermez, puis ouvrez un nouveau terminal en cliquant sur l’icône (ou appuyez sur Ctrl + Alt + T ): la nouvelle fenêtre du terminal devrait être maximisé.

Cette réponse est basée sur des conseils qui m'ont été donnés ici: Comment optimiser le démarrage du terminal?

    
réponse donnée Craig 02.07.2012 - 17:06
la source
9

Ubuntu 12.04 et 14.04 LTS

Exécutez ccsm (Gestionnaire de paramètres CompizConfig). Sous Window Management, activez Window Rules et ouvrez-le, et dans le champ Maximized, ajoutez class=Gnome-terminal . Vous devrez peut-être vous déconnecter et vous reconnecter avant que les modifications n'entrent en vigueur.

Si vous ne voyez pas les règles de la fenêtre, assurez-vous que le package compiz-plugins est installé.

Vous pouvez faire plus. J'utilise (class=Gnome-terminal) | (class=Evince) .

    
réponse donnée Brent Baccala 24.06.2012 - 22:51
la source
8

Dans Ubuntu 11.10 et supérieur:

  • Rechercher & gt; Clavier & gt; Raccourcis & gt; Raccourcis personnalisés & gt; Ajouter (bouton +) & gt;
    • Nom: Terminal de lancement maximisé
    • Commande: gnome-terminal --window --maximize
  • Cliquez sur Appliquer
  • Cliquez sur 'Désactivé'
  • Maj + Ctrl + Alt + T
réponse donnée Gurjeet Singh 25.09.2012 - 17:19
la source
6
gnome-terminal --full-screen

Vous pouvez créer un raccourci sur votre bureau ou votre panneau pour cette commande.

    
réponse donnée popey 05.08.2010 - 17:00
la source
6

La réponse sélectionnée ne fonctionnait pas pour moi sur Ubuntu 12.04 LTS entièrement mis à jour, alors j'ai décidé qu'il était temps d'adopter une approche plus radicale. Les solutions ci-dessous sont testées jusqu'à 16.04 LTS.

Mon ancienne solution

  1. Renommez le fichier exécutable original gnome-terminal en gnome-terminal-original :

    cd /usr/bin
    sudo mv gnome-terminal gnome-terminal-original
    
  2. Créez un nouveau fichier dans /usr/bin nommé gnome-terminal avec le contenu suivant:

    #!/bin/bash
    /usr/bin/gnome-terminal-original --maximize [email protected]
    
  3. Rendez-le exécutable:

    sudo chmod +x gnome-terminal
    

Maintenant, peu importe la façon dont j'ouvre le terminal, il s'ouvre toujours au maximum. Le seul inconvénient que je vois pour cette approche est que vous devez répéter ces étapes chaque fois que vous mettez à jour gnome-terminal avec une nouvelle version via le gestionnaire de mise à jour ou apt-get upgrade .

Remarque: le paramètre [email protected] signifie que tous les arguments pouvant être transmis à gnome-terminal seront toujours transmis à gnome-terminal-original , avec l'argument --maximize .

Une meilleure solution

  1. Installer "wmctrl":

    sudo apt-get install wmctrl
    
  2. Ajoutez cette ligne à la toute fin de votre fichier ~/.bashrc :

    wmctrl -i -r $WINDOWID -b add,maximized_vert,maximized_horz
    
  3. Répétez la deuxième étape pour les fichiers .bashrc d'autres utilisateurs si nécessaire, par exemple, pour l'utilisateur "root" ( /root/.bashrc ).

Cette solution n’affectera pas initialement la taille de la fenêtre du terminal, mais la maximisera peu après son ouverture, généralement en quelques millisecondes. Vous pouvez essayer de déplacer la ligne que vous avez ajoutée à la deuxième étape vers le début du fichier .bashrc pour que le terminal soit encore plus performant.

    
réponse donnée Brane 30.04.2013 - 00:15
la source
2

Si vous souhaitez simplement que le terminal s'ouvre en plein écran à l’écran, utilisez la méthode de l’interface graphique pour modifier de manière appropriée la taille par défaut via la boîte de dialogue des préférences de profil actuelles. Pour ce faire, suivez simplement les étapes suivantes:

  • Ouvrir un terminal
  • Choisissez Modifier
  • Dans l'onglet Général, cochez l'option "Utiliser la taille de terminal par défaut personnalisée"
  • Vous devez ajuster ces valeurs pour qu'elles correspondent à votre écran par simple essai et erreur

Le paramètre de colonne est 128 pour moi. Vous devez définir les valeurs qui vous conviennent le mieux.

    
réponse donnée Siamore 29.10.2010 - 21:14
la source
-2

Vous pouvez probablement modifier vos raccourcis pour qu’ils utilisent le maximum afin qu’il démarre toujours de cette manière.

Le moyen le plus simple est de localiser votre application (dans /usr/share/applications ou ~/.local/share/applications ) et de modifier votre fichier .desktop .

Dans ce fichier .desktop , vous verrez la ligne qui commence par Exec=... . Pour démarrer gnome-terminal maximisé, il vous suffit d'ajouter --start-maximized à la fin de la commande.

    
réponse donnée Nigel 05.08.2010 - 17:44
la source

Lire d'autres questions sur les étiquettes