Comment augmenter la résolution en mode console?

50

J'ai récemment réinstallé Maverick sur mon ordinateur. Il utilise les pilotes Nvidia proposés.

Tout se passe bien, sauf que je vois beaucoup de texte laide lors du démarrage et de l'arrêt d'Ubuntu.

Le texte ne me dérange pas du tout. en fait, j'aime bien voir les informations de démarrage / fermeture.

Ce que je n'aime pas c'est sa laideur!

Lorsque mon ordinateur passe en mode console - (démarrage, arrêt ou CTRL + ALT + F1), le texte est trop gros - je ne peux pas en prendre une capture d'écran, mais sa résolution est de 640x480. Mon moniteur fonctionne normalement à 1440x900.

Je me souviens que le texte de la console apparu lors de l'installation à partir du CD était joli et petit.

Comment puis-je donner au texte de la console l'apparence qu'il avait lors du démarrage à partir du CD?

    
posée egarcia 22.12.2010 - 00:50
la source

8 réponses

32

J'ai trouvé une solution adaptée à ce message de forum

En bref:

Ouvrez /etc/default/grub avec votre éditeur favori en tant que root.

Localisez la ligne indiquant GRUB_GFXMODE= ... et remplacez-la par la résolution souhaitée. Ajoutez une autre ligne pour une nouvelle variable appelée GRUB_GFXPAYLOAD avec la même résolution. Cela devrait ressembler à ceci:

GRUB_GFXMODE=1440x900x32
GRUB_GFXPAYLOAD=1440x900x32

Enregistrez et quittez. Puis éditez en tant que root /etc/grub.d/00_header

Localisez la ligne indiquant if [ "x${GRUB_GFXMODE}" = "x" ] ; then GRUB_GFXMODE=... . Comme auparavant, remplacez la résolution par celle de votre choix et ajoutez une autre ligne pour la charge utile:

if [ "x${GRUB_GFXMODE}" = "x" ] ; then GRUB_GFXMODE=1440x900x32 ; fi
if [ "x${GRUB_GFXPAYLOAD}" = "x" ] ; then GRUB_GFXPAYLOAD=1440x900x32 ; fi

Enfin, localisez la ligne indiquant le jeu gfxmode=${GRUB_GFXMODE} et ajoutez une ligne pour la charge en dessous. Cela devrait ressembler à ceci:

set gfxmode=${GRUB_GFXMODE}
set gfxpayload=${GRUB_GFXPAYLOAD}

Enregistrer et quitter.

Toujours en tant que root, actualisez le fichier grub avec

update-grub2

Redémarrez. Le menu de menu et la console devraient avoir de meilleures résolutions.

Terminé!

    
réponse donnée egarcia 22.12.2010 - 05:54
la source
22

Cela m'a aidé sur Ubuntu 14.04 avec ESXi 5.5:

:~$ sudo vi /etc/default/grub

Changer de ligne en:

GRUB_CMDLINE_LINUX_DEFAULT="splash vga=792"

:~$ sudo update-grub :~$ sudo reboot -r now

Utilisez 795 ou 799 pour une résolution supérieure et consultez le lien: link . pour plus de détails.

    
réponse donnée vranger 22.05.2014 - 23:24
la source
14

Définissez le mode graphique avec GRUB_GFXPAYLOAD_LINUX

D'abord, installez xrandr et exécutez-le:

$ sudo apt-get install xrandr
$ xrandr

Les modes d'écran disponibles sont répertoriés.

Maintenant, éditez /etc/default/grub :

$ sudo nano /etc/default/grub

En supposant un fichier non modifié précédemment, apportez les modifications suivantes:

La variable GRUB_CMDLINE_LINUX_DEFAULT doit contenir au moins nomodeset , peut-être en plus de quiet et splash sur les systèmes de bureau.

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"

Sur les systèmes serveur, annulez la mise en commentaire de GRUB_TERMINAL=console pour que davantage de messages soient transmis lors du démarrage avant d'entrer dans la console graphique.

Laissez cette ligne sous forme de commentaire:

#GRUB_GFXMODE=640x480

À la fin du fichier, ajoutez une ligne:

GRUB_GFXPAYLOAD_LINUX=1280x1024x16

ou remplacez la valeur par tout autre mode (séparé (s) par une virgule) pris en charge par votre matériel. Les valeurs text , keep , auto , vga et ask devraient également fonctionner.

Enfin, après avoir enregistré le /etc/default/grub édité avec Ctrl + O et l'avoir quitté avec Ctrl + X , lancez les commandes suivantes:

$ sudo update-grub
$ sudo reboot

Cette réponse permettra également de réduire la résolution et / ou le taux de rafraîchissement ou la fréquence de la mémoire tampon de trame sur les systèmes synchronisés. Les moniteurs CRT affichent généralement des bandes clignotantes lorsque la fréquence de rafraîchissement est trop élevée.

    
réponse donnée Serge Stroobandt 23.06.2014 - 14:31
la source
14
  1. Démarrer dans le menu GRUB
  2. Appuyez sur C pour accéder à la ligne de commande GRUB
  3. Exécutez vbeinfo et prenez une décision (par exemple, 1920x1200x32).
  4. Redémarrez votre système
  5. sudo nano /etc/default/grub
  6. Modifiez GRUB_GFXMODE= (par exemple, GRUB_GFXMODE=1920x1200x32 )
  7. Définissez GRUB_GFXPAYLOAD_LINUX sur GRUB_GFXPAYLOAD_LINUX=keep
  8. sudo update-grub
  9. redémarrez votre système
réponse donnée A.B. 15.04.2015 - 11:33
la source
4

Juste un peu d’arrière-plan personnel: sur mon autre ordinateur, je n’ai aucun problème avec ce mode fantaisie (160 colonnes x 60 lignes, mais avec un moniteur CRT 4: 3). Il est équipé d'une TNT2 (oui, je le jure), et ce mode a été rapidement affiché lors du premier démarrage. Le problème, c’est qu’il charge cela en chargeant le pilote nouveau , et que ce gars est toujours un peu défectueux (dans mon cas, il bloque tout le système lorsque vous essayez de déplacer des fenêtres) . Donc, pour avoir un système utilisable, je devais passer à l’ancien et stable nv , et aussi désactiver le réglage du mode (car le noyau chargerait toujours toujours quand activée). Notez que je n’utilise pas les pilotes propriétaires nVidia, mais comme vous, j’ai repassé le mode 80x25 en mode console.

Cela est dû au fait que le pilote nv n’utilise pas le noyau paramètre de mode . Maintenant, je ne connais pas les pilotes propriétaires, mais j'imagine qu'ils ont peut-être changé votre configuration pour pouvoir être utilisée, et c'est peut-être pour cette raison que vous voyez ce mode "grand". Peut-être qu'ils ont désactivé le mode de réglage lors de l'installation. C'est pourquoi vous voyez le "petit" mode texte lors du démarrage à partir du Live CD.

Vous pouvez essayer de démarrer avec un mode VESA différent, mais cela dépend beaucoup de votre matériel. Pour cela, veuillez consulter le lien . Par exemple, si vous souhaitez essayer de démarrer votre mode texte sur 1024x640, vous constaterez que l'ID du mode est 877.

Ainsi, lors du démarrage, maintenez la touche SHIFT enfoncée (si vous n'avez pas de délai d'expiration GRUB) pour afficher le menu de GRUB. Sélectionnez le mode que vous souhaitez démarrer et appuyez sur 'e' (pour éditer les commandes). A la fin de la commande "kernel", ajoutez vga=877 . Le numéro correspond à l'identifiant du mode. Si vous souhaitez essayer d'autres modes, remplacez-le par le numéro souhaité.

De plus, sur cette même page Wikipedia, vous pouvez également essayer le "format universel", très utile, juste en dessous du tableau des modes. Cette commande hwinfo est très utile.

    
réponse donnée Charles Roberto Canato 22.12.2010 - 05:11
la source
3

Pourquoi je réponds à cette menace même si elle est très ancienne? La réponse est assez simple, car de nombreuses autres menaces y font référence.

Si vbeinfo ou hwinfo --framebuffer ne montre pas la résolution native de votre affichage, désactivez vesa, pour ce faire, supprimez vga = options dans:

sudo nano /etc/default/grub

Recherchez GRUB_CMDLINE_LINUX_DEFAULT= et supprimez vga= si vous le trouvez.

Si vous avez supprimé l'option, n'oubliez pas de générer un nouveau fichier grub.cfg:

sudo update-grub

Si vous ne savez pas que vous l'avez bien fait, redémarrez et ouvrez un terminal:

grep vga /proc/cmdline
grep -ir vga /etc/modprobe.d/

Si grep n'affiche rien, vous avez supprimé l'option vga =.

Installez maintenant uvesafb:

sudo apt-get install v86d

Assurez-vous que le module uvesafb est inclus dans votre initrd. Ajoutez-le à la fin de / etc / initramfs-tools / modules:

sudo sh -c "echo uvesafb >> /etc/initramfs-tools/modules"

Pour voir quels modes sont disponibles:

sudo modprobe uvesafb
cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes

Configurez maintenant uvesafb mode_option = YOURxResoultion-BitColorMode, par exemple. 1280x1024-32:

sudo sh -c "echo options uvesafb mode_option=1280x1024-32 scroll=ywrap > /etc/modprobe.d/uvesafb.conf"

N'oubliez pas de reconstruire votre initrd:

sudo update-initramfs -k all -u

Vous pouvez maintenant redémarrer!

Voir this pour plus d'informations. détails. C'est pour Debian, mais ça marche aussi pour Ubuntu. J'espère que cela vous a aidé et qu'il devrait être plus générique que d'utiliser grub2.

    
réponse donnée Arch User 05.09.2015 - 16:00
la source
0

Cela ne changera pas la police au démarrage, mais pour la console sous Ctrl + Alt + F [1-6]

Installez les polices personnalisées Ubuntu pour votre console:

sudo apt-get install fonts-ubuntu-font-family-console

Et créez un script /usr/local/bin/fontset avec cette commande:

#!/bin/sh
setfont /usr/share/consolefonts/Uni3-TerminusBold32x16.psf.gz

(choisissez le fon souhaité dans le dossier /usr/share/consolefonts/ )

Vous pouvez appeler fontset à chaque fois sur votre console après avoir utilisé Ctrl + Alt + F1

ou ajoutez cette ligne à votre /root/.profile

[ ! -t 0 ] && sleep 1 & /usr/local/bin/fontset

(n’ajoutez pas ceci à votre profil utilisateur, ni à une erreur lors d’un démarrage graphique)

source: Redimensionner la police sur l'écran et la console du message de démarrage

    
réponse donnée rubo77 01.09.2015 - 08:26
la source
0

Ce qui suit a fonctionné pour moi sur Debian Stretch 4.9.51-1.
Aucune interface graphique, uniquement en mode console:

Modifiez /etc/default/grub et ajoutez la ligne suivante

GRUB_CMDLINE_LINUX_DEFAULT="splash vga=795 nomodeset"

Pour obtenir la liste des codes vga= , voir lien

.

Le nomodeset empêche la résolution de changer à nouveau après l’initialisation de grub [merci Comment augmenter la résolution en mode console? ]

MODIFIER: Comme mentionné par @Videonauth: Ensuite faire: sudo update-grub

    
réponse donnée Otti 26.10.2017 - 17:11
la source

Lire d'autres questions sur les étiquettes