LibreOffice Spell Checker ne fonctionne pas?

38

J'ai été un peu surpris de découvrir que dans LibreOffice (3.5.4.2), le correcteur orthographique ne fonctionne pas vraiment. J'ai été surpris car les correcteurs orthographiques ont été autour depuis .... 80's? Ce n'est pas une chose difficile.

Je cours Ubuntu 12.04 sur une installation relativement nouvelle. Je n'ai rien fait pour mes dictionnaires ou fichiers de langue.

Sous outils & gt; options & gt; languages ​​& gt; Aides à l'écriture, j'ai l'option choisie pour vérifier que je tape et utiliser les dictionnaires anglais.

Cependant, je n’obtiens aucune erreur lorsque je tape exprès des fautes d’orthographe, et lorsque je lance le vérificateur, il indique simplement que la vérification orthographique est terminée et ferme la fenêtre.

Est-ce un bug avec Libre? ou ai-je fait quelque chose de mal?

    
posée Michael 20.10.2012 - 20:28
la source

7 réponses

34

Un correctif rapide pour le document actuel (en supposant le texte anglais) est Outils - Langue - Pour tous les textes - Anglais (USA).

Je pense que le correctif permanent consiste à s’assurer que la langue par défaut utilisée pour les documents est prise en charge par un dictionnaire installé. Cette solution a été documentée par "idiota" sur le forum de questions de LibreOffice:

"Le problème est résolu en cliquant sur Outils / Options / Paramètres de langue / Langues. Il permet des dizaines de saveurs d’anglais, MAIS l’orthographe est désactivée pour tous ceux qui n’ont pas la petite coche bleue icône ABC à côté."

lien

    
réponse donnée CentaurusA 20.10.2012 - 22:23
la source
10

Lors du choix de votre langue, voyez-vous le chèque en plus?

Sinon, ouvrez "Language Support" et cliquez sur "Install / Remove Languages ​​..." et installez la langue de votre choix, fermez LibreOffice et réessayez.

    
réponse donnée Jeggy 20.10.2012 - 22:44
la source
8

Pour installer les packages de vérification orthographique pour l'anglais et les États-Unis, les commandes du terminal sont les suivantes:

sudo apt update
sudo apt install myspell-en-gb myspell-en-us

Remarques:

  • Si vous avez déjà installé hunspell-en-gb , vous devez le supprimer pour installer myspell-en-gb .
  • Si vous avez déjà installé hunspell-en-us , vous devez le supprimer pour installer myspell-en-us .
réponse donnée Tom 19.08.2013 - 13:53
la source
4

Installez les éléments suivants:

sudo apt-get install myspell-en-us

Maintenant, redémarrez la suite bureautique pour que le correcteur orthographique fonctionne. J'espère que ça aide

    
réponse donnée xtreak 13.08.2013 - 22:02
la source
2

Dans mon cas, l'option de vérification orthographique pour activer la langue de mon choix n'était pas présente.

Les dictionnaires ont été installés et le problème est lié au programme bureautique.

Cela a été corrigé par les éléments suivants:

  1. killall soffice.bin

  2. rm -r .config/libreoffice/

  3. Lancez LibreOffice & amp; allez dans Outils- & gt; Options- & gt; Paramètres de langue - & gt; Langue par défaut pour les documents: anglais britannique (maintenant avec l'icône de vérification orthographique)

PS: pour l'anglais britannique, j'ai installé libreoffice-l10n-en-gb et myspell-en-gb .

    
réponse donnée mark quinn 19.04.2013 - 15:38
la source
0

Aller à - & gt; outils- & gt; options- & gt; langues- & gt; occidental. Ensuite, définissez la langue occidentale comme anglais usa car elle est activée avec la vérification orthographique.

    
réponse donnée supreeth I 18.05.2015 - 06:47
la source
0

Si vous avez choisi autre chose que l'anglais (USA), il est peu probable que la vérification orthographique soit disponible.

C'est le A avec des points verts vus ici:

Si vous avez besoin d'une variante anglaise de GB, AU, CA ou ZA, installez l'extension English Dictionaries . / p>     

réponse donnée Greg Bell 14.07.2017 - 04:54
la source

Lire d'autres questions sur les étiquettes