Impossible de trouver curl-config dans Ubuntu 13.04

40

J'installe le package RCurl dans R et je reçois une erreur

  checking for curl-config... no
  Cannot find curl-config
  ERROR: configuration failed for package ‘RCurl’

J'ai essayé d'installer libcurl sur Ubuntu, mais cela ne résout pas mon problème avec des dépendances

sudo apt-get install libcurl4-gnutls-dev
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.29.0-1ubuntu3.1) but 7.29.0-1ubuntu3.2 is to be installed
Depends: libldap2-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

locate curl config ne me donne rien:

locate curl-config
curl-config
The program 'curl-config' can be found in the following packages:
* libcurl4-gnutls-dev
* libcurl4-nss-dev
* libcurl4-openssl-dev

J'ai parcouru une partie de la solution RCurl mais elle fonctionne. Pouvez-vous suggérer ou aider dans cette direction? Merci beaucoup.

Modifier

lorsque j'ai essayé d'installer (Curl) depuis le centre logiciel Ubuntu a reçu le même message erroe

Les dépendances de package ne peuvent pas être résolues

Cette erreur peut être provoquée par des logiciels supplémentaires nécessaires manquants ou non installables. De plus, il pourrait y avoir un conflit entre les logiciels qui ne sont pas autorisés à être installés en même temps.

  

Les paquets suivants ont des dépendances non satisfaites:

 curl: Depends: libcurl3 (= 7.29.0-1ubuntu3.1) but 7.29.0-1ubuntu3.2 is to be installed
  Depends: zlib1g (>= 1:1.1.4) but 1:1.2.7.dfsg-13ubuntu2 is to be installed

EDITED

  

sudo aptitude install libcurl4-openssl-dev

The following NEW packages will be installed:
libcurl4-openssl-dev{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,210 kB of archives. After unpacking 2,778 kB will be used.
The following packages have unmet dependencies:
libcurl4-openssl-dev : Depends: libcurl3 (= 7.29.0-1ubuntu3.1) but 7.29.0-1ubuntu3.2 is installed.
                    Depends: libidn11-dev but it is not going to be installed.
                    Depends: libkrb5-dev but it is not going to be installed.
                    Depends: libldap2-dev but it is not going to be installed.
                    Depends: librtmp-dev but it is not going to be installed.
                    Depends: libssl-dev but it is not going to be installed.
 The following actions will resolve these dependencies:
 Keep the following packages at their current version:
 1)     libcurl4-openssl-dev [Not Installed]               
    
posée Aashu 15.10.2013 - 08:34
la source

2 réponses

62

Les 3 packages contenant curl-config :

  1. libcurl4-gnutls-dev
  2. libcurl4-nss-dev
  3. libcurl4-openssl-dev

Tous semblent avoir la même fonctionnalité. J'ai installé le premier via Synaptic Package Manager et j'ai pu installer RCurl depuis CRAN.

Donc, si vous choisissez la première option, ouvrez une boîte à bornes et faites

sudo apt-get install libcurl4-gnutls-dev

puis allez dans R et faites

install.packages("RCurl")
    
réponse donnée Placidia 02.03.2014 - 15:04
la source
2

Voici ce que j'ai fait pour résoudre le même problème:

sudo aptitude install libcurl4-openssl-dev

Lorsque vous êtes invité à accepter la solution, [Y / n / q]

 :
 The following actions will resolve these dependencies:
 Keep the following packages at their current version:
 1)     libcurl4-openssl-dev [Not Installed]      
 :

répondez "n". Répondez ensuite à [Y] lorsqu'une autre action est demandée.

    
réponse donnée John Huang 26.05.2015 - 07:56
la source

Lire d'autres questions sur les étiquettes