Comment modifier les options du bouton d'alimentation?

90

Lorsque j'appuie sur le bouton d'alimentation, une boîte de dialogue s'ouvre, mais je veux arrêter le système sans recevoir "Voulez-vous vraiment vraiment vous arrêter?". Comment puis-je choisir une action d'arrêt direct sur un bouton d'alimentation enfoncé?

J'ai eu le même problème avec la version 11.04, mais je ne me souviens pas de la solution et hier, je suis passé à Ubuntu 11.10.

    
posée NaN 15.10.2011 - 11:36
la source

8 réponses

81

Action de fermeture du couvercle

Pour configurer l’action de fermeture du couvercle du portable, vous devez installer Advanced Setting (ou l’outil Gnome Tweak). Il est dans l'USC (Ubuntu Software Center) sous tweak ou Advanced Settings. Si installé, appuyez sur le bouton super et tapez tweak ou avancé et choisissez les paramètres avancés. Lorsqu'il s'ouvre, choisissez l'onglet shell;

Appuyez sur les flèches et choisissez ce que vous souhaitez à la fois sur secteur et sur batterie;

Comportement des boutons par défaut

Installer dconf-tools:

sudo apt-get install dconf-tools

Appuyez sur alt + f2 et ouvrez dconf-editor (ou dans un terminal de type dconf-editor)

Accédez à org.gnome.settings-daemon.plugins.power et définissez votre action par défaut sur les boutons:

Sur certains systèmes, vous devrez également marquer l'élément suppress-logout-restart-shutdown .

    
réponse donnée Bruno Pereira 15.10.2011 - 11:48
la source
39

Je crains que les premières réponses ne fonctionnent pas pour moi, je pense que les «solutions graphiques» ne fonctionnent que pour l'indicateur en haut à droite, pas pour le bouton d'alimentation. solution de règle fonctionne pour moi, je pense que je peux l'améliorer et faire disparaître l'invite complètement. Au lieu de créer un nouveau fichier, vous pouvez utiliser le fichier /etc/acpi/events/powerbtn existant

sudo -H gedit /etc/acpi/events/powerbtn

Ajoutez # à la ligne de commentaire:

#action=/etc/acpi/powerbtn.sh

Ajouter une nouvelle ligne:

action=/sbin/poweroff

Enregistrer le fichier. Ouvrez une console et tapez:

sudo acpid restart

Cela fonctionne pour moi ET l'invite a disparu, comme dans Ubuntu 11.04. Souhaite que cela aide.

    
réponse donnée David López 04.12.2011 - 00:55
la source
28

Voici la réponse simple et rapide dont j'avais besoin:

gsettings set org.gnome.settings-daemon.plugins.power button-power 'hibernate'

Si vous voulez d'abord voir vos paramètres, essayez ceci:

gsettings get org.gnome.settings-daemon.plugins.power button-power

Ou peut-être cela si vous voulez voir tous les paramètres d'alimentation:

gsettings list-recursively org.gnome.settings-daemon.plugins.power
    
réponse donnée phord 14.02.2017 - 21:30
la source
10

Je voulais changer le bouton d’alimentation pour le suspendre en RAM. Sur un serveur Ubuntu 14.04 (pas de Gnome / X), changer /etc/acpi/events/powerbtn pour utiliser une autre action ( /usr/sbin/pm-suspend ) ne fonctionnait pas.

Au lieu de cela, ajouter une seule ligne à /etc/systemd/logind.conf était suffisant pour faire l'affaire:

#HandlePowerKey=poweroff
HandlePowerKey=suspend

Appuyez sur le bouton d’alimentation pour interrompre immédiatement la lecture.

    
réponse donnée gojomo 01.06.2015 - 22:21
la source
8

La réponse de Bruno est seulement à moitié correcte.

Après avoir installé dconf, vous devez accéder aux applications & gt; indicateur-session

Cochez l’élément "suppress-logout-restart-shutdown".

Cela fonctionnera pour Unity dans Ubuntu 11.10 mais pas pour Gnome 3 ou Gnome Classic.

    
réponse donnée Ubuntuist 22.10.2011 - 01:51
la source
7

Cela ne fonctionnait pas pour moi dans l'unité ou gnome-shell (l'invite était toujours affichée). J'ai donc utilisé ce manuel

du wiki arch linux. J'ai créé le fichier / etc / acpi / events / power avec le contenu:

event=button/power (PWR.||PBTN)
action=/sbin/poweroff

et exécuté une commande:

sudo acpid restart (ne sait pas exactement si la commande est correcte)

Et puis en appuyant sur le bouton d’arrêt matériel de l’ordinateur (l’invite sera affichée, mais cela n’arrêtera pas le processus d’arrêt).

    
réponse donnée rulet 12.11.2011 - 17:37
la source
0

Rien de tout cela n'a fonctionné sur mon système 13.04. Au final, j'ai recompilé gnome-session .

Dans gsm_shell.c et gsm_logout_dialog.c , modifiez #define AUTOMATIC_ACTION_TIMEOUT from 60 to 5

    
réponse donnée user223389 08.12.2013 - 13:51
la source
0

Pour les systèmes Ubuntu et Lubuntu actuels:

echo "HandlePowerKey=suspend" | sudo tee -a /etc/systemd/logind.conf
sudo service systemd-logind suspend
    
réponse donnée cmcginty 30.04.2017 - 03:03
la source

Lire d'autres questions sur les étiquettes