Comment configurer les interfaces réseau sur Ubuntu dans des boîtes virtuelles?

7

La question

Comment ubuntu peut-il être configuré pour ne pas recevoir le message "attente de la configuration réseau ..." au démarrage si vous avez plusieurs adaptateurs?

Faits

  • J'ai un Ubuntu intact dans Virtual Box et dans VM-Ware Workstation.

  • Mon fichier /etc/network/interfaces est intact et j'ai activé un adaptateur Nat pour utiliser la vraie carte réseau du système hôte.

  • En outre, j'ai activé un adaptateur hôte uniquement pour pouvoir utiliser une adresse IP distincte pour les connexions entre la machine virtuelle et le système hôte.

Déduction

Je me suis rendu compte que le fichier d’interfaces n’a besoin que d’une seule entrée de passerelle.

auto eth0

iface eth0 inet dhcp .

Il s’agit donc de l’entrée correspondant à la première carte réseau qui fournit des informations sur la passerelle. La deuxième configuration n’a donc pas besoin d’une ligne appelée

.

gateway 192.168.1.1 .

Pour moi, cela signifie que la deuxième entrée doit ressembler à ceci:

address 192.168.217.131

en fonction de ce que le routeur vous indique en tant qu’adresse réseau pour l’interface configurée via le protocole dcp et la deuxième ligne est le masque de réseau. Dans les cas les plus courants, c'est

netmask 255.255.255 .

Le fichier '/ etc / network / interfaces' ressemble à ceci:

#This file describe the network interfaces available on your system
#and how to activate them. For more information see interfaces(5).

#The loopack network interface 

auto lo
iface lo inet loopback

#The primary network interface 

# ethernet 0
auto eth0 
iface eth0 inet dhcp

auto eth1
iface eth1 inet static

address 192.168.217.131
netmask 255.255.255

#No need for gateway here because this is already provided by the dhcp entry.

Dans cet exemple, j'ai pris l'adresse IP fournie par le serveur ^ du serveur Ubuntu (Basic Ubuntu Server) qui était 192.168.217.130 et augmentée de un.

Maintenant, je redémarre Ubuntu et j'ai reçu le message Waiting for network Configuration... où Ubuntu essaie d'attendre la connexion réseau environ 2 minutes.

J'ai la même chose avec Virtual Box.

    
posée Josh 10.09.2013 - 23:36
la source

3 réponses

6

Il y a deux choses à savoir

  1. Comme déjà mentionné ci-dessus, il n’ya pas besoin d’une deuxième passerelle avec un serveur DHCP dans votre réseau car l’entrée de passerelle est générée à partir de là.

  2. Après avoir ajouté un adaptateur hôte, vous devez copier l'adresse IP de votre hôte Windows.

Jusqu'à présent.

Voici un exemple de configuration pour une connexion hôte uniquement avec un adaptateur supplémentaire:

auto eth1

iface eth1 inet static
address 192.168.253.128
netmask 255.255.255.0
network 192.168.253.1
broadcast 192.168.253.255

Le troisième bloc de la ligne réseau dépend de votre ip. la ligne de diffusion est nécessaire pour la communication réseau entre l'hôte et l'invité. Ceci est une chose liée au protocole réseau.

    
réponse donnée Josh 15.09.2013 - 17:07
la source
3

Si vous souhaitez connecter votre machine virtuelle à votre réseau domestique avec une adresse IP déférente par rapport au système hôte, vous devez choisir l'option Bridge . Dans ces options avancées, vous devez choisir permettre à tous les communications entre les machines virtuelles à héberger, Vm à Vm.

Vous devez choisir la connexion Bridge pour la deuxième carte réseau. Vous devez également configurer dns-nameservers et gateway car cette carte réseau est différente de la première.

Dans votre fichier de configuration, netmask devrait être

netmask 255.255.255.0
    
réponse donnée Ketankumar Patel 13.09.2013 - 12:03
la source
1

Quelque chose de plus serait nécessaire pour que le réseautage fonctionne à certaines occasions. Fournir des serveurs DNS dans le fichier / etc / network / interfaces au lieu du fichier '/etc/resolvconf/resolv.conf.d/base'. Exemple:

auto eth1

iface eth1 inet static
address 192.168.217.131
netmask 255.255.255.0
network 192.168.217.1
broadcast 192.168.217.255
gateway 'provide your gateway here might be necessary'
dns-nameservers 'provide your nameserver here'

Enfin,

sudo restart network-manager
    
réponse donnée George Kourouleas 20.09.2013 - 01:09
la source

Lire d'autres questions sur les étiquettes