Comment faire fonctionner un contrôleur de vapeur?

39

J'ai un contrôleur de vapeur et je dois le faire fonctionner dans Ubuntu, comment puis-je le faire?

    
posée Jorge Castro 16.10.2015 - 14:31
la source

7 réponses

25

Mise à jour au 22/11/2016 (si vous avez utilisé cette solution )

En raison d’une mise à jour récente, votre règle udev doit être mise à jour.

Modifiez le fichier udev:

sudoedit /lib/udev/rules.d/99-steam-controller-perms.rules

Tout remplacer par:

# This rule is needed for basic functionality of the controller in Steam and keyboard/mouse emulation
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666"

# This rule is necessary for gamepad emulation; make sure you replace 'pgriffais' with a group that the user that runs Steam belongs to
KERNEL=="uinput", MODE="0660", GROUP="pgriffais", OPTIONS+="static_node=uinput"

# Valve HID devices over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="28de", MODE="0666"

# Valve HID devices over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*28DE:*", MODE="0666"

# DualShock 4 over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="05c4", MODE="0666"

# DualShock 4 wireless adapter over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0ba0", MODE="0666"

# DualShock 4 Slim over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="09cc", MODE="0666"

# DualShock 4 over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*054C:05C4*", MODE="0666"

# DualShock 4 Slim over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*054C:09CC*", MODE="0666"

Maintenant, débranchez et rebranchez votre dongle Steam et réparez votre contrôleur

    
réponse donnée Insperatus 26.11.2016 - 08:37
la source
31

Pour les versions Ubuntu antérieures à 15.10

Reconnaissance du contrôleur

Créez le fichier udev:

sudoedit /lib/udev/rules.d/99-steam-controller-perms.rules

puis ajoutez les contenus suivants, n'oubliez pas d'utiliser votre nom d'utilisateur dans le fichier!

# This rule is needed for basic functionality of the controller in
# Steam and keyboard/mouse emulation
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666"

# This rule is necessary for gamepad emulation; make sure you
# replace 'pgriffais' with the username of the user that runs Steam
KERNEL=="uinput", MODE="0660", GROUP="pgriffais", OPTIONS+="static_node=uinput"

Donnez au contrôleur l’accès à /dev/uinput

  • Pour rapide et sale, sudo chmod 666 /dev/uinput
  • Pour une solution de contournement qui survit aux redémarrages: sudo apt-get install python3-autopilot Puis, déconnectez-vous ou redémarrez. Cela vous ajoutera à un groupe qui a un accès en écriture à /dev/uinput . Cela va ajouter quelques paquets dont vous n'aurez probablement pas besoin, mais vous pouvez les supprimer une fois que la mise à jour du paquet de vapeur arrive.

Voir aussi:

réponse donnée Jorge Castro 16.10.2015 - 14:31
la source
10

Instructions pour Ubuntu 16.10

Comme le contrôleur n’a pas fonctionné, c’était une solution simple:

sudo apt install steam-devices

Après le redémarrage, cela a bien fonctionné.

    
réponse donnée TheGhost 16.10.2016 - 21:53
la source
7

J'ai 15.10 et mon contrôleur ne fonctionnait pas.

J'ai consulté les fichiers mentionnés ci-dessus et je vois une faute de frappe dans le fichier de distribution fourni. Il a ATTRS{idVendor} deux fois. Le second est supposé être idProduct .

Pour rappel, voici ce que disait le fichier:

# Steam Controller device node write access, per lp:1498655
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", ATTRS{idVendor}=="1102", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", ATTRS{idVendor}=="1142", MODE="0666"
# Steam Controller udev write access, per lp:1498658
KERNEL=="uinput", SUBSYSTEM=="misc", TAG+="uaccess"

Et c'est ce que c'était censé dire (et travaille pour moi):

# Steam Controller device node write access, per lp:1498655
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", ATTRS{idProduct}=="1102", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", ATTRS{idProduct}=="1142", MODE="0666"
# Steam Controller udev write access, per lp:1498658
KERNEL=="uinput", SUBSYSTEM=="misc", TAG+="uaccess"
    
réponse donnée Stephen 19.12.2015 - 03:08
la source
5

Comme noté par Jorge Castro. La solution fonctionne bien. Si vous modifiez le groupe sur users , il couvrira tous les comptes d'utilisateur du système. De cette façon, si votre installation utilise des comptes différents, vous n'avez pas à apporter de modifications au fichier.

    
réponse donnée Kent Seaton 21.10.2015 - 15:43
la source
4

Je viens de recevoir mon Steam Controller, branché sur mon système Ubuntu 15.10 x64 et ça ne fonctionnerait pas du tout. Cependant, j'ai remarqué quelque chose de différent sur le mien qui n’a pas été mentionné ici.

J'ai tapé lsusb au Terminal et ai trouvé ceci:

Bus 001 Device 011: ID 28de:1042

J'ai remarqué que le idProduct indiqué dans les règles par défaut d'udev était "1102" ou "1142". J'ai donc ajouté la ligne suivante à /lib/udev/rules.d/99-steam-perms.rules (sous les autres lignes similaires):

SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", ATTRS{idProduct}=="1042", MODE="0666"

J'ai ensuite débranché le dongle USB, branché et ça marche! Ensuite, il a fait une mise à jour du firmware immédiatement (dans Steam) à "1142" et donc, techniquement, je n'ai plus besoin de la ligne que j'ai ajoutée. J'espère que cela aide quelqu'un d'autre.

    
réponse donnée Monkey 19.12.2015 - 15:52
la source
1

Impossible de faire fonctionner mon contrôleur non plus. Ubuntu 16.04. J'ai placé le texte dans les fichiers comme suggéré par Insperatus, mais toujours pas d'amour.

Au lieu de cela, placez le texte dans un fichier dans /etc/udev/rules.d .

Entrez ceci dans le terminal:   sudoedit /etc/udev/rules.d/99-steam-controller-perms.rules

Ensuite, collez cette réponse :

# This rule is needed for basic functionality of the controller in Steam and keyboard/mouse emulation
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666"


KERNEL=="uinput", MODE="0660", GROUP="users", OPTIONS+="static_node=uinput"

# Valve HID devices over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="28de", MODE="0666"

# Valve HID devices over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*28DE:*", MODE="0666"

# DualShock 4 over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="05c4", MODE="0666"

# DualShock 4 wireless adapter over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0ba0", MODE="0666"

# DualShock 4 Slim over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="09cc", MODE="0666"

# DualShock 4 over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*054C:05C4*", MODE="0666"

# DualShock 4 Slim over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*054C:09CC*", MODE="0666"

J'ai utilisé le bloc de texte ci-dessus et nommé le fichier comme suggéré dans la 1ère réponse: 99-steam-controller-perms.rules

Le contrôleur fonctionne maintenant.

    
réponse donnée user640096 09.01.2017 - 10:00
la source

Lire d'autres questions sur les étiquettes