Comment installer Adobe Flash Player?

101

J'ai eu des problèmes importants en regardant la vidéo flash sur Ubuntu 64 bits. Est-ce que quelqu'un connaît un bon moyen de faire fonctionner Flash sur la plate-forme?

    
posée Steven Oxley 28.07.2010 - 21:27
la source

20 réponses

81

Pour 11.04 et plus tôt:

L'installez-vous à partir du centre logiciel Ubuntu?

  1. Allez à Applications-> Ubuntu Software Center.
  2. Cliquez sur Partenaires Canonical
  3. Cliquez sur le plug-in Adobe Flash 11 et cliquez sur Installer.

Remarque: c'est la méthode que j'utilise sur mon installation Ubuntu 64 bits et qui ne m'a pas encore échoué.

    
réponse donnée Nathan Osman 28.07.2010 - 21:31
la source
68

pour 11.10 et plus tard

Lancez Software Center depuis le lanceur et recherchez flash

Deux entrées seront trouvées. Le premier est le wrapper autour de la version flash 32 bits d'Adobe. La seconde est la version flash 64 bits.

Sélectionnez la seconde entrée flash - si l’image suivante est visible, vous n’avez pas encore activé le référentiel de partenaires Canonical.

Cliquez sur Plus d’informations

... et cliquez sur Utiliser cette source pour activer le référentiel de partenaires Canonical

voir la fin de cette réponse pour le rapport de bogue

Cliquez sur Installer

Cliquez sur le bouton Installer et entrez votre mot de passe lorsque vous y êtes invité. Remarque: vous devez avoir l'autorisation d'installer un logiciel.

L'installation se poursuivra:

Une fois terminé, lancez Firefox et accédez à votre vidéo Flash. Cliquez avec le bouton droit de la souris et confirmez que la dernière version de Flash a été installée correctement.

Remarque - les images sont sujettes à changement - la version 64 bits n’a été récemment mise en ligne que la dernière semaine avant la publication de Oneiric - Un problème existe actuellement:

  1. lien

Entre-temps, utilisez le premier plug-in 32 bits "Multiverse" dans les images ci-dessus ou utilisez adobe-flashplugin

sudo apt-get install adobe-flashplugin
    
réponse donnée fossfreedom 10.10.2011 - 00:52
la source
31

Voici comment installer Adobe Flash Plugin pour Firefox:

  1. Allez à la page cette et sélectionnez l’option .tar.gz pour les autres Linux. Téléchargez le fichier.
  2. Décompressez le plugin tar.gz et copiez les fichiers à l'emplacement approprié.
  3. Enregistrez le plug-in tar.gz localement et notez l'emplacement où le fichier a été enregistré.
  4. Lancez le terminal et changez de répertoire à l'emplacement où le fichier a été enregistré.
  5. Décompressez le fichier tar.gz. Une fois déballé, vous verrez ce qui suit:

    • libflashplayer.so
    • / usr
  6. Identifiez l'emplacement du répertoire des plug-ins du navigateur, en fonction de votre distribution Linux et de la version de Firefox. (Généralement, il s'agit de /usr/lib/mozilla/plugins/ )
    Pour Ubuntu 14.04 , le chemin est: /usr/lib/firefox/browser/plugins

  7. Copiez libflashplayer.so dans le répertoire approprié des plug-ins de navigateur. À l'invite, tapez:

    sudo cp libflashplayer.so <BrowserPluginsLocation>
    
  8. Copiez les fichiers de configuration de Flash Player Local Settings dans le répertoire / usr. A l'invite, tapez:

    sudo cp -r usr/* /usr
    
  9. Redémarrez votre navigateur.

réponse donnée ignite 04.09.2012 - 18:36
la source
21

Depuis que vous avez déclaré que c'était la première fois que vous utilisiez Ubuntu. Je suggère que vous installez le paquet ubuntu-restricted-extras, cela inclut beaucoup de choses utiles comme Adobe Flash et les codecs et les polices MS, etc.

vous pouvez le faire de plusieurs manières.

centre logiciel: Cliquez sur ce lien:

ou dans un terminal: tapez sudo apt-get install ubuntu-restricted-extras

synaptic: recherchez le paquet ubuntu-restricted-extras avec un clic droit sur le paquet et sélectionnez installer, puis sélectionnez marque. après, cliquez sur le bouton Appliquer et tout sera installé.

    
réponse donnée Terry 02.04.2011 - 16:02
la source
13

Il existe une solution simple à ce problème.

Ouvrez votre Firefox et accédez à Youtube . Cliquez sur n'importe quelle vidéo. Certainement, il ne jouera pas parce que vous n'avez pas de lecteur flash installé. Mais Firefox va vous promouvoir à install missing plug-in en haut. Cliquez simplement dessus et suivez la procédure. Après cela, votre vidéo commencera à jouer. Assurez-vous que le dernier navigateur Firefox est installé.

Ou essayez ceci dans votre terminal

sudo apt-get install flashplugin-installer
    
réponse donnée Kaktarua 04.09.2012 - 18:38
la source
5

Obtenez mon extension Flash-Aid pour Firefox. Il se chargera de télécharger et d'installer la version appropriée pour votre architecture système et supprimera également les plugins en conflit. Si vous êtes sur 64 bits, il vous permet également d’installer la version de prévisualisation 64 bits, ce qui donne de meilleurs résultats que le 32 bits avec nspluginwrapper.

BTW, si vous ne pouvez pas copier quelque chose dans le dossier ~ / .mozilla / plugins, vous devriez vérifier la propriété du dossier ~ / .mozilla. Il devrait permettre d'y copier n'importe quoi. À moins bien sûr que vous vous référiez à un dossier système situé en dehors de votre répertoire personnel, qui nécessite des privilèges root.

    
réponse donnée lovinglinux 02.12.2010 - 13:40
la source
4

Cela dépend du navigateur que vous utilisez. Google Chrome (et non Chrome) dispose de Flash Player par défaut.

Accédez à www.google.com/chrome et cliquez sur Télécharger Chrome Choisissez .deb 64 bits (toute personne lisant ceci à l'aide de machines 32 bits doit sélectionner .deb 32 bits)

Lorsque vous cliquez sur le fichier .deb lorsqu’il a été téléchargé, il s’ouvre dans Software Center. Maintenant, cliquez sur installer et quand il est terminé, vous pouvez trouver le navigateur dans Applications - & gt; Internet.

    
réponse donnée Mozart321 02.04.2011 - 22:00
la source
2

Utilisez le centre logiciel Ubuntu (dans le menu Applications). Dans le champ de saisie de texte (du champ de recherche), vous pouvez rechercher "flash" et les résultats rempliront un plug-in Adobe Flash (notez le logo Adobe). Choisissez cette option et suivez les instructions pour utiliser la source.

    
réponse donnée Daniel T Chen 01.12.2010 - 20:14
la source
2

Vérifiez le répertoire "plugin" utilisé. Nous avons dû passer une bonne heure à labourer tous les répertoires de plug-ins jusqu'à ce que je trouve ceux que mon firefox lisait, puis les co-juger tous pour les désigner.

À la fin de la journée, vous pourriez la déposer au mauvais endroit.

En outre, démarrez Firefox à partir de la ligne de commande, vous risquez de rencontrer des erreurs. L'exemple exécute un lecteur flash x86 dans un navigateur x64 (pas os) et vice versa. À partir de la ligne de commande ( ln -s ), vous devriez voir les lignes de journal d'initialisation du plug-in. (peut-être essayer celui-ci en premier: P)

En outre, tout ce qui se trouve dans %> firefox appartient à root, vous devrez donc /usr/lib/...sudo cp libflashplayer.so /usr/lib/firefox/plugin pointe vers l'emplacement du répertoire du plug-in firefox.

    
réponse donnée Dmitriy Likhten 01.12.2010 - 20:51
la source
2

Correction définitive du Flash 64 bits le 11.10

J'ai corrigé le Flash 64 bits sur mes systèmes 11.10 sans aucun emballage. Si vous suivez les solutions mentionnées ci-dessus, vous obtiendrez toujours la version 32 bits et les wrappers.

Remarque: la plupart de ces opérations peuvent également être effectuées dans un terminal. Dans ce cas, vous n'avez pas besoin d'installer Synaptic. De plus, il se peut que l'exécution des étapes 5, 6 et 8 suffise, mais je n'ai pas encore testé cela.

  1. Installer Synaptic (Software Center n'affiche pas le package dont vous avez besoin, pas dans les éléments principaux et pas dans les éléments techniques et même après son installation)
  2. Lancez Synaptic et recherchez «flash»
  3. Trier par état installé
  4. Supprimez tous les packages liés à la mémoire flash (tels que flashplugin-downloader: i386, installateur flashplugin, ndiswrapper-common, etc.). S'il n'y a rien dans la liste, vous n'avez probablement pas installé Flash du tout. Dans ce cas, passez à l'étape suivante.
  5. Activer le référentiel de partenaires Canonical (voir les publications ci-dessus sur la façon de procéder)
  6. Mettez à jour la liste des paquets (ne comptez pas sur Software Center pour cela, parfois pas) en cliquant sur "Recharger" dans
  7. Chercher à nouveau "flash"
  8. Installez le paquet "adobe-flashplugin". Si ce n'est pas dans la liste, quelque chose s'est mal passé avec la mise à jour des listes de paquets. Essayez de quitter et de redémarrer Synapic, puis cliquez sur "Recharger".

Un paquet supplémentaire, "adobe-flash-properties-gtk", sera installé automatiquement. Rien de plus.

Maintenant, vous disposerez d’un Flash 64 bits complet, sans wrappers ni autres erreurs, à la fois dans Firefox et dans Chrome. Un redémarrage de votre (vos) navigateur (s) est cependant nécessaire. Si cela ne fonctionne toujours pas, essayez un redémarrage (il pourrait y avoir de fausses références aux anciens plugins quelque part).

    
réponse donnée iGadget 12.11.2011 - 13:18
la source
2
sudo apt-get remove --purge adobe-flashplugin flashplugin* nspluginwrapper
sudo apt-get install --reinstall adobe-flashplugin

Réf: lien

    
réponse donnée Coc 20.11.2011 - 11:21
la source
2

Voici ce que vous devez faire: par défaut, Ubuntu ne contient que des logiciels open source activés (je pense que c’est le cas, de toute façon).

La façon dont vous activez d’autres éléments (tels que Flash, Java et le support pour l’enregistrement ou la lecture de fichiers MP3, qui n’est PAS open source) est de vous rendre dans votre Software Center, aller dans les menus (malheureusement je ne suis pas actuellement sur Ubuntu) et ne peut pas vous dire quel menu) et rechercher des sources de logiciels.

Cliquez dessus et vous serez amené à une fenêtre qui indique à Ubuntu ce qu’il est autorisé à installer pour vous. En face de vous devrait être une liste de cinq "univers" différents. Ce que vous devez faire est d'activer les deux qui ne sont pas actuellement activés.

Après cela, il devrait vous demander si vous souhaitez recharger vos référentiels, mais si ce n'est pas le cas, entrez une ligne de commande et tapez

sudo apt-get update

et laissez-le finir. Ensuite, vous devriez être capable de trouver Flash dans Software Center ou dans la ligne de commande. Vous pouvez également installer le paquet ubuntu-restricted-extras, qui vous donnera toutes les trois choses que j'ai mentionnées ci-dessus.

Bonne chance!

    
réponse donnée Noah 04.09.2012 - 18:14
la source
2

J'ai parcouru le plus grand nombre de suggestions possibles pour que Flash fonctionne avec Chrome sur mon installation 13.10 64 bits. Rien n'a fonctionné. Je suis finalement tombé sur la réponse de Pepper Flash.

Il y a des instructions complètes et bien écrites sur (lien direct)

ubuntuhandbook.org

Ils détaillent l’ajout du dépôt, la mise à jour de apt, l’installation de Pepper et la modification de la configuration de chrome. La chose que j'ai faite différemment de leurs instructions était de changer pour le répertoire / etc / chrome-browser et de lancer la commande

sudo gedit default

ce qui m'a permis d'ajouter un commentaire au fichier en plus des informations nécessaires sur .sh, donc les dernières lignes de mon fichier par défaut moddé étaient:

# enable Pepper Flash Player Plugin
. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Espérons que cette solution fonctionnera pendant un certain temps.

    
réponse donnée zenpistolero 03.05.2014 - 01:58
la source
2

Les vidéos Flash ne peuvent pas être lues sur une nouvelle installation d'Ubuntu 14.04, même avec adobe-flashplugin du référentiel "partner" - écran noir sur youtube (sauf après avoir paramétrer l'utilisation de HTML5 ), dailymotion, etc. Installation freshplayerplugin (apparemment un wrapper pour le lecteur flash de Chrome) a résolu le problème:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
    
réponse donnée Skippy le Grand Gourou 22.08.2015 - 09:33
la source
1

Au cas où le

sudo apt-get install flashplugin-nonfree

ne fonctionne pas (comme dans mon cas et je ne sais pas pourquoi ...), vous voudrez peut-être essayer Opera comme navigateur. C'est le seul qui fonctionne pour moi.

PS: Je ne veux pas annoncer Opera comme navigateur, c'est juste que c'était la seule solution qui fonctionnait pour moi.

    
réponse donnée Remi Meier 14.08.2010 - 15:19
la source
1

Je viens de trouver une solution pour ceux qui utilisent Flash sur Firefox mais pas sur Chrome. Il est basé sur le fait que chaque navigateur possède son propre répertoire de plugins:

  • / usr / lib / firefox-addons / plugins (pour Firefox)
  • / usr / lib / navigateur-chrome / plugins (pour Chrome)

Donc, la seule chose que vous devez faire est de les unifier, alias en faire un lien vers l’autre. Probablement, tous les plugins sont sur le répertoire des plugins Firefox, mais cela ne vaut pas la peine de s’assurer que:

ls -l /usr/lib/{mozilla,chromium-browser}/plugins

Si Firefox est celui où se trouvent tous les plugins, faites le suivant. Sinon, faites le contraire:

sudo rmdir /usr/lib/chromium-browser/plugins
sudo ln -s /usr/lib/mozilla/plugins /usr/lib/chromium-browser/

Enfin, redémarrez Chrome pour que les modifications prennent effet.

Probablement, ce ne serait pas une mauvaise idée de créer un rapport de bogue sur les responsables de paquets Chromium / Firefox pour alerter sur le bogue et la solution simple.

    
réponse donnée emi 16.08.2012 - 19:19
la source
1

Eh bien, je poste ceci ici, dans l'espoir d'aider quelqu'un. Je vais dire ce qui se passait et comment je l'ai résolu.

SETUP:
    Exécution de 12.04 depuis une installation WUBI.

PROBLÈME:
    Lorsque je cherchais dans le Centre de logiciels Ubuntu le mot-clé flash , aucune des options affichées ici n'apparaissait à l'exception de ONE pour flash plugin pour Mozilla. En essayant de l'installer, j'ai eu une erreur de dépendance.

J'ai essayé de l’installer avec les Extras restreints d’Ubuntu à partir du Centre logiciel Ubuntu, mais la partie Flash de cette installation ne fonctionnait pas à cause de l’erreur de dépendance.

Nous avons recherché et avons trouvé cette commande pour installer le plugin

sudo apt-get install flashplugin-nonfree

et l'a exécuté depuis le terminal.

Même erreur de dépendance avec cette sortie:

Reading package lists... Done Building dependency tree        
Reading state information... Done Note, selecting 'flashplugin-installer' instead of 'flashplugin-nonfree' 
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. 
The following information may help to resolve the situation:
The following packages have unmet dependencies:  
 flashplugin-installer : 
 Depends: libnspr4-0d but it is not going to be installed E: Unable to correct problems, you have held broken packages.

SOLUTION

J'ai couru

sudo apt-get install -f 

puis

sudo apt-get update 

que j'ai trouvé depuis un autre poste qui essayait de résoudre des dépendances.

Puis j'ai couru

sudo apt-get install flashplugin-nonfree

et le plugin flash fonctionne désormais sur Chromium et Firefox.

    
réponse donnée Joel 02.10.2012 - 17:55
la source
1

Cela dépend de votre installation. est-ce via un fichier tar.gz ou rpm ou une autre méthode. Il existe de nombreuses façons d’obtenir le flash.

Download link: https://get.adobe.com/flashplayer/

Installation instructions
-------------------------

Installing using the plugin tar.gz:
    o Unpack the plugin tar.gz and copy the files to the appropriate location.  
    o Save the plugin tar.gz locally and note the location the file was saved to.
    o Launch terminal and change directories to the location the file was saved to.
    o Unpack the tar.gz file.  Once unpacked you will see the following:
        + libflashplayer.so
        + /usr
    o Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version
    o Copy libflashplayer.so to the appropriate browser plugins directory.  At the prompt type:
        + cp libflashlayer.so <BrowserPluginsLocation>
    o Copy the Flash Player Local Settings configurations files to the /usr directory.  At the prompt type:
        + sudo cp -r usr/* /usr

Installing the plugin using RPM:
   o As root, enter in terminal:
          + # rpm -Uvh <rpm_package_file>
          + Click Enter key and follow prompts

Installing the standalone player:
   o Unpack the tar.gz file
   o To execute the standalone player,
          + Double-click, or 
          + Enter in terminal: ./flashplayer

Bonus:

Uninstallation instructions
---------------------------

Manual uninstallation (for users who installed the plugin via Install script):
   o Delete libflashplayer.so binary and flashplayer.xpt file in 
   directory /home/<user>/.mozilla/plugins/

RPM uninstallation:
   o As root, enter in terminal:
          + # rpm -e flash-plugin
          + Click Enter key and follow prompts
    
réponse donnée Revanth Kumar 02.05.2015 - 03:59
la source
0

J'ai vérifié de nombreuses réponses à ce sujet la semaine dernière. Enfin, j'ai trouvé un lien avec une solution qui fonctionne:

lien

En gros, la réponse est qu’elle semble être supprimée de toutes les sources de logiciels et que vous devez télécharger une ancienne version et l’installer manuellement

    
réponse donnée palbeda 12.04.2017 - 16:33
la source
0
  

Linux ne prend plus en charge Adobe Flash Player dans son magasin. Par conséquent, vous devez le faire manuellement.

  

Ceci n'est vérifié que sur Firefox, même si vous avez Chrome / Chromium, vous n'avez pas à l'installer.

Il existe une procédure d’installation manuelle d’Adobe Flash Player sur Ubuntu, procédez comme suit: -

  1. Ouvrez ce lien . Il vous proposera automatiquement une version en fonction de votre environnement de bureau.

  2. Sélectionnez l’option .tar.gz for Linux comme indiqué ci-dessous.

  3. Cliquez maintenant sur le bouton Télécharger (sélectionnez le chemin de téléchargement sous Téléchargements sur votre système pour y accéder facilement).

  4. Maintenant, extrayez le fichier par Right clicking sur le dossier et en sélectionnant l'option Extract Here .

  5. Ouvrez Terminal CTRL+ALT+T et copiez ci-dessous la commande un par un

    5.1. cd ../

    5.2. cd your-pc-name (ex: paper96)

    5.3. cd Downloads (il s'agit du dossier dans lequel vous avez téléchargé le fichier dans Option 3 ).

    5.4. cd flash_player_npapi_linux.x86_64 (Votre nom de fichier peut être différent, copiez simplement le nom du fichier et collez-le dans le terminal)

    5.5. sudo mv libflashplayer.so \/usr/lib/firefox-addons/plugins appuyez sur Entrée et c'est tout.

  6. Fermez maintenant votre navigateur (Firefox) et votre terminal.

  7. Redémarrez Firefox et vous avez maintenant Flash Player dans votre navigateur. Consultez ce lien pour vérifier.

réponse donnée Pankaj Gautam 17.07.2017 - 09:52
la source

Lire d'autres questions sur les étiquettes