Installer gcc sur Ubuntu 12.04 LTS

44

Lorsque j'essaie d'installer gcc sur Ubuntu 12.04 LTS Server avec apt-get install gcc , j'obtiens l'erreur suivante:

The following packages have unmet dependencies:
 gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) but it is not going to be installed
       Depends: gcc-4.6 (>= 4.6.1-1) but it is not going to be installed
       Recommends: libc6-dev but it is not going to be installed or
                   libc-dev

Lorsque je fouille plus profondément (c’est-à-dire que vous essayez de apt-get install gcc-4.6 ), je reçois:

 gcc-4.6 : Depends: gcc-4.6-base (= 4.6.1-9ubuntu3) but 4.6.3-1ubuntu5 is to be installed
           Depends: cpp-4.6 (= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libgomp1 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libquadmath0 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed

Donc, quand j'essaie d'installer gcc-4.6=4.6.1-9ubuntu3 , j'obtiens une liste de 366 paquets à supprimer (par exemple apt ). Ce qui est la folie.

Il s’agit d’une installation essentiellement du serveur Ubuntu 12.04 LTS (c’est-à-dire que j’utilise nginx, python-flup, python-yaml, rsync, python-pkg-resources, lsof, fontconfig, iptables, ufw, scons et grc).

Il est très surprenant que je ne puisse pas installer gcc, donc je suis un peu perplexe quant à la tentative d’installation de gcc échoue. Le seul correctif apparent semble être la désinstallation de 366 paquets, dont beaucoup sont essentiels au fonctionnement d’Ubuntu.

Quelque chose ne s’ajoute pas et je vous serais très reconnaissant de votre aide.

EDIT Ce qui précède concerne les derniers packages, bien sûr, après avoir utilisé apt-get update; apt-get upgrade avant d’essayer ce qui précède. Désolé, j'aurais dû le mentionner.

    
posée Brian M. Hunt 22.06.2012 - 02:49
la source

3 réponses

78

Il y a un métapaquet appelé build-essential qui devrait installer le compilateur et un tas de paquets liés / nécessaires:

sudo apt-get install build-essential

La suggestion de faire d'abord sudo apt-get update est le son, cela mettra à jour les listes de paquets et toutes les versions devraient bien correspondre.

C'est, cependant, si vous n'avez pas modifié votre fichier /etc/apt/sources.list manuellement. Si tel est le cas, certaines des modifications que vous avez apportées ou les référentiels que vous avez ajoutés contiennent peut-être des packages en conflit qui provoquent les problèmes que vous rencontrez. Si tel est le cas, consultez le fichier et corrigez les entrées problématiques. Bien sûr, si vous voulez de l’aide, vous pouvez poster votre fichier sources.list (ou tout fragment dans /etc/apt/sources.list.d ) et peut-être que quelqu'un peut vous aider à le réparer.

    
réponse donnée roadmr 22.06.2012 - 03:08
la source
4

Essayez de continuer à aller plus loin:

sudo apt-get update
sudo apt-get install gcc-4.6-base cpp-4.6 libgomp1 libquadmath0 libc6-dev
    
réponse donnée David M. Sousa 22.06.2012 - 02:58
la source
0

Commencez par écrire la commande:

sudo apt-get update.

Puis essayez:

sudo apt-get install gcc

J'ai fait ça et ça a marché! Vous devriez aussi l'essayer.

Si ça ne marche pas alors:

sudo apt-get install build-essential

Alors, essayez. J'espère que ça va marcher!

    
réponse donnée Master Programmer 01.10.2015 - 12:48
la source

Lire d'autres questions sur les étiquettes