erreur db5 (-30969) à partir de dbenv-open: BDB0091 DB_VERSION_MISMATCH: non-concordance de version de l'environnement de base de données

6

J'utilise Ubuntu 14.04 LTS et j'essaye de décompresser le fichier rpm comme

sudo alien --scripts -d oracle-xe-11.2.0-1.0.x86_64.rpm

Je deviens comme

error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /root/.rpmdb

S'il vous plait, aidez-moi

    
posée user3270288 25.06.2014 - 04:18
la source

2 réponses

12

Cela n’a rien à voir avec Oracle. Supprimez le répertoire ~/.rpmdb/ et réessayez.

    
réponse donnée Pero 17.07.2014 - 13:32
la source
1

Je suis allé sur le site Web d’Oracle, puis j'ai parlé de Google pendant un bon moment sur celui-ci. Franchement, je pense que vous regardez une installation très difficile, et vous devrez passer beaucoup de temps de qualité avec votre moteur de recherche pour que cela fonctionne. Oracle n'aime pas beaucoup Ubuntu!

La manière la plus simple d’implémenter Oracle que j’ai trouvée est d’exécuter Oracle Linux, un dérivé de RedHat (?) en tant que VM dans VirtualBox, auquel cas Oracle Express doit s’installer de manière transparente.

En fait, pour faciliter encore plus les choses, vous pouvez télécharger une machine virtuelle préinstallée avec une version relativement récente d’Oracle Linux et Oracle Express 12g à ces pages . La "VM de la plateforme de prestation de services" ressemble à un bon pari.

    
réponse donnée Charles Green 25.06.2014 - 04:47
la source

Lire d'autres questions sur les étiquettes