Impossible de changer la luminosité dans Ubuntu 16.04 LTS

42

Je suis nouveau sur les systèmes Linux en général (j'utilise Ubuntu 16.04 LTS) et j'ai du mal à changer la luminosité de mon ordinateur portable.

Quand j'utilise le Fn + F8 ou Fn + F9 la barre de luminosité apparaît mais il y a aucun changement dans la luminosité réelle de l'écran.

J'ai essayé toutes les méthodes décrites dans cet article ( Comment ajuster la luminosité de l'écran dans Ubuntu 14.04 (Trusty Tahr)? ) sans succès. L'installation et l'utilisation de xbacklight n'ont aucun effet, de même que l'édition du fichier de luminosité dans le fichier "intel_backlight".

Quelqu'un sait comment résoudre ce problème?

    
posée Andrei 26.04.2016 - 00:15
la source

7 réponses

51

Cela ne fait pas fonctionner vos touches de fonction de luminosité, mais est un workround.

Installez Brightness Controller avec les commandes suivantes:

sudo add-apt-repository ppa:apandada1/brightness-controller
sudo apt update

Pour la version 1 avec jusqu'à 4 Monitor Support:

sudo apt install brightness-controller-simple

Pour la version 2 avec prise en charge de Multi Monitor et d’autres fonctionnalités:

sudo apt install brightness-controller

Remarque: Cela ne diminue pas l’intensité du rétroéclairage, vous ne pourrez donc pas économiser vos piles. Mais vous pouvez l'utiliser en dernier recours pour sauver vos yeux. Cela fonctionne également dans les bureaux, où il n’ya pas d’option pour contrôler la luminosité.

    
réponse donnée Archisman Panigrahi 26.04.2016 - 11:09
la source
23

Pre Ubuntu LTS 16.04

Sous (X) Ubuntu 14.04 LTS, contrôle de la luminosité sur mes Panasonic Toughbook CF-52 a bien fonctionné en ajoutant acpi_osi=Linux à la ligne GRUB_CMDLINE_LINUX_DEFAULT= dans /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

et émettre

$ sudo update-grub

après l'édition et avant le redémarrage.

Depuis Ubuntu LTS 16.04

Cependant, la solution ci-dessus a cessé de fonctionner après la mise à niveau vers (X) Ubuntu LTS 16.04. Cela semble être typique pour les ordinateurs portables dotés de graphiques vidéo Intel intégrés.

Pour savoir si vous avez intégré les graphiques vidéo Intel, entrez la commande suivante:

$ ls /sys/class/backlight/
    intel_backlight  panasonic

Au moins intel_backlight doit être mentionné, probablement en plus d'un nom OEM, par exemple panasonic , dell_backlight , etc.

Si tel est le cas, procédez à la création du fichier suivant

$ sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

contenant les lignes suivantes:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

Redémarrez et profitez de vos boutons de rétro-éclairage!

Source

    
réponse donnée Serge Stroobandt 11.12.2016 - 16:27
la source
5

Une autre option est l’application Redshift , qui, en plus de régler la luminosité, peut également ajuster la température de couleur pour réduire la lumière bleue la nuit. .

Exemple d'utilisation: redshift -b 0.8 définira la luminosité sur 0,8 sur une échelle de 0 à 1

    
réponse donnée xji 03.07.2016 - 14:52
la source
3

J'utilise Lenovo Z570 et l'ajout de acpi_backlight=none à /etc/default/grub et la mise à jour de grub ont parfaitement fonctionné avec la clé Fn .

    
réponse donnée sanjay Joshi 14.05.2016 - 08:39
la source
1

En 16.04, il existe un paquetage appelé "indicateur de rétro-éclairage" qui utilisera votre appareil photo pour définir le rétroéclairage (ou non) et le régler de manière différentielle pour une utilisation sur secteur et / ou sur batterie.

    
réponse donnée Andor Kiss 19.05.2016 - 18:52
la source
0

J'ai corrigé cela sur mon Asus UX303UB avec une petite différence:

  • défini sur GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" (acpi_osi = l'a fait pour moi, les autres options ne fonctionnaient pas, cela provient de ici ). Bien sûr, après cette exécution, update-grub . Cela permet aux touches de fonction de répondre en affichant la notification Ubuntu, mais ne change pas vraiment la luminosité. Une autre chose tirée d'autres réponses:
  • sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

avec le contenu:

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection

Le seul problème est d’associer Fn + F7 à xset dpms force standby pour désactiver l’écran.

    
réponse donnée Pablo Bianchi 19.12.2016 - 04:48
la source
0

Dans mon cas, le problème était dû à un problème avec mes pilotes graphiques. Les changer en une version stable a résolu le problème.

    
réponse donnée sv_jan5 04.07.2017 - 06:14
la source

Lire d'autres questions sur les étiquettes