Comment désactiver la session invité?

180

Comment puis-je désactiver la session invité dans Ubuntu 11.10 ou supérieur? Je ne veux pas que les gens puissent utiliser mon ordinateur sans utiliser de mot de passe pour se connecter!

    
posée Jeremy Bicha 22.09.2011 - 17:45
la source

12 réponses

116

Mis à jour: août 2016

Pour Ubuntu 16.04 LTS (15.10 ou supérieur)

Adapté de: Wiki LightDM Ubuntu - Configuration

  • Les fichiers de configuration fournis par le système dans /usr/share/lightdm/ ne sont pas destinés à être édités par l'utilisateur . Au lieu de cela, les utilisateurs doivent utiliser: /etc/lightdm/
  • Les nouvelles versions de LightDM (Ubuntu 15.10 ou ultérieur) utilisent [Seat:*] au lieu de [SeatDefaults]

Il suffit de lancer ceci une fois au terminal:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Pour annuler (restaurer l'option Invité), supprimez le fichier créé :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Pour Ubuntu 14.04 LTS (jusqu'à 15.04)

Adapté de: Forums Ubuntu - Emplacement des fichiers de configuration lightdm dans 14.04

Il suffit de lancer ceci une fois au terminal:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Vous n’aurez plus d’option «Invité» lors de votre prochaine connexion.

Pour annuler (restaurer l'option Invité), supprimez le fichier créé :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Pour Ubuntu 12.04 LTS (jusqu'à 13.10)

Méthode la plus simple

Il suffit de lancer ceci une fois au terminal:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Vous n’aurez plus d’option «Invité» lors de votre prochaine connexion.

  • Ceci ajoute simplement allow-guest=false à /etc/lightdm/lightdm.conf .

  • Devrait fonctionner à partir de 11.10 (car ceux-ci utilisent également LightDM ).

Pour annuler (restaurer l'option Invité):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
réponse donnée david6 28.07.2012 - 01:38
la source
113
  

Utilisez cette méthode uniquement si vous utilisez Ubuntu Desktop. Si vous utilisez une autre version telle que Xubuntu ou Lubuntu, veuillez vous reporter à cette réponse .

Si vous utilisez le LightDM par défaut, éditez /etc/lightdm/lightdm.conf pour qu'il ressemble à ceci:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Si vous utilisez GDM (qui était la version par défaut dans les précédentes versions d'Ubuntu), désinstallez gdm-guest-session .

Pour Ubuntu 13.10 à 14.10 , le fichier a été déplacé vers /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Pour Ubuntu 14.10 ou supérieur, le fichier a été déplacé vers /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
réponse donnée Jeremy Bicha 22.09.2011 - 17:48
la source
23

Tapez ceci dans le terminal

gksu gedit /etc/lightdm/lightdm.conf

Vous verrez ce qui suit:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Ajoutez allow-guest=false à la fin afin que votre résultat final ressemble à:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Enregistrez le document et quittez l'éditeur de texte.

De retour dans le terminal, redémarrez le gestionnaire d’affichage. (Ceci mettra fin à la session de connexion graphique, quitte immédiatement tous les programmes qui s’y exécutent, alors assurez-vous que votre travail - comme tout document ouvert - est enregistré en premier!)

sudo restart lightdm

Une fois la session de connexion graphique terminée, vous revenez à l’écran de connexion, où vous remarquerez que le compte invité est désactivé.

C'est ça - le compte invité n’est plus utilisable.

    
réponse donnée sarveshlad 25.10.2011 - 03:08
la source
16

Vous pouvez le faire en utilisant Ubuntu Tweak .

Pour l'installer, utilisez ces commandes:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Après l’installation, accédez à Tweaks Paramètres de connexion et désactivez le "Compte invité".

    
réponse donnée Eliran Malka 21.10.2012 - 19:54
la source
11

Il suffit de courir

gksudo gedit /etc/lightdm/lightdm.conf

Ajoutez la ligne suivante

allow-guest=false

Ensuite (ceci vous déconnectera immédiatement, quitte tous les programmes en cours d’exécution dans votre session graphique, sauvegardez donc votre travail d’abord):

sudo restart lightdm
    
réponse donnée LnxSlck 27.07.2012 - 18:42
la source
3

Pour Ubuntu 13.10 , ajoutez

allow-guest=false

au fichier /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
réponse donnée uahummer 20.10.2013 - 15:27
la source
3

13.04 et plus tard

  1. Exécuter cette commande dans un terminal

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Redémarrez votre machine ou redémarrez lightdm avec la commande suivante
    (Cela vous déconnectera immédiatement, enregistrez vos données)

    sudo restart lightdm
    

Apparemment, cela fonctionne en 13.10 (ne peut pas tester moi-même, mais il y a un commentaire ici ).

J'utilise 13.04 et tout cela ajoute allow-guest=false à /etc/lightdm/lightdm.conf , mais cela pourrait être différent en 13.10.

À l'origine par david6 d'ici: lien

    
réponse donnée kiri 21.10.2013 - 09:33
la source
3

Comment désactiver cette option à l'avenir

Je viens de rencontrer le même problème sur ma nouvelle installation trusty / 14.04. À ma grande surprise, je n’ai pas pu trouver le dossier lightdm.conf.d dans /etc/lightdm/ just users.conf .

Enquête

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, vous êtes là. Qu'y a-t-il là?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Ok, qu'est-ce qu'il y a là?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Conclusion

Nous trouvons un tas de fichiers de configuration similaires au format INI suivant le schéma de nommage de 50-${some-descriptive-name}.conf et la configuration des clés pour la section [SeatDefaults] .

Nous n'éditerons aucun de ces fichiers car ils sont destinés à être gérés par le gestionnaire de paquets, mais nous allons maintenant ajouter et gérer notre bits de configuration personnalisée vers /etc .

solution

Compte tenu de ce qui précède, lightdm est le gestionnaire d'affichage et les fichiers de configuration ressemblent à ce qui précède. La solution suivante devrait fonctionner:

  1. Créez les répertoires manquants:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Ajoutez un fichier de configuration personnalisé en exécutant:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    et collez les lignes suivantes:

    [SeatDefaults]
    allow-guest=false
    

    Puis sauvegardez ( Ctrl + O ) et fermez ( Ctrl + X ).

  3. Maintenant, déconnectez-vous et passez à un terminal virtuel ( Ctrl + Alt + F1 ), puis exécutez:

    $ sudo service lightdm restart
    

    L’option de session d’invité devrait maintenant disparaître. Si quelque chose ne fonctionne pas correctement, vous savez maintenant où la configuration par défaut est stockée et que vous ne l'avez pas modifiée.

Lectures complémentaires

réponse donnée LiveWireBT 16.03.2014 - 03:32
la source
2

Installez ubuntu-tweak, accédez à l'onglet tweak, désactivez le bouton invité et redémarrez. C'est tout!

On peut trouver le terminal plus facile, mais si le compte invité doit être activé, il faudra consulter à nouveau cette page et voir les instructions (ou plutôt annuler). C'est l'avantage de la chose GUI ... on s'en souvient facilement.

    
réponse donnée tadatma 27.09.2012 - 19:33
la source
2

Remplacez allow-guest=true par 'false' in /etc/lightdm/lightdm.conf

Vous pouvez ensuite redémarrer ou redémarrer le service dans le terminal:

sudo restart lightdm

En supposant que vous utilisez lightdm , qui est standard dans 11.10.

    
réponse donnée filescraps 21.10.2011 - 12:42
la source
0

Je suis dans le même cas, le fichier /etc/lightdm/lightdm.conf n’existe pas dans UBUNTU 13.10.

J'essaie de créer le fichier /etc/lightdm/lightdm.conf avec cette ligne allow-guest=false et CRASH, le système ne démarre pas correctement, seul le mode console ...

J'essaie de modifier le fichier /etc/lightdm/lightdm.conf.d/10-ubuntu.conf et fonctionne correctement.

Modifier le fichier

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

Et entrez les lignes dont vous avez besoin

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

Et le dernier, redémarrez votre système

sudo reboot

Je pense que cela fonctionne bien si vous redémarrez uniquement le ligthgdm

sudo service lightdm restart
    
réponse donnée Foncu 23.10.2013 - 16:05
la source
0

Terminal ouvert

gksudo gedit /etc/lightdm/lightdm.conf

Ajoutez la ligne suivante

allow-guest=false

Enregistrez et quittez le fichier.

    
réponse donnée scouser73 21.10.2013 - 09:29
la source

Lire d'autres questions sur les étiquettes