Enceinte Bluetooth: mode préféré "Lecture haute fidélité" (A2DP) n'est pas enregistrée

38

MISE À JOUR août 2017: La solution identifiée comme acceptée par moi semble avoir fonctionné jusqu'à Ubuntu 15.10. Pour 16.04+, choisissez l'une des solutions les plus récentes.

Pour 16.04+, le fichier de configuration est /etc/bluetooth/main.conf NOT /etc/bluetooth/audio.conf.

J'ai un haut-parleur bluetooth, Sony SRS-BTX300, qui fonctionne sous Linux / Ubuntu 13.04, mais seulement après un peu de bidouillage. (Mise à jour décembre 2013: les mêmes problèmes persistent en 13.10)

Je dois définir le mode de bande passante préféré sur "Lecture haute fidélité" (A2DP) après chaque mise sous tension de l'ordinateur et la reconnexion du haut-parleur.

Le mode se réinitialise à "téléphonie / duplex" (= faible bande passante) à chaque fois. Il faut environ 20 clics pour réinitialiser le haut-parleur, (cliquez sur le menu, déconnectez-vous, reconnectez-vous, sélectionnez le mode, testez), et ces clics sont certainement trop nombreux.

Comment puis-je faire du mode "A2DP" le mode par défaut, et ce de manière persistante?

Quelques captures d'écran vont illustrer.

Après avoir choisi ce menu en cliquant sur l’icône Bluetooth dans le panneau supérieur dans Unity ...

Après avoir configuré cela ...

... le mode préféré sera réinitialisé après le redémarrage / la suspension de l'ordinateur

    
posée knb 14.07.2013 - 11:04
la source

5 réponses

22

Il existe une option dans /etc/bluetooth/audio.conf appelée AutoConnect=true qui est extraite.

sudo nano /etc/bluetooth/audio.conf

Supprimer le "#" au début de la ligne AutoConnect = true

J'ai trouvé cette option activée en supprimant # et en reliant correctement mon casque Bluetooth

Redémarrez le service Bluetooth pour que la modification prenne effet:

sudo service bluetooth restart
    
réponse donnée Joe 21.12.2014 - 14:12
la source
21

Ajoutez la ligne suivante à /etc/bluetooth/audio.conf :

[General]
Disable=Headset

puis exécutez cette commande:

sudo service bluetooth restart

Discussion: (Natty) Connectez uniquement le profil A2DP pour le casque Bluetooth.

    
réponse donnée amagnoni 11.02.2014 - 03:07
la source
4

Pour ceux qui se demandent, j'ai trouvé dans Ubuntu 16.04 il y a une légère différence avec la réponse:

sudo gedit /etc/bluetooth/main.conf

Et mettez à jour la ligne suivante

#AutoEnable=false

à

AutoEnable=true

Suivi par

sudo service bluetooth restart

Pour moi, le profil audio a été défini sur A2DP Sink lors de la connexion d’un périphérique audio Bluetooth.

    
réponse donnée N.AbdullaSunderland 02.09.2017 - 13:01
la source
3

J'utilise Gnome3 et après un certain temps, mon oreillette n'est plus connectée à A2DP. J'ai dû arrêter Gnome en créant un démon pulseaudio en créant le fichier /var/lib/gdm3/.config/pulse/client.conf (en tant que root) et en y ajoutant les lignes suivantes:

autospawn = no
daemon-binary = /bin/true

Puis définissez le propriétaire sur gdm:

sudo chown gdm:gdm /var/lib/gdm3/.config/pulse/client.conf

Ensuite, déconnectez-vous ou recherchez le processus pulseaudio en cours d'exécution en tant qu'utilisateur gdm avec ps aux | grep pulse

La sortie

(découpée) ressemble à:

gdm       2943  10616 ?        S<l  Sep01   0:00 /usr/bin/pulseaudio..

Puis tuez le processus avec kill <pid> qui pour moi était 2943

En exécutant bluetoothctl et en vous connectant à nouveau, je pouvais alors exécuter pacmd list-cards et trouver mon périphérique index: 2 et passer à a2dp_sink avec pacmd set-card-profile 2 a2dp_sink .

Enfin, encore travailler!

    
réponse donnée Dylan 30.08.2017 - 07:23
la source
0

Afin de basculer automatiquement l’audio sur le périphérique Bluetooth A2DP lorsqu’il est connecté à Ubuntu 14.04, j’ai suivi les instructions de lien et cela a fonctionné parfaitement.

Modifiez /etc/pulse/default.pa pour basculer automatiquement le récepteur pulseaudio sur Bluez:

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
load-module module-switch-on-connect  # Add this
.endif

Modifiez /etc/bluetooth/audio.conf pour sélectionner automatiquement le profil A2DP (au lieu de HSP / HFP):

[General]
Disable=Headset # Add this

Appliquer les modifications:

pulseaudio -k # Restarts pulseaudio
sudo service bluetooth restart # Restarts BT

Plus d’informations sur: lien

    
réponse donnée Caumons 11.10.2017 - 10:35
la source

Lire d'autres questions sur les étiquettes