Deux applications de moniteur s'ouvrant sur un mauvais moniteur

39

Je suis nouveau sur Ubuntu, l’utilise depuis environ un mois maintenant. J'ai créé ce bureau pour my tv, et j'utilise donc une configuration à deux écrans (un moniteur pour regarder les émissions et un pour tout le reste). Mais parce que je n'ai pas le tuner (pour l'instant), j'utilise simplement le bureau hulu et certains fichiers vidéo que j'ai déjà. Le problème est que lorsque j'ouvre certaines applications, telles que Firefox, elles s'ouvrent sur le moniteur qui lit la vidéo. Parfois, ils s'ouvrent même derrière l'application vidéo. Existe-t-il un moyen de coller des applications sur un moniteur donné, de manière à ce qu'il s'ouvre toujours sur cette application?

J'allais publier une image de l'écran de configuration de l'affichage, mais je ne suis pas prêt à publier des images. Si vous avez besoin de voir une image, faites le moi savoir et je vous l'enverrai par e-mail. l'image montre juste mes deux écrans, un 20 "à droite et un inconnu à gauche. Le bouton" Même image dans tous les moniteurs "n'est pas coché.

Le samsung est le moniteur sur lequel je veux l’ouvrir, et l’inconnu est le téléviseur sur lequel je regarde les vidéos. Firefox, en particulier, s’ouvre toujours à la télévision chaque fois qu’il est fermé alors qu’il est agrandi, et s’ouvre sur l’écran où il est fermé quand il est fermé alors qu’il n’est pas agrandi. C'est le plus gros ennui que j'ai avec Ubuntu. Je viens d'ubuntu à partir de mac, et j'ai une expérience de base à niveau intermédiaire.

    
posée chazwh 28.10.2010 - 06:14
la source

8 réponses

27

Si vous n'avez pas CompizConfig, installez-le (vous en avez de toute façon besoin). Accédez à Gestionnaire de paramètres CompizConfig & gt; Gestion des fenêtres & gt; Placez Windows (assurez-vous que ce plugin est coché). Sous l'onglet Général, vous voyez l'option Multi Output Mode. Vous avez des options telles que: Utiliser un périphérique de sortie actif ou Utiliser un périphérique de sortie avec un pointeur, etc.

    
réponse donnée Vadim 12.05.2011 - 21:03
la source
9

Il m’est arrivé quelque chose de similaire il ya quelque temps. Essayez d'aller à System & gt; Préférences & gt; Moniteurs Assurez-vous que le moniteur principal (votre moniteur de travail) est à gauche et non à droite. Si les deux moniteurs sont différents, assurez-vous qu'ils s'alignent tous les deux en haut. J'ai remarqué cela avec ma configuration il y a quelques mois lorsque j'ai installé un moniteur utilisant une résolution supérieure à celle de mon moniteur de travail.

    
réponse donnée Jordon Bedwell 31.10.2010 - 07:34
la source
5

Un autre choix consiste à utiliser devilspie. Vous pouvez obtenir Devilspie du référentiel de l'univers.

    
réponse donnée SpaceGhost 03.11.2010 - 20:51
la source
3

Je crois (si vous avez activé compiz) que vous pouvez le faire depuis le gestionnaire de paramètres compiz en utilisant le plug-in place windows. Je ne l'ai pas fait moi-même, mais si vous jouez un peu avec les options, vous devriez pouvoir afficher la fenêtre sur le moniteur souhaité.

    
réponse donnée RolandiXor 28.10.2010 - 19:24
la source
2

Je l'ai corrigé en utilisant compiz-config-manager. installer en utilisant

sudo apt-get install compizconfig-settings-manager

Aller à General & gt; Options générales & gt; Paramètres d'affichage

Définissez le traitement de la sortie par chevauchement sur l’écran que vous préférez (le plus petit ou le plus grand, pas sûr de savoir quoi faire lorsque vous avez des moniteurs de taille égale?).

La définition correcte du champ de texte Outputs avec vos résolutions d'écran respectives semble aider à mieux placer les fenêtres.

    
réponse donnée Gerard 15.03.2013 - 02:26
la source
2

Dans System- & gt; Préférences, sélectionnez Monitors. Cochez "Afficher les moniteurs dans le panneau" puis cliquez sur le moniteur que vous voulez par défaut et appuyez sur le bouton "Définir par défaut". Déconnectez-vous et revenez et voilà.

J'ai essayé ceci quelques fois et cela n'a jamais pris jusqu'à ce que je vérifie la case "Afficher les moniteurs dans le panneau".

    
réponse donnée WebWeasel 07.04.2011 - 04:37
la source
0

Cliquez avec le bouton droit sur la barre de titre de la fenêtre et sélectionnez: More Actions -co Window Manager Settings . Choisissez Focus dans la colonne de gauche. Activer l'option Active screen follows mouse .

Si aucun autre paramètre par défaut n’est spécifié, des fenêtres apparaissent sur l’écran actuellement actif. Avec la procédure décrite ci-dessus, la position de la souris définit cet écran actif.

    
réponse donnée BiberBb 25.04.2014 - 18:05
la source
0

Dans "Affichages" à l’aide de la liste déroulante "Emplacement du lanceur", sélectionnez le moniteur sur lequel les applications doivent s’ouvrir.

    
réponse donnée Aaron 15.12.2017 - 22:05
la source

Lire d'autres questions sur les étiquettes