Comment installer glib?

33

Je veux construire l’empathie dans Ubuntu 11.04. Lorsque je suis le processus de construction,

 ./autogen.sh

Le shell m'a dit que

libtoolize: copying file 'm4/lt~obsolete.m4'
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.67
checking for automake >= 1.9...
testing automake-1.11... found 1.11.1
checking for libtool >= 1.5...
testing libtoolize... found 2.2.6b
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build Empathy.  Download the appropriate package for
from your distribution or get the source tarball at
ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz

Mais quand je ne peux pas trouver le moyen d'installer glib. Que devrais-je faire pour l'installer dans Ubuntu 11?

    
posée Kim 23.08.2011 - 06:47
la source

3 réponses

77

Vous avez besoin de libglib2.0-dev pour glib-gettext. Vous pouvez l'installer avec

sudo apt-get install libglib2.0-dev
    
réponse donnée binW 23.08.2011 - 14:40
la source
4

vous devez également installer libgtk2.0-dev pour pouvoir installer complètement glib (glib fait partie de: libgtk2.0-dev)

sudo apt-get install libgtk2.0-dev

voir ce lien pour plus d'explications: installer gtk et glib

    
réponse donnée Ali.A 21.10.2013 - 18:56
la source
3

Je vous recommande de rechercher les ppa disponibles si vous souhaitez simplement vérifier la nouvelle empathie que vous avez. Je pense que cette ppa est le meilleur pari ou simplement faire ceci

sudo add-apt-repository ppa:telepathy/ppa

Ou si vous avez besoin de le construire.

sudo apt-get build-dep empathy

qui installera toutes les dépendances requises pour créer de l’empathie à partir des sources.

    
réponse donnée sagarchalise 23.08.2011 - 07:10
la source

Lire d'autres questions sur les étiquettes