Impossible de passer d'Intel à NVIDIA GPU

41

[Ubuntu 14.04 64bit]

Après avoir basculé entre les graphiques Intel / NVIDIA et les différents pilotes NVIDIA, je suis maintenant soudainement coincé avec le GPU Intel. Il n'y avait aucun problème à changer entre les deux - je ne peux pas dire avec certitude ce qui cause soudainement le problème. Je pense que la dernière chose que j'ai faite a été de passer au pilote "X.Org X server" - alors quelque chose s'est cassé. Le changement faisait partie de mes tentatives pour résoudre les problèmes liés à la configuration d'un écran secondaire .

Chaque fois que j'essaie de passer à NVIDIA, je reçois ce message d'erreur très expressif, puis il retourne à Intel: /

Je pourrais vous aider avec le dépannage ou des suggestions sur ce qu’il faut essayer.

Jusqu'à présent, j'ai (un / re) installé les différents paquets "nvidia-settings" / "nvidia-current" / "nvidia-current-updates" / "nvidia-331" / "nvidia-331-updates". En vain.

> lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K2000M] (rev a1)

/etc/apt/sources.list: peut être trouvé sur pastebin.com

Concernant la suggestion de Qasim:

[email protected]~> sudo prime-select nvidia
[sudo] password for raffael: 
Error: alternatives are not set up properly
Error: nvidia mode can't be enabled
[email protected]~> sudo prime-select intel
Error: alternatives are not set up properly
Error: intel mode can't be enabled

Concernant la 2ème suggestion de Qasim:

sudo apt-get purge nvidia*
[reboot]
sudo apt-get install nvidia-319-updates nvidia-settings-319-updates nvidia-prime
[reboot]
[tried to switch to NVIDIA]

Bizarre, ça a fonctionné la première fois!? Puis je suis revenu à Intel - déconnecter / allumer - Rétablir NVIDIA - déconnecter / allumer - & gt; Le système est tombé en panne - erreur décrite ci-dessus.

Sur la suggestion de Louis Matthijssen:

[email protected]:~$ sudo update-alternatives --set /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf /usr/lib/nvidia-331-updates-prime/ld.so.conf
update-alternatives: error: alternative name (/etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf) must not contain '/' and spaces
[email protected]:~$ ls -la /usr/lib/nvidia-331-updates-prime
total 44
drwxr-xr-x   2 root root  4096 Mai  2 22:45 .
drwxr-xr-x 196 root root 32768 Mai  3 10:57 ..
-rw-r--r--   1 root root     0 Apr  4 11:50 alt_ld.so.conf
-rw-r--r--   1 root root    60 Apr  4 11:50 ld.so.conf

Répété algo deux fois - ne fonctionne plus: /

Maintenant, cela semble fonctionner:

[email protected]:~$ sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/nvidia-331-updates-prime/ld.so.conf 
update-alternatives: using /usr/lib/nvidia-331-updates-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode

[email protected]:~$ sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/nvidia-331-updates-prime/alt_ld.so.conf
update-alternatives: using /usr/lib/nvidia-331-updates-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

Par la suite, je pourrais passer à NVIDIA - mais on ne me proposait pas les "Paramètres de serveur NVIDIA X étendus" - il redémarrera maintenant et verra ce qui se passera. Suivi: Il est revenu à Intel après le redémarrage et ne peut plus passer à NVIDIA comme d'habitude. Pour moi, il me semble que votre méthode, Louis, fait croire à l’OS qu’elle utilise NVIDIA alors que ce n’est pas le cas.

    
posée Raffael 20.04.2014 - 15:15
la source

6 réponses

18

Lorsque vous obtenez l'erreur suivante:

Error: alternatives are not set up properly

Vous pouvez essayer de définir vous-même les alternatives.

Lorsque je passe à Intel, je vois:

update-alternatives: using /usr/lib/nvidia-331-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode
update-alternatives: using /usr/lib/nvidia-331-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

Lorsque je passe à NVIDIA, je vois:

update-alternatives: using /usr/lib/nvidia-331/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode
update-alternatives: using /usr/lib/nvidia-331/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

Vous pouvez donc essayer ceci pour passer à Intel:

sudo update-alternatives --set x86_64-linux-gnu_gl_conf /usr/lib/nvidia-331-prime/ld.so.conf
sudo update-alternatives --set i386-linux-gnu_gl_conf /usr/lib/nvidia-331-prime/alt_ld.so.conf

Évidemment, vous devriez remplacer 331 par votre propre version.

Maintenant, vous pouvez essayer quelques choses pour déclencher le commutateur:

  • Déconnectez-vous et reconnectez-vous

    pour redémarrer le serveur X comme vous le feriez normalement

  • Redémarrez tout votre PC

    dans le même but que ci-dessus

  • Exécuter sudo prime-select nvidia

    comme vos alternatives sont maintenant définies pour Intel, j'espère que cela corrigera également tous les autres paramètres pour que tout soit comme il se doit (évidemment, vous devez toujours redémarrer le serveur X)

J'espère que j'ai bien interprété l'erreur.

En outre, vous pouvez utiliser prime-select query pour vérifier quelle carte est actuellement sélectionnée, et corriger les alternatives pour cette carte (par exemple NVIDIA), car vous pouvez définir des alternatives pour l’autre carte (par exemple Intel), mais la L'outil pense toujours que vous utilisez l'autre carte (par exemple NVIDIA), ce qui donne une erreur en disant que les alternatives ne sont pas configurées correctement.

    
réponse donnée Louis Matthijssen 03.05.2014 - 21:21
la source
5

Je pense avoir trouvé une solution au moins .

Tout est à propos de update-alternatives .
J'ai remarqué que les deux

sudo update-alternatives --config i386-linux-gnu_gl_conf

et

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

renvoie la liste contenant /usr/lib/i386-linux-gnu/mesa/ld.so.conf ou similaire.

Après chaque redémarrage, /usr/lib/i386-linux-gnu/mesa/ld.so.conf a été défini comme choisi, même si je l'ai déjà modifié manuellement.

J'ai essayé de changer l'ordre sur cette liste, mais finalement la solution consistait à la supprimer par

sudo update-alternatives --remove x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf

et

sudo update-alternatives --remove i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf

Cela devrait suffire.
Sinon, définissez les deux options 'i386' et 'x86_64' sur la même option avec

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

et

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

Redémarrez après.

Vous pouvez toujours restaurer l'état d'origine par

sudo update-alternatives --install /etc/ld.so.conf.d/i386-linux-gnu_GL.conf i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf 500  

et

sudo update-alternatives --install /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf 500

J'espère que cela fonctionnera aussi pour vous.

    
réponse donnée kcpr 29.01.2015 - 18:31
la source
4

ce qui a fonctionné pour moi, j'essaie toujours de trouver son poste. J'avais tellement de choses à voir:

Voici ce qui a fonctionné pour moi:

J'ai essayé:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf
sudo ldconfig -n
sudo update-initramfs -u

Et redémarré sans modification. J'ai donc essayé:

sudo apt-get purge libvdpau-va-gl1 bumblebee* nvidia*
sudo apt-get install linux-headers-generic
sudo apt-get install nvidia-331 nvidia-settings nvidia-prime

Redémarrez. Pourtant, aucun changement, et le même message d'erreur vierge dans nvidia-settings lorsque je tente de passer à moi nvidia card.

J'ai essayé de basculer manuellement en utilisant sudo prime-switch nvidia et les informations de configuration ont été mises à jour. J'ai encore essayé, et nvidia-settings m'a demandé de me déconnecter et de me reconnecter et ... voilà! Je l'ai fait fonctionner!

Dans mon cas, il est apparu qu'avant de pouvoir utiliser l'interface utilisateur de nvidia-settings, je devais d'abord basculer manuellement en tant que superutilisateur, afin de générer la configuration appropriée!

C'est une bonne chose que j'ai essayé, ou je continue à bricoler, à installer d'autres pilotes! J'espère que cela sera utile à quelqu'un d'autre!

    
réponse donnée Michael 26.08.2014 - 05:54
la source
4

suivez les pré-réponses, c'est comme ça que je l'obtiens correctement sur mon linux mint 17.2.

d'abord je fais:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf

sélectionnez celui avec 'nvidia-prime':

sudo prime-select nvidia

puis redémarrez:

sudo init 6
    
réponse donnée realhu 12.09.2015 - 12:56
la source
1

J'ai eu un problème qui semblait identique, et la réponse était que bumblebee-nvidia était toujours installé.

Notez que vous purgez "tout NVIDIA" avec sudo apt-get purge nvidia* et que le package ci-dessus ne correspond pas à ce caractère générique.

Alors, lancez la commande:

apt-get purge bumblebee-nvidia nvidia*

Puis redémarrez, puis installez les paquets nvidia-xxx , nvidia-settings et nvidia-prime pertinents (j'utilise actuellement la version 340.24 de xorg-edgers ).

Maintenant, pendant cette installation, vous devriez voir les messages update-alternatives pertinents sur les fichiers *gnu_gl_conf .

    
réponse donnée Dmitry 23.07.2014 - 14:59
la source
0

J'ai trouvé la solution.

Je ne sais pas exactement quel était le problème, mais ce problème semble avoir disparu sur une nouvelle installation du 16.04. Peut-être ont-ils mis à jour correctement les dépendances? Je ne suis pas sûr.

Mais je peux personnellement confirmer que ce n’est plus un problème en 16.04. J'ai eu le même problème EXACT en 14.04. Mais maintenant avec 16.04 ce n’est plus un problème.

    
réponse donnée Rakshith Ravi 28.04.2016 - 14:41
la source

Lire d'autres questions sur les étiquettes