VBox sur 14.04: Pilote du noyau non installé (rc = -1908) [doublon]

62
  

Pilote du noyau non installé (rc = -1908)

     

Le pilote du noyau VirtualBox Linux (vboxdrv) n’est pas chargé ou   il y a un problème de permission avec / dev / vboxdrv. Veuillez réinstaller le   module du noyau en exécutant

     

'/ etc / init.d / vboxdrv setup'

     

en tant que root. S'il est disponible dans votre distribution, vous devez installer   le package DKMS en premier. Ce paquet garde la trace du noyau Linux   modifie et recompile le module du noyau vboxdrv si nécessaire.

Ceci est un message familier à tous ceux qui utilisent Virtual Box. Ce "bug" est apparu tous les quelques mois au moins depuis 11.10. Je l'ai eu aujourd'hui pour la première fois le 14.04 et malheureusement la solution classique de réinstaller virtualbox-dkms n'est pas ayant un effet:

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove virtualbox-dkms
sudo apt-get install virtualbox-dkms

Quelle pourrait être la raison de l'échec de cette ancienne solution?

Mise à jour : dans les commentaires, l'utilisateur fait référence à un ancien thread qui semble signaler le même problème. Bien que le message d'erreur soit similaire, sur Ubuntu 14.04, ce problème semble avoir une nature différente, sans rapport avec le package virtualbox-dkms . Par exemple, sur Ubuntu 14.04, le package virtualbox est à jour:

$ sudo apt-cache policy virtualbox
virtualbox:
  Installed: 4.3.10-dfsg-1
  Candidate: 4.3.10-dfsg-1
  Version table:
 *** 4.3.10-dfsg-1 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages
        100 /var/lib/dpkg/status
    
posée Luís de Sousa 17.07.2014 - 09:06
la source

1 réponse

85

Le correctif pour 14.04 est en effet différent, mais pas si différent:

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove --purge virtualbox-dkms
sudo apt-get install virtualbox-dkms

La commande install virtualbox-dkms échouait à appliquer le correctif 13.10. En purgeant complètement le paquet, les choses sont revenues à la normale.

Mise à jour [17-01-2015]: dans la dernière itération de ce bogue, un redémarrage du système est requis entre la commande apt-get remove et la seconde apt-get install .

Mise à jour [07-02-2016]: ce correctif est apparemment fonctionnel sur Ubuntu 15.10.

Mise à jour [29-09-2016]: ce correctif est également fonctionnel sur Ubuntu 16.04 .

    
réponse donnée Luís de Sousa 17.07.2014 - 15:04
la source

Lire d'autres questions sur les étiquettes