Comment ajouter / supprimer les applications de démarrage "cachées"?

56

Comment gérer (ajouter / supprimer) toutes les applications de démarrage dans Ubuntu 11.10 et les versions ultérieures?

Applications de démarrage n'affiche pas toutes les applications démarrées lors du démarrage.

    
posée Praveen Sripati 20.10.2011 - 17:06
la source

5 réponses

44

Comme dit plus haut, vous devez éditer /etc/xdg/autostart/ et soit:

  • supprimer les lignes NoDisplay=true ;
  • ou faites ces mêmes lignes de commentaires en ajoutant # devant eux;
  • ou remplacez true par false dans ces mêmes lignes.

La troisième solution peut être facilement réalisée en trois étapes:

  1. Invoquer le terminal avec Ctrl + Alt + T .
  2. Tapez les deux commandes suivantes:

    cd /etc/xdg/autostart/
    sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop
    

Après avoir modifié ce que vous voulez, vous pouvez revenir à l’état précédent en le saisissant dans le terminal:

sudo sed --in-place 's/NoDisplay=false/NoDisplay=true/g' *.desktop

Ceci a été testé en 12.04, 12.10 et 13.04.

[Source: iloveubuntu.net , merci Nikhil Sinha pour le lien]

    
réponse donnée stragu 02.04.2012 - 06:53
la source
16

Supprimez la ligne NoDisplay=true de chaque entrée de /etc/xdg/autostart/ . Désélectionnez simplement celles que vous ne voulez pas dans les applications de démarrage. Bien que les applications de démarrage automatique soient là pour une raison, assurez-vous de savoir ce que vous faites lorsque vous les désactivez.

Il existe également divers services qui stockent leurs fichiers de configuration dans /etc/init . La plupart des utilisateurs ne doivent cependant pas toucher ces fichiers.

    
réponse donnée Jeremy Bicha 20.10.2011 - 19:15
la source
9

La manière correcte de le faire en tant qu'utilisateur normal consiste à copier le fichier de bureau en question de /etc/xdg/autostart/ à ~/.config/autostart/ (créez d'abord le répertoire si nécessaire) et éditez cette copie à l'état NoDisplay=false . Ensuite, ouvrez "Startup Applications Preferences" et décochez la case correspondante.

    
réponse donnée Tormod Volden 05.04.2013 - 21:10
la source
8

Il est normal que vous ne voyiez rien dans la liste. La liste Programmes de démarrage supplémentaires ne concerne que les programmes qui démarrent pour l’utilisateur actuel (pas nécessairement pour les autres utilisateurs et pas tous les services qui démarrent au démarrage d’Ubuntu). En outre, il ne répertorie pas les parties normales de l'environnement de bureau qui démarrent lorsque l'utilisateur se connecte graphiquement.

Tout le monde peut le vérifier en cliquant sur "Applications de démarrage". C'est vide par défaut.

Si vous souhaitez afficher les entrées de démarrage masquées (par exemple, notificateur de mise à jour, lecteur d'écran orca, etc.), tapez / copiez et collez les éléments suivants dans un terminal:

find /etc/xdg/autostart ~/.config/autostart -name \*.desktop -exec sudo sed –i -e '/^NoDisplay=/d' {} +

Si vous souhaitez masquer les entrées normalement masquées, tapez / copiez et collez les éléments suivants

echo NoDisplay=true | find /etc/xdg/autostart ~/.config/autostart -name \*.desktop -exec sudo tee -a {} + >/dev/null

Source: How-To Geek

    
réponse donnée BigSack 18.06.2012 - 09:35
la source
5

Une alternative:

Pour afficher toutes les applications de démarrage sur les " applications de démarrage ", ouvrez simplement /etc/xdg/autostart et modifiez la ligne NoDisplay=true à #NoDisplay=true . Ajoutez simplement un # . Ensuite, vous pourrez tout voir sur les " applications de démarrage " et désactiver ce que vous voulez à partir de là.

    
réponse donnée Nik. 06.11.2011 - 02:16
la source

Lire d'autres questions sur les étiquettes