Comment échanger Escape et Caps Lock en 14.04?

34

Il semble que les options de disposition du clavier qui permettent des choses telles que "Permuter la touche Échap et Verrouillage des majuscules" ont disparu des paramètres du clavier dans 14.04 Existe-t-il une autre interface graphique où elles peuvent être définies? Ou est-il revenir à des fichiers par points ?

    
posée Hamish Downer 08.04.2014 - 00:56
la source

4 réponses

41

Installez l’outil Outil GNOME Tweak (gnome-tweak-tool), sous l’onglet Typing , une option permet d’échanger Esc avec < kbd> Caps Lock . Cela a fonctionné pour moi dans Ubuntu 14.04.

    
réponse donnée user268068 12.04.2014 - 05:10
la source
4

Comme je l'ai mentionné dans une autre question similaire , la méthode habituelle pour échanger Esc et < kbd> Ctrl contient les lignes suivantes dans le fichier ~/.Xmodmap :

clear Lock
keysym Caps_Lock = Escape
keysym Escape = Caps_Lock
add Lock = Caps_Lock

Cela devrait fonctionner avec tous les environnements de bureau (KDE, Gnome) sur les distributions les plus courantes (famille Ubuntu et Debian, famille Fedora et RH).

    
réponse donnée dotancohen 01.11.2015 - 12:42
la source
4

J'ai eu un peu de mal avec cela lors de ma dernière configuration du système d'exploitation et j'ai trouvé une solution. Sur cette configuration, j'ai dû parcourir Internet à nouveau pour trouver. Laissez-moi le laisser ici pour référence future.

J'utilise Ubuntu 14.04 LTS (en travaillant également avec 16.04), et c'est ainsi que j'ai remappé mon verrouillage des majuscules pour s'échapper:

  1. Ouvrir le terminal
  2. Ouvrez le fichier /etc/default/keyboard avec sudo (par exemple sudo nano /etc/default/keyboard )
  3. ajoutez caps:swapescape au XKBOPTIONS . Après modification la ligne devrait ressembler à la suivante

      

    XKBOPTIONS="caps: swapecape"

Notez que je n'ai pas essayé ceci avec le paramètre caps:swapescape . J'ai utilisé le paramètre caps:escape ; c'est-à-dire que ma modification ne fait que remapper le verrouillage des majuscules pour s'échapper mais ne mappe pas mon échappement au verrouillage des majuscules.

Ma source

    
réponse donnée ALM 19.06.2016 - 10:11
la source
1

Une autre solution est celle mentionnée dans cet article comment changer de manière permanente Verrouillage des majuscules et échap qui utilise dpkg-reconfigure avec quelques étapes supplémentaires mais en définissant "caps:swapescape" dans xkb-options

    
réponse donnée Wakaru44 01.07.2015 - 02:59
la source

Lire d'autres questions sur les étiquettes