Comment désactiver le microphone en réglant automatiquement son volume d'entrée

38

Je veux désactiver la façon dont le microphone s'abaisse en fonction de l’entrée. Voici une image:

Le microphone a démarré à 100% et a lentement commencé à afficher l’image. Cela est dû à un bruit de fond ou à la voix de l'utilisateur. Dans tous les cas, je voudrais interdire ce comportement car, lorsque le niveau devient trop bas, il sera nécessaire d’élever la voix.

Existe-t-il une option ou un fichier de configuration permettant de modifier et de modifier ce comportement?

Ceci n’est pas lié à une seule application, mais à plusieurs applications, allant de Skype à Google Hangouts, à Empathy to Teamspeak, etc. Donc, s'il vous plaît, pas de réponses mentionnant une seule application si la solution ne résout pas le problème pour les autres.

l’application pulseaudio (interface graphique et terminal) était déjà utilisée. Alsamixer a également été utilisé. Dans les deux cas, l'ajustement du niveau du microphone n'a pas aidé. Le réglage automatique se produit toujours lorsque quelqu'un parle, n'a même pas besoin d'être quelqu'un qui parle fort, il a juste besoin de parler et après quelques secondes, le niveau du micro commence à s'ajuster automatiquement. Je le répète, ce n’est pas un problème avec 1 application, mais plusieurs, alors une solution commune vaut mieux qu’un 1 pour chaque application (dont nous parlons plus de 50 applications).

    
posée Luis Alvarado 09.04.2013 - 04:32
la source

9 réponses

21

Pour Skype:

Skype & gt; Options & gt; Périphériques audio
et décochez Autoriser Skype à ajuster automatiquement le niveau de mon mélangeur

    
réponse donnée selvan 04.12.2014 - 07:31
la source
14

Vous ne savez pas si cela s'applique à tout le monde, mais si vous utilisez un service de conférence Web / chat vidéo dans Chrome / Chromium tel que Google Hangouts, il est fort probable qu’il utilise le protocole WebRTC. Malheureusement, l’implémentation WebRTC dans Chromium est accompagnée d’une "fonctionnalité" pratique appelée Automatic Gain Control qui a tendance à se visser avec le volume de votre microphone. À moins que l’application Web elle-même ne vous donne l’option de le désactiver, il est impossible de l’éteindre autrement, et Les développeurs Chrome ne veulent pas ajouter un" interrupteur "global pour cela .

J'ai fini par utiliser la solution de @lelandbatey. Comme j'utilisais PulseAudio, j'ai utilisé pacmd au lieu de amixer :

while sleep 0.1; do pacmd set-source-volume alsa_input.???-?????.analog-stereo 90000; done

Notez que 65535 correspond à 100%, donc 90000 est d'environ 135%. Le nom du périphérique ( alsa_input.???-?????.analog-stereo ) doit être remplacé par celui que vous avez trouvé en exécutant pacmd list-sources | grep name: :

name: <alsa_input.???-?????.analog-stereo>
    
réponse donnée Rufflewind 26.09.2016 - 20:50
la source
7

Réglez votre microphone sur Non amplifié 100% Essayez d’installer le contrôle du volume audio pulsé:

sudo apt-get install pavucontrol

Et puis ouvrez: pavucontrol

    
réponse donnée Marcela Oniga 24.02.2014 - 18:33
la source
5

Je travaille toujours sur ce problème ennuyeux (une option devrait être incluse dans l'onglet Périphériques d'entrée pour "forcer" le volume d'entrée à rester là où l'utilisateur veut le définir. Cela s'appliquerait dans des cas spécifiques où l'utilisateur sait quoi le volume dont il a besoin pour une application particulière et les fonctions d'ajustement automatique ne fonctionnent pas correctement En tout cas, pour le mettre en mode "semi-manuel" au lieu de l'ajustement automatique pour Google Apps comme Hangouts, créez / modifiez les options de fichier dans: / p>

nano ~/.config/google-googletalkplugin/options

et ajoutez la ligne:

audio-flags=1

ou lancez simplement la ligne suivante:

echo "audio-flags=1" > ~/.config/google-googletalkplugin/options

Enregistrez le fichier et fermez toutes les applications associées à Google. Le volume du périphérique d'entrée doit arrêter le réglage automatique. Cela fonctionne 50/50 c'est pourquoi je cherche une solution permanente.

    
réponse donnée Luis Alvarado 10.11.2014 - 02:26
la source
2

J'ai ce problème avec Skype, vous devez désactiver les niveaux de réglage automatique du mixeur (peut-être devez-vous vérifier les paramètres avancés ou une chose pareille)

    
réponse donnée lanodan 27.02.2014 - 16:10
la source
2

J'avais ce problème, mais avec chaque type de conversation vidéo que j'ai tenté d'utiliser sur Xubuntu, de Google Hangouts à appr.tc, tout ajustait automatiquement le volume de mon microphone. En particulier, il semble augmenter le volume si des voix peuvent être entendues en arrière-plan, comme pour faire entendre la voix la plus silencieuse.

Quoi qu’il en soit, ma solution consistait à définir manuellement le volume de mon microphone à l’aide d’une directive de ligne de commande, à mettre en boucle et à courir tous les dixièmes de seconde. Donc, voici le shell oneliner qui résout mon problème:

while true; do amixer -c 1 set 'Mic Boost' 0db > /dev/null; amixer -c 1 set 'Capture' 35db > /dev/null;  sleep 0.1; done;

Sur votre ordinateur pour le faire fonctionner, vous devrez peut-être modifier le périphérique à ajuster et les canaux à modifier. Pour trouver cette information, vous pouvez utiliser le mélangeur Alsa, accessible avec alsamixer .

    
réponse donnée lelandbatey 05.02.2016 - 05:40
la source
2

Cela a fonctionné pour nous (nous n’utilisons pas Skype):

lien

# Disable auto adjusting of gain on mic:
# Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
# Edit as root: /usr/share/pulseaudio/alsa-mixer/paths/analog-input-mic.conf
# Under "[Element Internal Mic Boost]" set "volume"  to "zero".
# Under "[Element Int Mic Boost]" set "volume"  to "zero".
# Under "[Element Mic Boost]" set "volume"  to "zero".
    
réponse donnée nh2 19.02.2016 - 14:47
la source
2

J'ai résolu le problème sur ma machine en désactivant tous les micros de mon bureau. J'ai trouvé que si le micro de l'appareil photo captait l'audio, le gain sur le casque était réduit. J'ai désactivé le micro de l'appareil photo et le casque est maintenant stable.

Je ne sais pas si ça aide, mais j'ai trouvé ça intéressant.

    
réponse donnée Andy Thornton 20.09.2016 - 15:53
la source
1

La réponse de cette question "en double" est pour moi le meilleur, je laisse le crédit à la personne qui a répondu

Dans le fichier de configuration /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf (vous devrez peut-être rechercher le fichier correct pour votre microphone), j'ai remplacé la partie volume = par 100 , qui correspond au pourcentage au lieu de merge

[Element Capture]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

à

[Element Capture]
switch = mute
volume = 100
override-map.1 = all
override-map.2 = all-left,all-right

et après un sudo alsa force-reload , les applications ne modifient plus comme par magie le volume du microphone.

    
réponse donnée Philippe Gachoud 06.05.2017 - 17:10
la source

Lire d'autres questions sur les étiquettes