Assistance KEMU KVM VNC

6

Dois-je installer un package spécial pour obtenir le support VNC?

J'ai installé:

sudo apt-get install kvm qemu-kvm qemu-kvm-extras

Tout fonctionne bien. Je n’ai pas de serveur VNC opérationnel, bien qu’il soit configuré pour la VM.

Peut-être est-ce un problème de pare-feu car je peux me connecter localement.

    
posée Dukeatcoding 01.03.2013 - 15:18
la source

2 réponses

6

Le support VNC doit être disponible par défaut. Donc, comme vous l'avez dit, il pourrait y avoir un problème dans la configuration du pare-feu ou de qemu / libvirt.

Concernant qemu par défaut, il n'accepte que les connexions vnc locales. Pour changer cela, modifiez /etc/libvirt/qemu.conf :

vnc_listen = "0.0.0.0"

Cela permettra d’établir des connexions avec tous les hôtes, ce qui, selon ce que vous essayez de faire, peut être très dangereux. Dans ce fichier, vous pouvez trouver plus d'informations sur la façon de sécuriser les choses.

De plus, si vous utilisez libvirt, je pense qu’elle n’accepte que les connexions locales par défaut. Pour activer l'accès distant, éditez /etc/libvirt/libvirtd.conf :

listen_tcp = 1

Les mêmes problèmes de sécurité concernant qemu s'appliquent ici. Voyez comment sécuriser la connexion si nécessaire ici .

En dernier recours, vérifiez si les ports utilisés par vnc et libvirt sont ouverts. Dans le cas où vous utilisez ufw:

sudo ufw status verbose
    
réponse donnée Salem 01.03.2013 - 15:56
la source
1

KVM (QEMU) possède un serveur VNC intégré et fonctionne par défaut. Il peut être activé de plusieurs manières. Si vous voulez un outil graphique, utilisez virt-manager.

Cependant, il existe une meilleure option pour l’OMI, utiliser le package SPICE.

Le serveur SPICE est beaucoup plus rapide.

Spice wiki Ubuntu - lien

J'utilise SPICE sur Fedora, désolé pour ça. Pour Ubuntu voir:

Obtenir le bon fonctionnement de SPICE dans Ubuntu 12.04.1-LTS

Pour une belle démonstration, voyez:

lien

Oui, c'est un peu dépassé et pour Fedora, mais j'utilise SPICE avec mes invités Ubuntu, et ça marche bien.

    
réponse donnée Panther 01.03.2013 - 19:17
la source

Lire d'autres questions sur les étiquettes