Les extensions sont désactivées après le redémarrage [fermé]

34

J'utilise Ubuntu Gnome 13.10 avec Gnome 3.10. Mon problème est que chaque fois que je redémarre le système d'exploitation, toutes les extensions du shell sont désactivées. La chose étrange est que leurs paramètres sont conservés. Ils sont juste éteints et je dois les réactiver à chaque fois. Comment puis-je les rendre persistants?

Merci

Mise à jour

Aujourd'hui, Ubuntu 13.10 a été officiellement publié et après la mise à niveau, mon problème est toujours là. Voici mon info système:

$ uname -a
Linux ubuntu-desktop 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:20:46 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Des idées?

Sidenote - Quelqu'un peut-il me dire s'il y a au moins les paramètres de l'état des extensions (on / off) enregistrés? J'ai supprimé toutes les extensions

rm -r ~/.local/share/gnome-shell/extensions/*
rm -r /usr/share/gnome-shell/extensions/*

et j'ai installé ceux que j'utilise. Je pense donc à créer un job cron et à les activer à chaque démarrage du système. Au moins jusqu'à ce que je trouve comment résoudre ce problème.

    
posée Christos Baziotis 16.10.2013 - 19:57
la source

4 réponses

16

Cela fonctionne dans Gnome 3.8.4, et devrait fonctionner plus tard.

Définissez toutes les extensions que vous souhaitez activer. Puis lancez:

gsettings get org.gnome.shell enabled-extensions

Cela devrait venir avec quelque chose comme

$ gsettings get org.gnome.shell enabled-extensions
['[email protected]', '[email protected]', '[email protected]']

Copiez la sortie, puis exécutez gnome-session-properties

Appuyez sur Ajouter, puis entrez la sortie de gsettings get org.gnome.shell enabled-extensions "['use... ...blogspot.com']" - Toutefois, comme cela a été gentiment souligné, remplacez get par set lorsque vous entrez dans la boîte de commande, comme dans l'image ci-dessous. METTEZ LES CITATIONS DOUBLES, AUTREMENT CELA NE FONCTIONNERA PAS (si vous n'êtes pas sûr, testez d'abord la commande dans le terminal - si aucun retour n'est donné, cela a fonctionné).

EDIT: Pour les nouvelles versions sans gnome-session-properties , vous aurez probablement besoin de créer manuellement une . desktop dans ~/.config/autostart - certains outils d'interface graphique peuvent être disponibles via l'outil Gnome Tweak ou similaire.

Par exemple:

Assurez-vous ensuite que ceci est activé:

Chaque fois que vous vous connectez, il doit exécuter une commande pour restaurer toutes les extensions!

N.B. Si vous apportez des modifications à vos extensions activées, vous devrez les mettre à jour.

Pour automatiser ce processus, ce script semble fonctionner:

#!/bin/bash
active_extensions=$(gsettings get org.gnome.shell enabled-extensions)
autostart_file=$HOME/.config/autostart/restore-extensions.desktop
echo -e "Currently active extensions:\n\e[34m$active_extensions\e[0m"
echo -e "[Desktop Entry]\nType=Application" > $autostart_file
echo Exec=gsettings set org.gnome.shell enabled-extensions \"$active_extensions\" >> $autostart_file
echo -e "Hidden=false\nNoDisplay=false\nX-GNOME-Autostart-enabled=true\nName=Restore Extensions\nComment=Restore enabled extensions on login" >> $autostart_file
echo "Command to restore currently active extensions added to $HOME/.config/autostart/restore-extensions.desktop"
exit

Enregistrez le script dans ~/.local/bin/extension-update , exécutez-le (définissez-le dans la fenêtre Propriétés du fichier ou exécutez chmod +x ~/.local/bin/extension-update )

.

Ensuite, chaque fois que vous exécutez extension-update , il va mettre à jour un fichier de démarrage automatique à ~/.config/autostart/restore-extensions.desktop (une entrée de démarrage automatique différente sera probablement différente si vous en avez créé une manuellement ci-dessus) peut vouloir le supprimer) - vous pouvez vérifier gnome-session-properties pour vous en assurer.

    
réponse donnée Wilf 29.10.2013 - 00:31
la source
9

Modifier: la sélection de "System Default" au lieu de "gnome" dans l'écran de connexion semble fonctionner pour moi

Ceci est un bug connu: lien

On dirait qu’il s’agit de l’extension TopIcons, essayez de le désactiver pour l’instant: lien

    
réponse donnée user203863 18.10.2013 - 02:40
la source
4

Dans le menu de connexion, définissez l'option "system default" au lieu de "gnome ou classic", les extensions doivent maintenant rester activées après le redémarrage. Travaillé pour moi!

    
réponse donnée Ubuntuser 08.12.2013 - 16:16
la source
-1

J'ai corrigé le problème (dans openSUSE, mais cela peut être la même chose pour vous) en supprimant la clé dconf pour les extensions activées, en redémarrant le shell ou en vous déconnectant, puis en réactivant les extensions dans l'outil tweak.

Certaines extensions dans dconf n’ont pas été réellement installées ... semble avoir été le problème, car il fonctionne maintenant ...

J'espère que ça aide.

    
réponse donnée brainstormtrooper 23.11.2013 - 13:25
la source

Lire d'autres questions sur les étiquettes