Comment supprimer "Show Desktop" du sélecteur Alt-Tab (application)?

97

Est-il possible de supprimer "Show Desktop" du sélecteur d’application Alt + ?

    
posée David Dossot 24.07.2012 - 00:14
la source

7 réponses

36

Cela peut être fait!

J'ai téléchargé un build Unity pour 12.04 qui corrige ce problème (pas de Show Desktop dans le sélecteur Alt-Tab).

  • Pour installer , ouvrez un terminal et:
sudo apt-add-repository ppa:izx/askubuntu -y
sudo apt-get update
sudo apt-get install unity
  • Vous pouvez activer le paramètre "Afficher l’icône du bureau" dans le plug-in Unity dans Compiz (en utilisant ccsm ) pour obtenir l’icône sur le lanceur situé à gauche:

  • Si une nouvelle mise à jour d’Unity est publiée, Update Manager le télécharge automatiquement. Je vais essayer de "réparer" la mise à jour et de la mettre dans le PPA dès que possible; veuillez ajouter un commentaire à cette réponse pour m'avertir si vous effectuez une mise à niveau et que "Show Desktop" réapparaît dans le commutateur!

Comment l'avez-vous fait?

J'ai modifié l'Unité Source. Il se compose de deux étapes:

  1. Mettez en commentaire la ligne 900 dans plugins/unityshell/src/LauncherController.cpp , qui ajoute par défaut l’icône "Afficher le bureau" au commutateur:
// results.push_back(pimpl->desktop_icon_);
  1. Changer la ligne 1638 dans plugins/unityshell/src/unityshell.cpp à partir de:

      if (!(results.size() == 1 && results[0]->GetIconType() == AbstractLauncherIcon::IconType::TYPE_DESKTOP))

    à

      if (!results.size() == 0))
    • Alors que la liste des icônes de commutateur Alt-Tab était au moins 1 auparavant (l’icône de show-desktop), maintenant elle est à 0 et nous avons besoin de la modifier pour afficher le sélecteur uniquement lorsque la liste contient au moins un élément (c'est-à-dire au moins une application en cours d'exécution).
réponse donnée ish 02.08.2012 - 01:23
la source
101

13.04 et plus récent

Pour 13.04, 13.10 et 14.04, pour activer ou désactiver l'option "Afficher le bureau" dans le sélecteur d'application, vous pouvez utiliser tool-tweak-tool

12.10

Pour 12.10, un nouveau paramètre a été ajouté à CCSM pour activer ou désactiver le "Afficher le bureau" option dans le sélecteur d'application.

Exécutez cette commande dans un terminal pour installer CCSM:

sudo apt-get install compizconfig-settings-manager

Maintenant, ouvrez CCSM et accédez au plug-in Ubuntu Unity.

Passez à l'onglet Switcher . Cochez ensuite la case en regard de Désactiver l’affichage du bureau dans l’option switcher .

Tada! Pas plus "Afficher le bureau" dans le sélecteur d

    
réponse donnée jokerdino 11.08.2012 - 01:47
la source
6

En 14.04, j'ai pu accomplir cela dans le Gestionnaire de paramètres CompizConfig.

sudo apt-get install compizconfig-settings-manager

En visitant:

  • Section "Bureau" de la liste dans la zone large, blanche et droite
  • Élément "Ubuntu Unity Plugin" →
  • Onglet "Switcher" →
  • "Désactiver l'option" Afficher le bureau dans le commutateur ".

C'était une version par défaut, non personnalisée de C.C.S.M. directement des pensions.

    
réponse donnée Erik Piper 04.08.2014 - 13:13
la source
1

Une option pourrait être de revenir au comportement de Alt + Tab avant 11.10 .

Je me rends compte que c'est un peu drastique, mais ça pourrait être mieux que rien.

    
réponse donnée ændrük 27.10.2011 - 07:09
la source
1

Je ne suis donc pas sûr que cela vous aide, mais en utilisant Unity 2D, vous en avez marre de ne pas avoir de pilotes graphiques. Alors insatisfait, je suis revenu à l'interface Unity. Je n'ai plus l'affichage "Afficher le bureau" dans le sélecteur d'application ALT + TAB. Je pense que cela est un effet secondaire de l’interface Gnome qui l’a placé dans le coin inférieur gauche, et quand je suis revenu en arrière, je ne l’avais plus. Semble travailler pour moi ... ça vaut le coup.

    
réponse donnée esnowrackley 26.07.2012 - 23:33
la source
0

Attention: je dois le faire fonctionner une seule fois exactement. Lorsque j'ai redémarré, j'avais deux instances d'unité en cours d'exécution et je ne pouvais pas comprendre pourquoi ou comment. les tuer ne fonctionnait pas, et la désinstallation de la réinstallation n’a pas aidé.

Je l'ai résolu en installant 13.10. J'utiliserai les autres correctifs listés ici.

Je ne pouvais pas le faire fonctionner au 12.04, le paquet fourni dans une autre réponse n'était pas assez nouvelle (version 5.14), et le guide n'était pas tout à fait parfait. (même si c'était très utile) Voici comment j'ai réussi à appliquer le correctif pour l'unité 5.20

1) Télécharger la source:

sudo apt-get source unity

2) Changer la source:

diff -ru org/plugins/unityshell/src/LauncherController.cpp patch/plugins/unityshell/src/LauncherController.cpp
--- unity-5.20.0/plugins/unityshell/src/LauncherController.cpp  2013-04-12 04:24:42.000000000 -0400
+++ unity-diff/plugins/unityshell/src/LauncherController.cpp    2013-12-23 12:22:50.154961579 -0500
@@ -761,7 +761,7 @@
 {
   std::vector<AbstractLauncherIcon::Ptr> results;

-  results.push_back(pimpl->desktop_icon_);
+  //results.push_back(pimpl->desktop_icon_);

   for (auto icon : *(pimpl->model_))
   {
diff -ru org/plugins/unityshell/src/unityshell.cpp patch/plugins/unityshell/src/unityshell.cpp
--- unity-5.20.0/plugins/unityshell/src/unityshell.cpp  2013-04-12 04:24:42.000000000 -0400
+++ unity-diff/plugins/unityshell/src/unityshell.cpp    2013-12-23 12:24:36.718966737 -0500
@@ -1909,7 +1909,8 @@

   auto results = launcher_controller_->GetAltTabIcons(show_mode == switcher::ShowMode::CURRENT_VIEWPORT);

-  if (!(results.size() == 1 && results[0]->GetIconType() == AbstractLauncherIcon::IconType::TYPE_DESKTOP))
+//  if (!(results.size() == 1 && results[0]->GetIconType() == AbstractLauncherIcon::IconType::TYPE_DESKTOP))
+  if (!(results.size() == 0))
     switcher_controller_->Show(show_mode, switcher::SortMode::FOCUS_ORDER, false, results);

   return true;

3) Installer d’autres paquets:

sudo apt-get build-dep unity
sudo apt-get install cmake

5) Lancez cmake.

cd <source folder>
# from the INSTALL file
mkdir build; cd build
cmake .. -DCMAKE_BUILD_TYPE=Debug -DCOMPIZ_PLUGIN_INSTALL_TYPE=package -DCMAKE_INSTALL_PREFIX=/opt/unity
make
sudo make install

Remarque: si vous définissez votre dossier DCMAKE_INSTALL_PREFIX sur /usr au lieu de /opt/unity , vous n'aurez plus besoin de synchroniser plus tard, mais je voulais d'abord essayer de lier le fichier. J'ai abandonné.

Je suppose que la meilleure option est de réinstaller l'unité, ce qui mettrait les fichiers standard au dessus.

6) Remplacez les fichiers:

sudo rsync -av /opt/unity/ /usr/

7) Réinstallez unité-greeter. Apparemment, les fichiers synchronisés rompent l'unité-greeter. Ce qui est apparemment nécessaire pour faire fonctionner l'unité.

sudo apt-get install --reinstall unity-greeter
    
réponse donnée isaaclw 24.12.2013 - 05:21
la source
0

Si vous utilisez dconf à gérer vos paramètres Unity , le chemin d'accès à ce paramètre (par inspection avec dconf watch / ) est le suivant:

/org/compiz/profiles/unity/plugins/unityshell/disable-show-desktop

Définissez cette option sur true et le bureau sera supprimé en tant qu’option alt-tab .

    
réponse donnée jamesc 25.03.2017 - 18:29
la source

Lire d'autres questions sur les étiquettes