Pourquoi l'utilisation du processeur kworker est-elle si élevée? [dupliquer]

32

J'ai récemment installé Ubuntu 12.04 sur mon ordinateur portable Samsung avec Windows 7. Chaque fois que j'utilise Ubuntu (même lorsque celui-ci est inactif), kworker utilise près de 90% de l'un des 8 cœurs. Même si cela n'affecte pas vraiment mon utilisation, cela me perturbe et j'ai peur que cela puisse nuire à mon processeur. J'ai même essayé d'installer une autre distribution Linux (Linux Mint), et kworker a causé le même problème. Donc je ne sais pas quoi faire. J'apprécierais vraiment votre aider.

    
posée Yusuf 16.08.2012 - 14:29
la source

3 réponses

50

Au lieu de cela, je pense que cette utilisation du processeur n'est pas normale et est liée au bogue bien connu de kworker: lien

La solution pour moi et pour beaucoup d’autres était, tout d’abord, de trouver le "gpe" qui cause les mauvaises choses avec quelque chose comme:

grep . -r /sys/firmware/acpi/interrupts/

et vérifier une valeur élevée (la mienne était gpe13 - avec une valeur comme 200K - donc, vous devez la modifier en conséquence, si elle est différente). Après cela:

~ cp /sys/firmware/acpi/interrupts/gpe13 /pathtobackup
~ crontab -e

Ajoutez cette ligne, elle sera donc exécutée à chaque démarrage / redémarrage:

@reboot echo "disable" > /sys/firmware/acpi/interrupts/gpe13

Enregistrer / quitter. Ensuite, pour que cela fonctionne aussi après le réveil de suspendre:

~ touch /etc/pm/sleep.d/30_disable_gpe13
~ chmod +x /etc/pm/sleep.d/30_disable_gpe13
~ vim /etc/pm/sleep.d/30_disable_gpe13

Ajoutez ce genre de choses:

#!/bin/bash
case "" in
    thaw|resume)
        echo disable > /sys/firmware/acpi/interrupts/gpe13 2>/dev/null
        ;;
    *)
        ;;
esac
exit $?

Enregistrer / quitter, terminé.

Testé et travaillant sur:

Ubuntu 12.10 on Samsung Chronos 7 series - Model no. NP700Z7C --
Ubuntu 16.04.2 on Clevo - Model no. P650RS --
    
réponse donnée Mauro Mascia 29.12.2012 - 11:02
la source
3

L'utilisation du processeur semble être normale, il n'y a qu'une seule CPU (CPU1) à forte utilisation. En tout, il y a 3 processus en cours d'exécution dont deux sont kworker et gnome-system-mo (les 2 premiers processus dans le court écran supérieur que vous avez ajouté).

"kworker" est un processus réservé aux threads de travail du noyau, qui effectuent la plupart du traitement réel pour le noyau, en particulier dans les cas où il y a des interruptions, des minuteries, des E / S, etc. tout temps "système" alloué aux processus en cours d'exécution. Ce n'est pas quelque chose qui peut être retiré du système en toute sécurité, et qui n'a aucun lien avec nepomuk ou KDE (sauf que ces programmes peuvent faire des appels système, ce qui peut nécessiter une action du noyau).

Pour plus d'informations sur kworker, consultez le lien suivant: -

    
réponse donnée Ankit 16.08.2012 - 15:13
la source
0

J'ai installé Linux Mint 17 hier et j'ai remarqué ce soir que kworker consommait 100% de l'un des 4 processeurs. J'ai effectué la vérification ci-dessus, mais je n'ai rien trouvé d'autre que 0 pour les interruptions.

Lors de l’examen des services que j’ai normalement en cours d’exécution, j’ai remarqué que l’arrêt du serveur nfs ramène le thread kworker à zilch. Un redémarrage du serveur nfs n'a pas résolu le problème.

J'ai trouvé ce rapport de bogue ( lien ), ce qui indique qu'un nfs similaire problème de serveur a été corrigé dans le noyau 3.13.0-32.57. La dernière mise à jour de Mint 17 semble exécuter le noyau 3.13.0-24-generic, donc je n'ai pas le correctif dans le noyau que je suis en train d'exécuter. Je ne sais pas si cela aidera quelqu'un d'autre mais je suis systématiquement allé sur chaque machine cliente nfs et j'ai fait un «umount -a -t nfs» et j'ai attendu pour voir si cela avait un effet. J'ai trouvé le client qui semblait avoir causé le problème car le kworker est tombé à rien après mon démontage. J'ai remonté les partages nfs sur le client 'mount -a -t nfs' et le problème n'est pas revenu.

    
réponse donnée Jack 21.10.2014 - 03:14
la source

Lire d'autres questions sur les étiquettes