Activer l'accélération matérielle 3D sur VMWare Workstation 10 sur Ubuntu 14.04

35

J'essaie d'activer les graphiques 3D à accélération matérielle dans une VM Win 8.1 dans VMware Workstation 10.0.3 sur Ubuntu 14.04.1 LTS (Trusty Tahr) pour jouer au jeu Smite en douceur. J'ai vérifié que l'accélération matérielle fonctionne dans Ubuntu:

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL version string:  3.0 Mesa 10.2.2

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes

Sur VMware Workstation, sur la VM sous "Virtual Machine Settings" - & gt; "Affichage" - & gt; "Accelerate 3D Graphics" est coché.

Mais lors du démarrage de la machine virtuelle, il est indiqué "Aucun support 3D n'est disponible depuis l'hôte".

Comment se fait-il que VMware ne détecte pas l’accélération HW 3D? Comment puis-je résoudre ce problème?

Merci!

    
posée Siemen 16.10.2014 - 15:13
la source

3 réponses

63

Modifiez le fichier ~/.vmware/preferences et recherchez une ligne commençant par mks.gl.allowBlacklistedDrivers , si elle n’est pas présente - vous pouvez l’ajouter au fichier.

Cela devrait être changé en mks.gl.allowBlacklistedDrivers = "TRUE" (notez les guillemets autour de TRUE)

    
réponse donnée Charles Green 16.10.2014 - 17:47
la source
11

Ajoutez mks.gl.allowBlacklistedDrivers = "TRUE" dans le fichier .vmx.

Cela a fonctionné pour Linux Mint Cinnamon en tant qu'hôte avec le noyau 3.16 et Debian 8.2 Cinnamon en tant qu'invité.

    
réponse donnée Amandeep Dhindsa 03.12.2015 - 22:45
la source
0

Pour moi, j'ai dû ajouter mks.gl.allowBlacklistedDrivers = "TRUE" à mon fichier de machine virtuelle (.vmx)

    
réponse donnée BXL 01.12.2017 - 19:21
la source

Lire d'autres questions sur les étiquettes