Lier toutes les frappes sur une application

6

J'utilise 16.04 avec LXDE sur un ancien serveur. Les graphiques ne sont évidemment pas géniaux (graphiques intégrés de 8 Mo), donc j'utilise x2go pour transférer ma xsession de plus de 10 100 1000. Le problème est que les frappes (comme alt + tab , ctrl + alt + right , etc.) ne lient pas l'application, donc au lieu de changer d'application dans x2go, il passe de l’application x2go au prochain programme ouvert sur la machine cliente.

Comment pourrais-je lier toutes les frappes de touches (encore plus belles, une frappe exclue) à une seule application?

L'ordinateur client exécute Unity. L’hôte (l’ordinateur dont j’envoie la session via x2go) exécute LXDE.

    
posée anonymous2 20.04.2016 - 14:41
la source

1 réponse

2

Désactiver les raccourcis Unity

  1. Installer ccsm

    sudo apt-get install compizconfig-settings-manager
    
  2. Aller dans la catégorie Desktop → Plugin Ubuntu Unity → Onglet Switcher

    Cliquez sur chaque raccourci, décochez Activer, puis sur OK

  3. Accédez à la catégorie Desktop → Desktop Wall → onglet Liaisons

    De même, désactivez les raccourcis souhaités.

  4. Fermer ccsm , il est effectif juste après la fermeture.

Les raccourcis

ccsm ont priorité sur les paramètres personnalisés du système. Vous pouvez utiliser dconf pour voir le paramètre sous-jacent modifié lorsque vous effectuez les étapes ci-dessus à l'aide de l'interface graphique.

$ dconf watch /
/org/compiz/profiles/unity/plugins/unityshell/alt-tab-prev
  'Disabled'

/org/compiz/profiles/unity/plugins/unityshell/alt-tab-prev
  'Disabled'

/org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward
  unset

/org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward
  unset

Il est donc préférable de créer un script d'encapsulation pour désactiver les raccourcis du commutateur d'unité, lancer x2goclient, puis les réactiver après la fermeture de x2goclient.

dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-prev "'Disabled'"
dconf write /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward "'Disabled'"
...
x2goclient
dconf reset /org/compiz/profiles/unity/plugins/unityshell/alt-tab-prev
dconf reset /org/compiz/profiles/unity/plugins/unityshell/alt-tab-forward
...

Désactiver les raccourcis LXDE

Ancienne réponse qui pourrait être utile pour certains.

Le raccourci que vous mentionnez appartient à OpenBox. Qui est lancé avec des paramètres prédéfinis pour Lubuntu. (Au moins, c'est le cas pour Lubuntu 14.04).

~$ pgrep -a openbox
4772 openbox --config-file /home/lubuntu/.config/openbox/lubuntu-rc.xml

Nous devrions les dissocier d’OpenBox ou de tous les outils qui les ont déjà liés.

  1. Ouvrez son fichier de configuration pour le modifier

    leafpad ~/.config/openbox/lubuntu-rc.xml
    
  2. Puis, commentez les raccourcis souhaités en utilisant des balises de commentaire XML <!-- --> ou les supprimer.

Nouveau raccourci personnalisé transféré vers x2goclient

Après cette configuration, les raccourcis globaux permettent de transférer le raccourci vers la fenêtre x2goclient en utilisant wmctrl & amp; xvkbd .

  1. Paramètres système → Clavier → onglet Raccourcis
  2. Ajouter un nouveau raccourci personnalisé avec la commande

    bash -c 'wid=$(wmctrl -l | awk "/X2Go Client/ {print ; exit}"); echo $wid; if [ "$wid" ] ; then xvkbd -window $wid -xsentevent -text "\A\t"; fi'
    

    pour Alt onglet

réponse donnée user.dz 04.07.2016 - 16:58
la source

Lire d'autres questions sur les étiquettes