Où sont les préférences de gedit?

33

C'est incroyablement bizarre. Je ne vois pas de "préférences" dans aucun de mes menus gedit. Je cours la version 3.8.3. Tout ce que je veux faire, c'est montrer les numéros de ligne, mais je ne peux pas le faire sans préférences.

Où sont-ils cachés?

note: j'ai supprimé indicator-appmenus car je déteste avoir les menus détachés de la fenêtre.

Mise à jour 2015: il s'agit en quelque sorte du type de activer les numéros de ligne dans gedit qui est un peu déroutant. La solution est la même mais les questions sont différentes.

    
posée Amanda 10.11.2013 - 18:13
la source

7 réponses

22

Je ne sais pas comment récupérer preferences dans vos menus, mais vous pouvez utiliser gsettings pour afficher les numéros de ligne. Entrez cette commande dans le terminal:

gsettings set org.gnome.gedit.preferences.editor display-line-numbers true

Si vous devez modifier d’autres paramètres pour gedit , vous pouvez utiliser cette commande pour en trouver un certain nombre: (grâce à this answer)

gsettings list-recursively | grep -i gedit
    
réponse donnée OSE 11.11.2013 - 00:39
la source
19

Si vous utilisez GNOME 3, vous pouvez accéder aux préférences via le menu principal.

vous devriez avoir des "activités" dans le coin supérieur gauche de votre écran. du bon côté des activités, vous aurez gedit. cliquez dessus et vous devriez voir les préférences.

    
réponse donnée Buğra Koç 25.01.2014 - 22:30
la source
12

Pour rétablir les préférences dans le menu d'édition, exécutez la commande suivante dans un terminal:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}'

Le problème est dû au fait que Gnome3 place l’entrée du menu Préférences dans le menu supérieur.

    
réponse donnée user5950 07.09.2015 - 18:39
la source
8

Tapez simplement Alt + E , puis à nouveau E lorsque vous êtes dans gedit. Une nouvelle fenêtre appelée "Préférences gedit" devrait apparaître.

    
réponse donnée Radu Rădeanu 10.11.2013 - 18:17
la source
1

Vous devrez peut-être utiliser l'outil tweak pour désactiver temporairement certaines des extensions courantes que les utilisateurs normaux utilisent maintenant pour rendre gnome 3 utilisable sur un bureau. Pour moi, j'ai dû désactiver les extensions de menu de la barre des tâches et des applications. On peut alors utiliser la méthode décrite par Buğra Koç ci-dessus.

Cela signifie que l’allumage et l’extinction faciles des numéros de ligne et du retour à la ligne dans gedit ont disparu.

Si vous n'avez pas besoin de surligner le texte, Leafpad remplace bien Gedit. Il ressemble à l'ancien gedit:

sudo apt-get install leafpad
    
réponse donnée varanasib 09.07.2014 - 14:32
la source
0

Les préférences sont en cours d’édition en bas de la liste.

Essayez de rétablir la barre de menus, ou si cela échoue, supprimez-la entièrement et installez une nouvelle instance de gedit, la mienne est la version 3.10.4, donc la votre est un peu ancienne!

    
réponse donnée Ken Mollerup 18.01.2016 - 12:14
la source
0

Je sais que c'est un vieux sujet, mais je viens de rencontrer le même problème. Au final, j'ai compris que c'était parce que j'étais toujours connecté en tant que superutilisateur. Une fois que je me suis déconnecté du terminal et que j'ai rouvert le terminal, tout est revenu à la normale.

Je pensais juste que je jetterais ça au cas où quelqu'un d'autre aurait le même problème.

Si vous voyez un # au lieu d'un $ sur votre ligne de commande, c'est probablement pour cette raison que vous ne pouvez pas voir vos valeurs par défaut.

    
réponse donnée DocGil 03.07.2016 - 01:31
la source

Lire d'autres questions sur les étiquettes