Écran vide après l'installation du pilote nvidia restreint

100

J'ai installé le pilote nvidia restreint actuel et redémarré mon ordinateur. et maintenant je reçois un écran noir ou blanc.

Comment puis-je résoudre ce problème?

    
posée LaMinifalda 13.04.2017 - 14:23
la source

16 réponses

73

Supprimer tous les paquets liés à Nvidia

  1. Connectez-vous à un terminal: Ctrl + Alt + F1 (le terminal est visible avec un écran vide)

  2. sudo apt-get remove --purge nvidia-*

Partir de zéro

  1. sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Tout réinstaller

  1. sudo apt-get install nvidia-common
  2. sudo apt-get install xserver-xorg-video-nouveau
  3. sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigurer le serveur X

  1. sudo dpkg-reconfigure xserver-xorg
Source Ubuntu Wiki

    
réponse donnée Marco Scannadinari 17.11.2016 - 17:38
la source
9
  1. Supprimez tous les pilotes pouvant être à l'origine du problème,
  2. ouvrez le terminal et tapez-le (ouvrez-le depuis le tiret à l'aide de l'icône ubuntu dans le coin gauche)

    sudo apt-get --purge remove nvidia
    

    ou

    sudo apt-get --purge remove nvidia-current
    

    (En fonction de celui que vous avez installé) ou désactivez-le à partir des paramètres de pilote restreints.

  3. redémarrez.

  4. puis sur un terminal, tapez ceci:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current nvidia-settings
    
  5. redémarrez.

réponse donnée Uri Herrera 10.05.2011 - 08:32
la source
5

Peut-être que Ubuntu CELA fonctionne mais utilise une autre sortie de carte. Pour moi, mon nVidia GeForce 7300 a 2 sorties, un VGA et un DVI. Il semble que la sortie par défaut lorsque vous installez les pilotes est au format DVI, mais je n’ai pas de moniteur DVI; j’ai donc réussi à accéder au mode de récupération (disponible dans GRUB lorsque vous démarrez) et à taper ceci:

nvidia-xconfig --twinview --twinview-orientation="Clone"

Redémarrez maintenant.

Cette commande dirige les mêmes graphiques vers les deux sorties. À partir de là, vous pouvez continuer à expérimenter cet utilitaire nVidia jusqu'à ce que vous obteniez ce que vous voulez. Pour plus d'informations, tapez:

nvidia-xconfig -A | less

L’espoir que cela aide.

    
réponse donnée Javier Rios 28.02.2012 - 18:36
la source
5

Dans mon cas, il s’agissait d’un problème lié au moniteur qui donnait un mauvais EDID à mon GPU Nvidia

Pour déboguer votre erreur, vous pouvez ajouter cette ligne à la section d'écran du fichier /etc/X11/xorg.conf

.
Option         "ModeDebug" "true"

Vérifiez maintenant votre /var/log/Xorg.0.log file .

Si vous trouvez une erreur comme celle-ci:

NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI

Ensuite, vous pouvez le résoudre en ajoutant cette ligne à la section du périphérique

Option         "IgnoreEDIDChecksum" "DFP"
    
réponse donnée Olav Grønås Gjerde 20.04.2013 - 12:55
la source
3

Appuyez sur Alt + Ctrl + F1 pour accéder à tty1 (terminal), puis lancez ceci:

sudo apt-get --purge remove nvidia*

Cela supprimera tous les packages de pilotes nvidia. Si cela ne fonctionne toujours pas, essayez ceci aussi:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

Cela supprimera un fichier de configuration xorg corrompu s'il existe. Vous devrez redémarrer après avoir terminé ces commandes. (Ctrl + Alt + Suppr)

PS. Si vous avez une carte nvidia optimus, n'installez pas le pilote x-swat ni aucun autre pilote nvidia. Les meilleurs pilotes de travail pour les cartes nvidia optimus proviennent du projet bumblebee .

    
réponse donnée Sepero 15.07.2012 - 17:38
la source
2

Cela m'est arrivé lors de l'exécution d'un processeur AMD: a appris qu'il s'agissait d'un IOMMU / AMD -v Bug = Incompatible avec Nvidia. La désactivation des paramètres du bios de la virtualisation a résolu ce problème.

    
réponse donnée TardisGuy 16.07.2012 - 14:32
la source
1

ce fil sur les forums Ubuntu vous aide-t-il?

En bref, il semble que les packages linux-header de certains noyaux (notamment les noyaux PAE) ne soient pas correctement installés et que la compilation du pilote nvidia échoue silencieusement lors de l'installation des packages nvidia.

    
réponse donnée neutro 13.05.2011 - 19:58
la source
0

Concernant le titre de la rubrique: Quelle est la version actuelle du pilote nvidia restreint utilisée dans Ubuntu natty?

Vous trouverez des informations sur les versions, les versions, les bogues, les fonctionnalités demandées sur le Launchpad . Pour comprendre le sujet, vous pouvez suivre leur visite .

La question sur la dernière version du pilote nVidia se trouve dans le paquet binaire "nvidia-current" dans Ubuntu. Natty i386 . Ainsi, à compter du 2011-04-20, la dernière version est la 270.41.06-0ubuntu1. Mais ce n’est pas nécessairement le recommandé . Le dernier pour moi semble toujours buggy (comme 'déchirer' etc.).

    
réponse donnée Rinzwind 10.05.2011 - 08:33
la source
0

Au lieu d’utiliser nvidia-current, vous devriez vraiment essayer d’utiliser un ancien pilote nvidia, par exemple. le 173.xx. Cela a résolu le problème pour moi. Il suffit de démarrer jockey-gtk et de choisir le pilote 173.xx. Puis redémarrez votre système.

    
réponse donnée Wolf F. 14.05.2011 - 07:11
la source
0

Essayez dans /etc/default/grub :

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXMODE=1680x1050x32

Remplacez "1680x1050x32 | par votre résolution native (pour l'exécuter, exécutez vbeinfo dans la console Grub lors du démarrage).

Puis dans /etc/grub.d/00_header :

set gfxmode=${GRUB_GFXMODE} <-- FIND THIS LINE
set gfxpayload=keep <-- ADD THIS LINE DIRECTLY BENEATH

Mettre à jour le vers:

sudo update-grub

Pourrait fonctionner ...

    
réponse donnée con-f-use 18.05.2011 - 19:16
la source
0

Essayez acpi=off . Cela a résolu mon problème de démarrage dans Ubuntu 11.10, à cause d’un écran vide.

    
réponse donnée VirusC 16.10.2011 - 12:14
la source
0

J'ai aussi un écran vide, mais c'était sur un ordinateur portable avec une carte nVidia optimus 4200m. Optimus ne semble pas être bien pris en charge sur Ubuntu. J'ai dû désactiver Optimus à partir du bios, puis réinstaller le pilote Nividia. Plus d'informations ici si vous souhaitez lire le lien

.     
réponse donnée Kaerax 13.01.2012 - 07:16
la source
0

Je commençais à avoir un écran noir. J'ai une carte graphique NVIDIA 6200. Renommer xorg.config et redémarrer a fonctionné pour moi. Le fichier xorg.config créé par nvidia-xconfig: version 304.51 (buildmeister@swio-display-x86-rhel47-06.nvidia.com) était à l'origine du problème.

    
réponse donnée user155543 04.05.2013 - 17:45
la source
0

Le plus gros problème que j’ai eu à faire était d’avoir un Macbook Pro pour installer les pilotes Nvidia !!!

La solution consiste à remplacer la partition de démarrage principale par REMOVE EFI et à utiliser Legacy MBP.

Ceci est discuté sur quelques pages web mais ce n’est pas si facile à suivre.

lien

En utilisant cette idée, j’ai démarré à partir d’un Live CD puis, avec Gparted, j'ai supprimé la partition de démarrage EFI, je l’ai modifiée d’EFI en FAT32, puis je l’ai reconstruite en tant que boot hérité avec la partition principale avec 13.04 64 bits installée.

lien

--- AVERTISSEMENT Sauvegardez vos données en premier. VOUS POUVEZ VISER TOUT SUR VOTRE DISQUE DUR ---

Insérez un Live CD - Démarrez en essayant Ubuntu Run Gparted - Modifiez la partition de démarrage EFI d’EFI en FAT32.

ouvrez un nouveau terminal, puis tapez:

sudo add-apt-repository ppa: yannubuntu / boot-repair & & sudo apt-get update

  • Appuyez sur Entrée.

  • Puis tapez:

sudo apt-get install -y boot-repair & & (réparation de démarrage et amp;)

Dans la réparation du démarrage, sélectionnez OPTIONS AVANCÉES

.

Décochez la case Utiliser le fichier EFI standard sous les options principales. Décochez Séparer la partition / boot / efi sous GRUB LOCATION

suivez les instructions pour utiliser le chargeur d'amorçage hérité que Boot Repair vous donnera.

Installez et chargez les pilotes NVidia autant de fois que vous le souhaitez

J'ai utilisé la méthode 2 sur cette page lien

Je travaillais dessus probablement pendant 18 heures et j'essayais CHAQUE option. Je veux dire tous les moyens d’installer ces pilotes friggin, et c’était la seule solution qui fonctionne pour le Macbook Pro 7.1 Running 13.04 avec Nvidia_current (nvidia_304)

    
réponse donnée MB- 15.09.2013 - 05:01
la source
0

J'ai tout essayé ici et la solution pour moi était de passer à lightdm, fonctionne parfaitement maintenant!

    
réponse donnée James Heald 28.03.2017 - 16:53
la source
-5

Il suffit d'installer Clear ubuntu ( pas de mises à jour, pas de logiciel ), connectez-vous à Internet, téléchargez votre pilote, installez et redémarrez! Travaillé pour moi! Merci pour mon voisin !!! (c’était son idée)

    
réponse donnée Lukas 02.07.2013 - 09:46
la source

Lire d'autres questions sur les étiquettes