Comment installer emacs 24.3 sur Ubuntu?

35

C'est la première fois que j'utilise Ubuntu et je ne sais pas comment installer un programme dessus. J'ai essayé d'utiliser cd le répertoire où il se trouve, puis de le configurer, mais cela ne fonctionne pas!

    
posée anita 18.05.2013 - 18:26
la source

5 réponses

35

Envisagez d'utiliser le PPA de Damien Cassou :

Pour ajouter ce PPA:

sudo add-apt-repository ppa:cassou/emacs
sudo apt-get update

Pour emacs-snapshot:

sudo apt-get install emacs-snapshot-el emacs-snapshot-gtk emacs-snapshot

Ou , pour emacs24 (c'est-à-dire 24.3, stable):

sudo apt-get install emacs24 emacs24-el emacs24-common-non-dfsg

Mise à jour

Comme mentionné dans le PPA de Damien Cassou , le dépôt ne sera plus maintenu (actuellement, Emacs 24.3) et Il est recommandé d'utiliser le PPA Ubuntu Elisp .

Par conséquent, utilisez ceci pour ajouter le PPA:

sudo add-apt-repository ppa:ubuntu-elisp/ppa
sudo apt-get update
sudo apt-get install emacs-snapshot emacs-snapshot-el

Réf: Guide Emacs

    
réponse donnée hayd 26.10.2013 - 01:44
la source
21

Il serait probablement préférable d’utiliser la version d’emacs déjà construite, testée et intégrée à Ubuntu plutôt que de la créer vous-même, à moins que vous ayez besoin de fonctionnalités spécifiques disponibles uniquement dans la version 24.3.

Dans un terminal:

sudo apt-get install emacs
    
réponse donnée Paul 18.05.2013 - 19:59
la source
2

J'utilise Ubuntu 14 LTS - x64 et la commande suivante fonctionne pour moi ;

sudo apt-get install emacs24

Pour Emacs quotidiens , installez l’installation;

sudo apt-add-repository ppa:ubuntu-elisp/ppa
sudo apt-get update
sudo apt-get install emacs-snapshot emacs-snapshot-el

Référence: Guide Emacs

    
réponse donnée gihanchanuka 09.10.2014 - 06:06
la source
2

Construire à partir de la source n’est pas mauvais car vous pouvez choisir la version dont vous avez besoin et Emacs fonctionnera encore plus vite, le problème est de trouver et d’installer des dépendances.

Commandes pour installer Emacs 24.5 avec / dépendances:

sudo apt-get update
sudo apt-get install build-essential
sudo apt-get build-dep emacs24
cd ~/Downloads
wget "http://gnu.mirrors.hoobly.com/gnu/emacs/emacs-24.5.tar.gz"
tar xvzf emacs-24.*.tar.gz
cd emacs-24.*
./configure --without-x
make
sudo make install

Fait.

    
réponse donnée Delfin 31.03.2016 - 04:43
la source
0

La réponse courte: retournez à Ubuntu 16 ou plus tôt.

Je viens d'installer Ubuntu 18. Les barres de défilement brisées dans emacs 25.2.2 me rendaient fou. Les autres solutions ne fonctionnaient pas ici (apt ne permet plus les repos non signés). J'ai pu installer emacs 23.4 à partir des paquets debian comme suit:

lien

dpkg -i emacs23-common_23.4+1-4+deb7u1_all.deb

lien

dpkg -i emacs23-bin-common_23.4+1-4+deb7u1_amd64.deb

lien

dpkg -i  libgif4_4.1.6-10+deb7u1_amd64.deb

lien

dpkg -i xaw3dg_1.5+E-18.2_amd64.deb

lien

dpkg -i libpng12-0_1.2.49-1+deb7u2_amd64.deb

lien

dpkg -i libtiff4_3.9.6-11+deb7u10_amd64.deb

lien

dpkg -i emacs23-lucid_23.4+1-4+deb7u1_amd64.deb

Je suppose que cette technique fonctionnerait aussi avec emacs 24.3.

Mais vous ne voulez pas Ubuntu 18. Les volumes de gnome cassent tout; Après quelques redémarrages, TOUTES les montages de volumes locaux échouent (même / boot / efi, bien que le matériel ait manifestement fonctionné dans memfs pour atteindre les scripts de montage locaux), et vous devez les monter manuellement dans le shell d'urgence à chaque fois. Revenez à Ubuntu 16, fourni avec emacs 24.

    
réponse donnée personal_cloud 07.05.2018 - 04:52
la source

Lire d'autres questions sur les étiquettes