Le curseur de la souris est invisible après la mise à jour de 15.04

49

Le pointeur de la souris est devenu invisible après quelques mises à jour après la mise à niveau du 15.10 à la version 15.04. Dans tous les paramètres standard, le pointeur de la souris est activé (paramètres système, dconf ...) J'ai également essayé différentes icônes de curseur sans succès.

Le pointeur est parfois visible après l’arrêt et le redémarrage du système. Mais seulement parfois et je n'arrivais pas à comprendre les raisons pour lesquelles cela se manifestait parfois.

J'ai trouvé la solution suivante qui ne fonctionnait pas

gsettings set org.gnome.settings-daemon.plugins.cursor active false

Toute aide appréciée! merci!

    
posée weelux 20.05.2015 - 14:23
la source

26 réponses

45

Ce bug existe toujours pour un système Xubuntu 16.04 utilisant lightdm. Un correctif pour Xubuntu, et éventuellement pour d'autres DE, tel que décrit dans le publication après publication de Xubuntu 16.04, est d'apporter le curseur revient avec Ctrl + Alt + F1 suivi de Ctrl + Alt + F7 .

Cela a fonctionné pour moi, où aucune des autres solutions n’avait sans tout recharger et fermer chaque page.

    
réponse donnée Ulad Kasach 05.05.2016 - 02:59
la source
30

Avoir le même problème après une mise à niveau à 15.04 à partir de 14.10. Parfois, le pointeur de la souris apparaîtra, cela se produit après environ 1 à 5 heures de commutation de l'ordinateur. J'ai trouvé un moyen de contourner cela comme suggéré ci-dessus.

sudo service lightdm restart

Cela doit être émis après chaque démarrage. Est-ce que quelqu'un connaît un correctif à plus long terme?

J'ai maintenant trouvé un correctif à long terme. Passez plutôt à gdm.

sudo apt-get install gdm

Après avoir essayé plusieurs redémarrages, ce correctif semble fonctionner à chaque fois.

:) Je ne sais pas si lightdm donne des avantages sur gdm , mais pour moi, voir le curseur est un grand avantage de GDM sur lightdm.

    
réponse donnée user417467 13.06.2015 - 12:46
la source
14

Un piratage que je fais (ce qui fonctionne étonnamment pour moi) consiste à ouvrir le terminal en appuyant sur Ctrl+Alt+T , puis à taper ls , puis la souris s'affiche en 1 à 2 secondes.

Cela dit, le fonctionnement normal est de redémarrer le pilote de la souris. Cette solution fonctionne également lorsque le pointeur de la souris se comporte mal (comme un vacillement aléatoire). Vous redémarrez le pilote de la souris comme:

sudo modprobe -r psmouse  # disable the driver
sudo modprobe psmouse # enable the mouse driver
    
réponse donnée dopstar 14.11.2015 - 16:18
la source
7

J'ai un problème similaire. Le pointeur de la souris est invisible après le démarrage du système, même sur l'écran LightDM. Pour ramener le curseur, je passe à la console virtuelle (ctrl + alt + f1) et lance la commande:

sudo service lightdm restart

Après le redémarrage de LightDM, ramenez le pointeur de la souris à la normale. J'ai signalé ce bogue à Launchpad .

    
réponse donnée QkiZ 29.05.2015 - 21:32
la source
5

Ouvrez un terminal ctrl + alt + t et tapez sudo apt-get install lightdm --reinstall puis sudo shutdown -r now pour redémarrer. Cela a fonctionné pour moi et je l'ai testé en redémarrant plusieurs fois.

    
réponse donnée Mad Man 23.08.2015 - 04:19
la source
3

Il peut y avoir des problèmes de ce genre si vous avez la technologie nvidia optimus sur votre ordinateur. Essayez d'utiliser un pilote différent (par exemple, pilote d'affichage Noveau) à partir de l'onglet Additional Drivers dans Software & Updates .

    
réponse donnée apex39 20.05.2015 - 14:31
la source
3

Je l'ai corrigé en allant dans les paramètres des affichages (écrire dans la barre de recherche) et en désactivant le " unknown display" . Vous voyez dans les paramètres deux affichages au milieu de l'image dans les paramètres. un autre est inconnu.Choisissez l'inconnu en cliquant dessus sur la photo et appuyez sur le bouton situé à côté de "Affichage inconnu".     

réponse donnée Vinnie Sklep 21.08.2015 - 09:49
la source
2

Depuis cet article sur les forums Ubuntu, l'exécution de cette commande dans un terminal a résolu ce problème.

gsettings set org.gnome.settings-daemon.plugins.cursor active false

Cela fonctionne par intermittence pour moi ... et je ne sais pas encore pourquoi cela fonctionne parfois et pas les autres, mais. peut vous aider aussi.

    
réponse donnée Robbie Capps 01.08.2015 - 07:31
la source
2

Si vous exécutez la commande suivante, vous redémarrez compiz (le gestionnaire de fenêtres et le décorateur), sans perdre votre bureau et en vous déconnectant (comme si redémarrer lightdm):

sudo killall -i -HUP compiz

Cela a ramené mon curseur quand il a disparu, tout en conservant toutes mes fenêtres et mes programmes en cours.

    
réponse donnée chronos00 23.09.2015 - 15:20
la source
1

J'ai aussi eu ce problème, il semble que remplacer gnome-setings-daemon par unity-settings-daemon semble résoudre ce problème.

    
réponse donnée Siphumelelise Ntshwenyese 20.05.2015 - 15:21
la source
1

Avez-vous essayé ceci:

 gsettings set org.settings.daemon-plugins.cursor -KEY=s.cursor -VALUE=false

et cela pourrait bien fonctionner de cette façon.

    
réponse donnée Michael 03.08.2015 - 15:15
la source
1

Il s’agit de un très ancien bogue Unity auquel il est fait référence. remonte à 13.04. Étant donné qu'Unity version 7 arrive en fin de vie, il ne sera probablement jamais réparé. Pendant un certain temps, la déconnexion et la reconnexion permettent de réactiver temporairement le pointeur de la souris, mais cette solution ne le fait plus sur Ubuntu 14.04. La commande gsettings set n'est pas non plus fonctionnelle le 14.04.

Cependant, ce problème peut être résolu sur 14.04 en lançant cette commande:

setsid unity

Cela réinitialisera toutes vos options Unity, le nombre d’espaces de travail, la taille du lanceur, etc. Mais mieux que de ne pas avoir le pointeur de la souris.

    
réponse donnée Luís de Sousa 06.05.2016 - 08:42
la source
1

Ubuntu 16.04 et Gnome Flashback ici. Le curseur de la souris disparaîtrait lors de la connexion. Correction similaire à celle mentionnée ci-dessus. J'ai utilisé "dconf Editor" et recherché "cursor". J'ai trouvé la valeur qui a résolu le problème dans l'emplacement:

org, gnome, desktop, settings-daemon, plugins, curseur, actif

J'ai décoché actif et ma souris revient instantanément et survit au redémarrage.

    
réponse donnée stvee 26.10.2016 - 05:24
la source
0

J'ai résolu ce problème en supprimant mon dossier .config de mon répertoire personnel (~) après avoir remarqué que le problème n'apparaissait que sur un utilisateur. Bien que ce ne soit pas idéal, c'est une solution possible.

    
réponse donnée royalaid 12.08.2015 - 20:47
la source
0

Cette opération a résolu le problème pour certains utilisateurs: installez dconf-editor

sudo apt-get install dconf-editor

et modifiez la taille de l’icône pour la réduire dans les paramètres. Cela semble résoudre les problèmes

    
réponse donnée 5ud0 05.09.2015 - 08:21
la source
0

Voici comment j'ai résolu le problème:

Créez un script shell (yourscript.sh) avec ce code:

#!/bin/bash
service lightdm restart 

en tant que root, déplacez-le dans le dossier /etc/init.d Ensuite, ouvrez le dossier dans le terminal et lancez:

chmod 755 yourscript.sh 

Puis, dans le terminal, entrez cette commande:

ln -s /etc/init.d/yourscript.sh /etc/rc2.d/S99yourscript.sh 

Maintenant, le pointeur de la souris apparaîtra à chaque démarrage et le problème du pointeur de la souris invisible devrait disparaître.

Références:

lien

lien

    
réponse donnée Kyle Barry 18.10.2015 - 13:17
la source
0

J'ai eu le même problème après la mise à niveau vers 16.04. J'ai essayé d'installer gdm comme suggéré par @ user417467 mais cela n'a pas résolu le problème donc je suis revenu à lightdm. J'ai constaté que, après être connecté, je pouvais faire réapparaître le pointeur en appuyant simplement sur crtl+F7 .

    
réponse donnée Abdd 29.04.2016 - 19:02
la source
0

Configuration: Ubuntu 14.04 avec installation par défaut. La connexion automatique est également activée.

Pour moi, je me déconnecte et me reconnecte. À l'écran de connexion, le curseur de la souris revient et reste jusqu'au prochain redémarrage. Fonctionne à chaque fois depuis plus de 50 fois maintenant.

    
réponse donnée user2087035 13.05.2016 - 13:33
la source
0

Je l'ai résolu en branchant un dongle de souris sans fil inutilisé pour que le conducteur reste heureux.

    
réponse donnée TheHackBox 21.05.2016 - 21:05
la source
0

Eh bien, sur Ubuntustudio 16.04, j’ai découvert que si la souris survolait le bouton du menu de l’application et que je commençais à naviguer, cela ne me posait aucun problème!

    
réponse donnée Mike Cherney 02.07.2016 - 10:43
la source
0

J'ai eu le même problème sur XUbuntu 15.10.

Le seul moyen de retrouver le curseur est:

  1. Ctrl + Shift + T (ouvrez le terminal)
  2. sudo apt-get install gnome-screensaver
  3. Ctrl + Shift + L (écran de verrouillage)
  4. ramène le curseur ...
réponse donnée Paolo 07.07.2016 - 17:39
la source
0

J'ai eu un problème similaire le 15.04. À un moment donné, le curseur de la souris a soudainement disparu, mais lorsque je suis passé à un autre espace de travail ( Ctrl + Alt + Flèche ), il est réapparu.

    
réponse donnée Pulsar 17.08.2015 - 06:03
la source
0

Je suis venu ici de Google, car j'ai rencontré le même problème dans Ubuntu 16.04 . La dernière fois que cela s'est produit, j'ai réussi à récupérer la souris en ouvrant simplement un terminal en utilisant ctrl + alt + t .

mieux que d'avoir à redémarrer à chaque fois.

    
réponse donnée r3wt 29.11.2016 - 11:16
la source
0

Même problème lors de la mise à niveau de Lubuntu 14.04 vers Lubuntu 16.04. Le curseur disparaît après la reprise. Ctr - Alt - F1 , Ctr - Alt - F7 résoudre le problème.

    
réponse donnée Quazzar 14.05.2016 - 03:05
la source
0

Les quelques premières réponses ne fonctionnaient pas pour moi, mais j'ai réussi à résoudre mon problème en débranchant et rebranchant ma souris USB.

    
réponse donnée Imran 16.02.2017 - 21:43
la source
-1

Je devais créer un fichier appelé:

20-intel.conf // J'utilise des graphiques intel

place le fichier sur:

/etc/X11/xorg.conf.d /

En utilisant ces lignes:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        Option      "AccelMethod" "uxa"
        Option      "SWCursor" "on"
        BusID       "PCI:0:2:0"
EndSection
    
réponse donnée Adrian 25.05.2016 - 17:52
la source

Lire d'autres questions sur les étiquettes